aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2017-01-17 05:11:08 +0800
committermartymac <martymac@FreeBSD.org>2017-01-17 05:11:08 +0800
commita5127ccd800ad7f697d25d5e71186116d4870c62 (patch)
treea7c5769142829906d07bb7a20a6428fcffd82cd4 /emulators
parent006a9dd7928a4d482533afb2df5c7f598c9d4062 (diff)
downloadfreebsd-ports-gnome-a5127ccd800ad7f697d25d5e71186116d4870c62.tar.gz
freebsd-ports-gnome-a5127ccd800ad7f697d25d5e71186116d4870c62.tar.zst
freebsd-ports-gnome-a5127ccd800ad7f697d25d5e71186116d4870c62.zip
Link to OpenGL libraries earlier to avoid crash with Nvidia's libGL
PR: 215803 Submitted by: Christian Zigotzky <chzigotzky@xenosoft.de>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu/Makefile2
-rw-r--r--emulators/dolphin-emu/files/patch-Source-Core-Common-CMakeLists.txt13
2 files changed, 14 insertions, 1 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index 834c1c18fdcb..5b7104bd7e2a 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dolphin-emu
PORTVERSION= 5.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MAINTAINER= martymac@FreeBSD.org
diff --git a/emulators/dolphin-emu/files/patch-Source-Core-Common-CMakeLists.txt b/emulators/dolphin-emu/files/patch-Source-Core-Common-CMakeLists.txt
new file mode 100644
index 000000000000..f1331a4fdc96
--- /dev/null
+++ b/emulators/dolphin-emu/files/patch-Source-Core-Common-CMakeLists.txt
@@ -0,0 +1,13 @@
+Link to OpenGL libraries earlier to avoid crash with Nvidia's libGL
+
+--- Source/Core/Common/CMakeLists.txt.orig 2016-06-24 08:09:07.000000000 +0000
++++ Source/Core/Common/CMakeLists.txt 2017-01-12 20:59:59.578506000 +0000
+@@ -88,7 +88,7 @@
+ set(SRCS ${SRCS} GL/GLInterface/GLX.cpp)
+ # GLX has a hard dependency on libGL.
+ # Make sure to link to it if using GLX.
+- set(LIBS ${LIBS} ${OPENGL_LIBRARIES})
++ set(LIBS ${OPENGL_LIBRARIES} ${LIBS})
+ endif()
+ set(SRCS ${SRCS} GL/GLInterface/X11_Util.cpp)
+ set(LIBS ${LIBS} ${XRANDR_LIBRARIES})