aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2003-04-14 09:52:50 +0800
committerobrien <obrien@FreeBSD.org>2003-04-14 09:52:50 +0800
commitaa1b50a749a7ab8627e5b0e86cb199c573d43d04 (patch)
tree79820ada957f780b850369464317182eadc477a0 /emulators
parentf9ae2c99e50954477ad44cd1745f740541273ff8 (diff)
downloadfreebsd-ports-gnome-aa1b50a749a7ab8627e5b0e86cb199c573d43d04.tar.gz
freebsd-ports-gnome-aa1b50a749a7ab8627e5b0e86cb199c573d43d04.tar.zst
freebsd-ports-gnome-aa1b50a749a7ab8627e5b0e86cb199c573d43d04.zip
Add support for configuring for a AMD64.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index adfc8fc21043..6ccc715f37cd 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -56,6 +56,10 @@ WITH_BOCHS_CPU_LEVEL= 6
CONFIGURE_ARGS+= --enable-cpu-level=${WITH_BOCHS_CPU_LEVEL}
.endif
+.if defined(WITH_BOCHS_AMD64)
+CONFIGURE_ARGS+= --enable-x86-64
+.endif
+
.if defined(WITH_BOCHS_DEBUGGER)
CONFIGURE_ARGS+= --enable-debugger --enable-disasm
.endif
@@ -112,6 +116,11 @@ pre-everything::
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_X86_DEBUGGER=yes\""
@${ECHO_MSG}
.endif
+.if !defined(WITH_BOCHS_AMD64)
+ @${ECHO_MSG} "If you want to compile with AMD x86-64 support."
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_AMD64=yes\""
+ @${ECHO_MSG}
+.endif
.if !defined(WITH_NE2000)
@${ECHO_MSG} "If you want to compile with networking (ne2000) support."
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_NE2000=yes\""