aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2016-04-30 04:15:36 +0800
committerjkim <jkim@FreeBSD.org>2016-04-30 04:15:36 +0800
commitab2ec4830774b2822203a2523add5d629e5dea73 (patch)
tree710c82b28af9c9cfdee8ebe9f9b16906627028ea /emulators
parent3872e42b1879e9b378e9e39de26d6e88fb29cecb (diff)
downloadfreebsd-ports-gnome-ab2ec4830774b2822203a2523add5d629e5dea73.tar.gz
freebsd-ports-gnome-ab2ec4830774b2822203a2523add5d629e5dea73.tar.zst
freebsd-ports-gnome-ab2ec4830774b2822203a2523add5d629e5dea73.zip
Add upstream patches to build with recent iASL on head.
https://www.virtualbox.org/changeset/58415 https://www.virtualbox.org/changeset/60582 https://www.virtualbox.org/changeset/60616
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose/files/patch-src_VBox_Devices_Makefile.kmk18
-rw-r--r--emulators/virtualbox-ose/files/patch-src_VBox_Devices_PC_vbox-cpuhotplug.dsl64
2 files changed, 82 insertions, 0 deletions
diff --git a/emulators/virtualbox-ose/files/patch-src_VBox_Devices_Makefile.kmk b/emulators/virtualbox-ose/files/patch-src_VBox_Devices_Makefile.kmk
new file mode 100644
index 000000000000..01c9ee03b3c7
--- /dev/null
+++ b/emulators/virtualbox-ose/files/patch-src_VBox_Devices_Makefile.kmk
@@ -0,0 +1,18 @@
+--- src/VBox/Devices/Makefile.kmk.orig 2016-04-20 10:01:06 UTC
++++ src/VBox/Devices/Makefile.kmk
+@@ -801,11 +801,13 @@ if !defined(VBOX_ONLY_EXTPACKS)
+ $(call MSG_TOOL,iasl,VBoxDD,$<,$@)
+ $(QUIET)$(RM) -f $@ $@.tmp $@.pre
+ $(QUIET)$(TOOL_$(VBOX_GCC_TOOL)_CC) -E -P -x c -o $@.pre $<
+- $(QUIET)$(VBOX_IASLCMD) -tc -vs -p $@ $@.pre
++ $(QUIET)$(SED) "s/<NL>/\n/g" \
++ --output $@.pre1 $@.pre
++ $(QUIET)$(VBOX_IASLCMD) -tc -vs -p $@ $@.pre1
+ $(QUIET)$(MV) -f $@ $@.tmp
+ $(QUIET)$(SED) "s/AmlCode/AmlCodeSsdtCpuHotPlug/g" \
+ --output $@ $@.tmp
+- $(QUIET)$(RM) -f $@.tmp $@.pre
++ $(QUIET)$(RM) -f $@.tmp $@.pre $@.pre1
+
+
+ vboxssdt-cpuhotplug.hex:: $$(VBoxDD_0_OUTDIR)/vboxssdt-cpuhotplug.hex
diff --git a/emulators/virtualbox-ose/files/patch-src_VBox_Devices_PC_vbox-cpuhotplug.dsl b/emulators/virtualbox-ose/files/patch-src_VBox_Devices_PC_vbox-cpuhotplug.dsl
new file mode 100644
index 000000000000..310328af4177
--- /dev/null
+++ b/emulators/virtualbox-ose/files/patch-src_VBox_Devices_PC_vbox-cpuhotplug.dsl
@@ -0,0 +1,64 @@
+--- src/VBox/Devices/PC/vbox-cpuhotplug.dsl.orig 2016-04-20 10:01:38 UTC
++++ src/VBox/Devices/PC/vbox-cpuhotplug.dsl
+@@ -27,16 +27,28 @@ DefinitionBlock ("SSDT-cpuhotplug.aml",
+ Return(LEqual(CPUL, 0x01))
+ }
+
++ // Method to notify the VMM that a CPU is not
++ // in use anymore and can be safely removed.
++ // Using the extra method here because the CPUL
++ // register identifer clashes with the CPUL object defined
++ // below making iasl starting with version 20150930 fail.
++ //
++ // Think of CPLO as "CPU Lock Open"
++ Method(CPLO, 1)
++ {
++ Store(Arg0, CPUL)
++ }
++
+ Scope (\_SB)
+ {
+
+-#define GENERATE_CPU_OBJECT(id, sck, sckuid, cpu, cpuuid) \
++#define GENERATE_CPU_OBJECT(id, sck, sckuid, cpu, cpuuid)<NL> \
+ Device (sck) \
+ { \
+ Name (_HID, "ACPI0004") \
+ Name (_UID, sckuid) \
+ \
+- \
++ <NL> \
+ Processor (cpu, /* Name */ \
+ id, /* Id */ \
+ 0x0, /* Processor IO ports range start */ \
+@@ -46,8 +58,8 @@ DefinitionBlock ("SSDT-cpuhotplug.aml",
+ Name (_HID, "ACPI0007") \
+ Name (_UID, cpuuid) \
+ Name (_PXM, 0x00) \
+- \
+- Method(_MAT, 0) \
++ <NL> \
++ Method(_MAT, 0, Serialized) \
+ { \
+ Name (APIC, Buffer (8) {0x00, 0x08, id, id}) \
+ IF (CPCK(id)) \
+@@ -60,6 +72,7 @@ DefinitionBlock ("SSDT-cpuhotplug.aml",
+ } \
+ Return (APIC) \
+ } \
++ <NL> \
+ Method(_STA) /* Used for device presence detection */ \
+ { \
+ IF (CPCK(id)) \
+@@ -71,9 +84,10 @@ DefinitionBlock ("SSDT-cpuhotplug.aml",
+ Return (0x0) \
+ } \
+ } \
++ <NL> \
+ Method(_EJ0, 1) \
+ { \
+- Store(id, CPUL) /* Unlock the CPU */ \
++ CPLO(id) /* Unlock the CPU */ \
+ Return \
+ } \
+ } \