aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormatusita <matusita@FreeBSD.org>2003-04-19 15:14:17 +0800
committermatusita <matusita@FreeBSD.org>2003-04-19 15:14:17 +0800
commit2bd883adc1fa26e582b70c705130a46b920adc39 (patch)
tree28ca6b2102ce9b6a2b9f6e2aadd390fd394bf269 /emulators
parent5ee6da0bde10b7ad89790cacdbc5cbd15e40dfc4 (diff)
downloadfreebsd-ports-gnome-2bd883adc1fa26e582b70c705130a46b920adc39.tar.gz
freebsd-ports-gnome-2bd883adc1fa26e582b70c705130a46b920adc39.tar.zst
freebsd-ports-gnome-2bd883adc1fa26e582b70c705130a46b920adc39.zip
Cosmetic fixes for old VMware guest tools to sync with the latest one.
* Update pkg-descr to point a new ports location. * Update RUN_DEPENDS to point a new ports location. * Sync COMMENT message to all versions. * Use INSTALL_PROGRAM instead of CP since it installs a program. * Wrap interactive-related script with .if !defined(BATCH) appropriately. * Unhide UMOUNT command and users will know what's happened.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux-vmware-toolbox2/Makefile16
-rw-r--r--emulators/vmware-guestd3/Makefile3
-rw-r--r--emulators/vmware-tools2/Makefile2
-rw-r--r--emulators/vmware-tools2/pkg-descr2
-rw-r--r--emulators/vmware-tools2/pkg-message2
-rw-r--r--emulators/vmware-tools3/Makefile7
-rw-r--r--emulators/vmware-tools3/pkg-descr2
7 files changed, 23 insertions, 11 deletions
diff --git a/emulators/linux-vmware-toolbox2/Makefile b/emulators/linux-vmware-toolbox2/Makefile
index ee82e72ab6a9..6c1d2a63dbc5 100644
--- a/emulators/linux-vmware-toolbox2/Makefile
+++ b/emulators/linux-vmware-toolbox2/Makefile
@@ -13,13 +13,15 @@ PKGNAMEPREFIX= linux-
DISTNAME= vmware-linux-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware toolbox for FreeBSD Guest OS (full-featured Linux version)
+COMMENT=VMware toolbox for guest OS (for VMware 2.x, Linux version)
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+.if !defined(BATCH)
IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
@@ -40,6 +42,8 @@ MOUNT_DEV?= vn0
.else
MOUNT_DEV?= fd0
.endif
+STRIP=
+
VMWARE_VER= 2.0.4
BUILD_VER= 1142
@@ -58,6 +62,7 @@ pre-fetch:
@${ECHO} "========================================================================"
@${ECHO} ""
@${ECHO} -n "Are ready to install this ports? [Y/n]: "
+.if !defined(BATCH)
@(read line; \
case "$${line}" in \
[Nn]*) \
@@ -66,16 +71,17 @@ pre-fetch:
${TRUE} ;; \
esac)
.endif
+.endif
do-fetch:
.if exists("${DISTDIR}/${DISTFILES}")
@${ECHO} "Found ${DISTDIR}/${DISTFILES}."
.else
${MKDIR} ${MOUNT_PT}
- -@${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
- -@${UMOUNT} /dev/${MOUNT_DEV} 2>&1 >/dev/null
+ -${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
+ -${UMOUNT} /dev/${MOUNT_DEV} 2>&1 >/dev/null
.if exists(${LINUX_FLP})
- -@${DEV_DETACH} 2>&1 >/dev/null
+ -${DEV_DETACH} 2>&1 >/dev/null
${DEV_ATTACH}
.endif
${MOUNT} -t msdos -r /dev/${MOUNT_DEV} ${MOUNT_PT}
@@ -87,6 +93,6 @@ do-fetch:
.endif
do-install:
- ${CP} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
+ ${INSTALL_PROGRAM} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
.include <bsd.port.post.mk>
diff --git a/emulators/vmware-guestd3/Makefile b/emulators/vmware-guestd3/Makefile
index 52ebdd20fc23..394dd9e0d911 100644
--- a/emulators/vmware-guestd3/Makefile
+++ b/emulators/vmware-guestd3/Makefile
@@ -22,6 +22,9 @@ WRKSRC= ${WRKDIR}/vmware-freebsd-tools
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
+.if !defined(BATCH)
+IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
diff --git a/emulators/vmware-tools2/Makefile b/emulators/vmware-tools2/Makefile
index ee1d7021c98b..d4cc0eaa9df8 100644
--- a/emulators/vmware-tools2/Makefile
+++ b/emulators/vmware-tools2/Makefile
@@ -16,7 +16,7 @@ MASTER_SITES= http://vmware-svca.www.conxion.com/software/ \
DISTNAME= tools-for-freebsd-${BUILD_VER}
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware tools for FreeBSD guest OS (for VMware 2.x)
+COMMENT=VMware tools for guest OS (for VMware 2.x, FreeBSD version)
WRKSRC= ${WRKDIR}/vmware-freebsd-tools
diff --git a/emulators/vmware-tools2/pkg-descr b/emulators/vmware-tools2/pkg-descr
index 6ccd281f4a21..2c11f4f3e02b 100644
--- a/emulators/vmware-tools2/pkg-descr
+++ b/emulators/vmware-tools2/pkg-descr
@@ -9,6 +9,6 @@ Linux has, and dual-boot configulation is broken because checkvm
doesn't work.
So this port installs X server ONLY. If you want vmware-toolbox,
-install emulators/linux-vmware-toolbox on your FreeBSD _Guest_ OS.
+install ports/emulators/linux-vmware-toolbox2 on your FreeBSD _Guest_ OS.
WWW: http://www.vmware.com/download/downloadtools.html
diff --git a/emulators/vmware-tools2/pkg-message b/emulators/vmware-tools2/pkg-message
index 57a109cb8812..b067e3ceb4e2 100644
--- a/emulators/vmware-tools2/pkg-message
+++ b/emulators/vmware-tools2/pkg-message
@@ -2,4 +2,4 @@ XFree86 configulation file is in ${PREFIX}/etc/XF86Config_VMware.
Copy this file to /etc/XF86Config before starting X.
This package does not contain vmware-toolbox. You need to install
-emulators/linux-vmware-toolbox if you want it.
+ports/emulators/linux-vmware-toolbox2 if you want it.
diff --git a/emulators/vmware-tools3/Makefile b/emulators/vmware-tools3/Makefile
index 065972ce96de..531755196a5b 100644
--- a/emulators/vmware-tools3/Makefile
+++ b/emulators/vmware-tools3/Makefile
@@ -12,10 +12,10 @@ MASTER_SITES= # none
DISTNAME= vmware-freebsd-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware tools for FreeBSD guest OS (for VMware 3.x)
+COMMENT=VMware tools for guest OS (for VMware 3.x, FreeBSD version)
LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
-RUN_DEPENDS= ${LOCALBASE}/sbin/vmware-guestd:${PORTSDIR}/emulators/vmware-guestd
+RUN_DEPENDS= ${LOCALBASE}/sbin/vmware-guestd:${PORTSDIR}/emulators/vmware-guestd3
DISTDIR= ${MOUNT_PT}
IGNOREFILES= ${DISTFILES}
@@ -24,6 +24,9 @@ WRKSRC= ${WRKDIR}/vmware-freebsd-tools
ONLY_FOR_ARCHS= i386
USE_X_PREFIX= yes
NO_BUILD= yes
+.if !defined(BATCH)
+IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
diff --git a/emulators/vmware-tools3/pkg-descr b/emulators/vmware-tools3/pkg-descr
index e8deec969f96..07e884cac2bd 100644
--- a/emulators/vmware-tools3/pkg-descr
+++ b/emulators/vmware-tools3/pkg-descr
@@ -11,6 +11,6 @@ This ports will install vmware-toolbox to your computer, and
XFree86 X server if you set XFREE86_VERSION to 3 in /etc/make.conf,
If you already use XFree86 4.1.0 or later, you may use 'vmware'
driver for X server. Vmware-guestd is installed as a separate port,
-ports/emulators/vmware-guestd, but this port install guestd automatically.
+ports/emulators/vmware-guestd3, but this port install guestd automatically.
WWW: http://www.vmware.com/products/desktop/ws_features.html