aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /emulators
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vice/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index c538374ebfb2..87d6e0dae18b 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -17,8 +17,7 @@ COMMENT= Emulator for Commodore C64, C128, VIC20, PET, and CBM-II
BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
- pkg-config:${PORTSDIR}/devel/pkg-config
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
gif:${PORTSDIR}/graphics/giflib \
mp3lame:${PORTSDIR}/audio/lame
@@ -32,6 +31,7 @@ LICENSE= GPLv2
USE_XORG= xpm ice sm xext xv xt x11 xmu
USE_XORG+= xrender xinerama xi xrandr xcursor xcomposite xdamage xfixes
USE_GMAKE= yes
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
MAKE_ENV+= MAKEINFOFLAGS="--no-split"
@@ -55,8 +55,6 @@ USE_XORG+= xaw
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
-PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
-CONFIGURE_ENV+= PKG_CONFIG="${LOCALBASE}/bin/pkg-config"
CONFIGURE_ARGS+= --enable-fullscreen --enable-ipv6 --disable-dependency-tracking
MAN1= vice.1 c1541.1 petcat.1
MLINKS= vice.1 x64.1 \