aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2014-02-17 00:11:44 +0800
committerrene <rene@FreeBSD.org>2014-02-17 00:11:44 +0800
commit8c54cb93e0b52c15d17651ad3c48802faaca8b3d (patch)
tree2802a44a4cfb3a443208e11a58991a558919c0e5 /emulators
parent085c47a2774122629a009979b32ef7fc32e0acb6 (diff)
downloadfreebsd-ports-gnome-8c54cb93e0b52c15d17651ad3c48802faaca8b3d.tar.gz
freebsd-ports-gnome-8c54cb93e0b52c15d17651ad3c48802faaca8b3d.tar.zst
freebsd-ports-gnome-8c54cb93e0b52c15d17651ad3c48802faaca8b3d.zip
emulators/fuse-utils: Use option helpers to reduce makefile inclusions.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fuse-utils/Makefile24
1 files changed, 6 insertions, 18 deletions
diff --git a/emulators/fuse-utils/Makefile b/emulators/fuse-utils/Makefile
index 3e9f46d4e10e..eea2b5b24eba 100644
--- a/emulators/fuse-utils/Makefile
+++ b/emulators/fuse-utils/Makefile
@@ -25,29 +25,17 @@ OPTIONS_DEFAULT= AUDIOTOOLS
AUDIOTOOLS_DESC= Build audio <-> tape utilities
-.include <bsd.port.options.mk>
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MAUDIOTOOLS}
-CONFIGURE_ARGS+=--with-audiofile
-LIB_DEPENDS+= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
-PLIST_SUB= AUDIOTOOLS=""
-.else
-CONFIGURE_ARGS+=--without-audiofile
-PLIST_SUB= AUDIOTOOLS="@comment "
-.endif
+AUDIOTOOLS_CONFIGURE_WITH= audiofile
+AUDIOTOOLS_LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
# FIXME no way to specify ffmpeg1 paths to configure script
-#.if ${PORT_OPTIONS:MFFMPEG}
-#LIB_DEPENDS+= libavformat1.so:${PORTSDIR}/multimedia/ffmpeg1
-#CONFIGURE_ARGS+=--with-ffmpeg
-#.else
-CONFIGURE_ARGS+=--without-ffmpeg
-#.endif
+#FFMPEG_LIB_DEPENDS= libavformat1.so:${PORTSDIR}/multimedia/ffmpeg1
+#FFMPEG_CONFIGURE_WITH= ffmpeg
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS ChangeLog README ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>