aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2011-12-21 07:48:21 +0800
committeracm <acm@FreeBSD.org>2011-12-21 07:48:21 +0800
commite9ec5e44b6a17455b8c4eb722fca1ed21f9eb684 (patch)
tree9101724f9898780e8fbf693a3359d0ab51da9edb /emulators
parentdcaa32fc853583873b17df622d16c315713be772 (diff)
downloadfreebsd-ports-gnome-e9ec5e44b6a17455b8c4eb722fca1ed21f9eb684.tar.gz
freebsd-ports-gnome-e9ec5e44b6a17455b8c4eb722fca1ed21f9eb684.tar.zst
freebsd-ports-gnome-e9ec5e44b6a17455b8c4eb722fca1ed21f9eb684.zip
- New port: emulators/mupen64plus-video-arachnoid
The arachnoid video plugin for Mupen64plus
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-video-arachnoid/Makefile30
2 files changed, 31 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index d3867656c9ff..a7ee257d2f3b 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -115,6 +115,7 @@
SUBDIR += mupen64plus-rsp-hle
SUBDIR += mupen64plus-rsp-z64
SUBDIR += mupen64plus-ui-console
+ SUBDIR += mupen64plus-video-arachnoid
SUBDIR += mupen64plus-video-rice
SUBDIR += nonpareil
SUBDIR += o2em
diff --git a/emulators/mupen64plus-video-arachnoid/Makefile b/emulators/mupen64plus-video-arachnoid/Makefile
new file mode 100644
index 000000000000..e0e050ea496a
--- /dev/null
+++ b/emulators/mupen64plus-video-arachnoid/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mupen64plus-video-arachnoid
+# Date created: 2011-12-20
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -video-arachnoid
+DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}${EXTRACT_SUFX}:plugin
+
+COMMENT= The arachnoid video plugin for Mupen64plus
+
+LIB_DEPENDS= mupen64plus.2:${PORTSDIR}/emulators/mupen64plus-core
+
+USE_GL= gl glu
+USE_SDL= #
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-core
+
+OPTIONS= #
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
+WRKSRC= ${WRKDIR}
+
+.include "${MASTERDIR}/Makefile"