aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-05-10 21:09:48 +0800
committermakc <makc@FreeBSD.org>2010-05-10 21:09:48 +0800
commitff982856872b8ea18185706edbcf515c0f04964e (patch)
treecc8c90fe091ead9b7b11f4833b62e6ceffbd3e09 /emulators
parent007cf79c0a849157f015e25c0fa0e9b7c89a892c (diff)
downloadfreebsd-ports-gnome-ff982856872b8ea18185706edbcf515c0f04964e.tar.gz
freebsd-ports-gnome-ff982856872b8ea18185706edbcf515c0f04964e.tar.zst
freebsd-ports-gnome-ff982856872b8ea18185706edbcf515c0f04964e.zip
Get rid of USE_GCC=3.4
PR: ports/144766 Submitted by: Andrius Morkunas <hinokind at gmail.com>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mupen64-rice/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/emulators/mupen64-rice/Makefile b/emulators/mupen64-rice/Makefile
index c6c493184e90..ffba6935c2f9 100644
--- a/emulators/mupen64-rice/Makefile
+++ b/emulators/mupen64-rice/Makefile
@@ -23,7 +23,6 @@ USE_GMAKE= yes
USE_SDL= sdl
USE_GL= gl
USE_GNOME= gtk12
-USE_GCC= 3.4
ONLY_FOR_ARCHS= i386
PLUGIN_NAME= ricedaedalus
@@ -34,6 +33,12 @@ PLIST_DIRS+= share/mupen64
FIXME2= glh_genext.h
+post-patch:
+ @${REINPLACE_CMD} -e 's|CDaedalusRender::IsTextureEnabled|IsTextureEnabled|' \
+ ${WRKSRC}/DaedalusRender.h
+ @${REINPLACE_CMD} -e 's|^HRESULT|template<> HRESULT|' \
+ ${WRKSRC}/Profiler.cpp
+
do-configure:
.for i in ${FIXME2}
${REINPLACE_CMD} -e 's|SDL/SDL.h|SDL.h|' ${WRKSRC}/${i}