aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-01-03 19:01:05 +0800
committermat <mat@FreeBSD.org>2017-01-03 19:01:05 +0800
commit057971c152a484648da5936e2abf430699f07815 (patch)
tree4258e0d342beadc5ca18094ba5ce084e678b753d /emulators
parentc743bcc36550fe214c3826e524078d4459e8cb90 (diff)
downloadfreebsd-ports-gnome-057971c152a484648da5936e2abf430699f07815.tar.gz
freebsd-ports-gnome-057971c152a484648da5936e2abf430699f07815.tar.zst
freebsd-ports-gnome-057971c152a484648da5936e2abf430699f07815.zip
Cleanup BROKEN/IGNORE for 10.3-
Sponsored by: Absolight
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile10
-rw-r--r--emulators/gem5/Makefile4
-rw-r--r--emulators/pearpc/Makefile4
-rw-r--r--emulators/x49gp/Makefile11
4 files changed, 6 insertions, 23 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 7a0018a68168..fd1cdd7c61b2 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -12,6 +12,8 @@ COMMENT= IA-32 (x86) PC emulator that runs DOS, Win 95, and more
LICENSE= LGPL21
+BROKEN_i386= does not build on i386 (../cpu.h:4513:117: error: 'regparm' parameter must be between 0 and 3 inclusive)
+
USES= gmake libtool:keepla pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_alsa_asoundlib_h=no \
@@ -290,10 +292,4 @@ post-install-DOCS-on:
(cd ${WRKSRC}/docs-html && ${INSTALL_DATA} *.html \
${STAGEDIR}${DOCSDIR}/html)
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && ${ARCH} == i386
-BROKEN= does not build on i386 (../cpu.h:4513:117: error: 'regparm' parameter must be between 0 and 3 inclusive)
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/gem5/Makefile b/emulators/gem5/Makefile
index 4c032be03739..41eb3911f4d1 100644
--- a/emulators/gem5/Makefile
+++ b/emulators/gem5/Makefile
@@ -23,10 +23,6 @@ USES= gmake
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-IGNORE= does not support FreeBSD versions < 10.0
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|sys/termios.h|termios.h|' \
${WRKSRC}/src/base/vnc/vncserver.cc \
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 27fc18b3c591..151284140e68 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -38,10 +38,6 @@ USE_GCC= yes
CONFIGURE_ARGS+= --enable-cpu=generic
.endif
-.if ${ARCH} == "amd64" && ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-BROKEN= does not build on FreeBSD < 10.x amd64
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|-O3|| ; \
diff --git a/emulators/x49gp/Makefile b/emulators/x49gp/Makefile
index 7c0d10bd0a9c..bd5b75524375 100644
--- a/emulators/x49gp/Makefile
+++ b/emulators/x49gp/Makefile
@@ -9,11 +9,12 @@ PORTREVISION= 1
CATEGORIES= emulators math
MASTER_SITES= LOCAL/shaun
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} sdcard64.tar.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= shaun@FreeBSD.org
COMMENT= HP 49g+/50g graphics calculator emulator
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+BROKEN_i386= does not build on i386 (error: frame pointer required, but reserved)
WRKSRC= ${WRKDIR}/x49gp/x49gp-code
HAVE_CONFIGURE= yes
@@ -95,10 +96,4 @@ do-install:
${INSTALL_DATA} ${DISTDIR}/sdcard64.tar.gz ${STAGEDIR}${DATADIR}/
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && ${ARCH} == i386
-BROKEN= does not build on i386 (error: frame pointer required, but reserved)
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>