aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /emulators
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/ines/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/emulators/ines/Makefile b/emulators/ines/Makefile
index 92e061df244c..3f1fd55bbd0a 100644
--- a/emulators/ines/Makefile
+++ b/emulators/ines/Makefile
@@ -3,7 +3,7 @@
# Date created: 02 November 1996
# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
#
-# $Id: Makefile,v 1.8 1998/10/13 03:43:37 jseger Exp $
+# $Id: Makefile,v 1.9 1998/10/13 04:01:21 jseger Exp $
#
DISTNAME= iNES07-FreeBSD-80x86-bin
@@ -18,6 +18,12 @@ WRKSRC= ${WRKDIR}/NES
USE_X_PREFIX= yes
NO_BUILD= yes
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+STRIP=
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ines ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/ines-debug ${PREFIX}/bin
@@ -26,8 +32,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/headers.tgz ${PREFIX}/share/ines
@${INSTALL_DATA} ${WRKSRC}/CART.* ${PREFIX}/share/ines
-.include <bsd.port.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-STRIP=
-.endif
+.include <bsd.port.post.mk>