aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-05 07:24:55 +0800
committerbapt <bapt@FreeBSD.org>2013-09-05 07:24:55 +0800
commit780fc255f4fb946eb4d78f50c473087fc2a9651b (patch)
tree657a490f7411f63ff2e0cba9578de15d44c8394b /emulators
parent2e266a80c11d835510c388ad1aed8373762f5a8c (diff)
downloadfreebsd-ports-gnome-780fc255f4fb946eb4d78f50c473087fc2a9651b.tar.gz
freebsd-ports-gnome-780fc255f4fb946eb4d78f50c473087fc2a9651b.tar.zst
freebsd-ports-gnome-780fc255f4fb946eb4d78f50c473087fc2a9651b.zip
Fix build with clang
Submitted by: dim
Diffstat (limited to 'emulators')
-rw-r--r--emulators/xmame/Makefile9
-rw-r--r--emulators/xmame/files/patch-src-unix-osinline.h11
2 files changed, 13 insertions, 7 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 0a9d2c40510e..59001e96d604 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmame
-# Date created: 4 Sep 1999
-# Whom: Donald Burr <dburr@FreeBSD.org>
-#
+# Created by: Donald Burr <dburr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME?= xmame
PORTVERSION?= 0.106
@@ -24,9 +20,8 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
NO_CDROM= License does not permit selling
USES= perl5 gmake
-USE_GCC= any
USE_BZIP2= yes
-MAKE_ARGS+= CC=${CC} ARCH=freebsd
+MAKE_ARGS+= CC="${CC}" ARCH=freebsd
WANT_SDL= yes
WANT_GNOME= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/emulators/xmame/files/patch-src-unix-osinline.h b/emulators/xmame/files/patch-src-unix-osinline.h
new file mode 100644
index 000000000000..09410545a2f0
--- /dev/null
+++ b/emulators/xmame/files/patch-src-unix-osinline.h
@@ -0,0 +1,11 @@
+--- src/unix/osinline.h.orig 2006-05-15 18:47:35.000000000 +0200
++++ src/unix/osinline.h 2013-08-28 11:04:54.000000000 +0200
+@@ -32,7 +32,7 @@ INLINE int _vec_mult(int x, int y)
+ : "=&a" (result) /* the result has to go in eax */
+ : "mr" (x), /* x and y can be regs or mem */
+ "mr" (y)
+- : "%edx", "%cc" /* clobbers edx and flags */
++ : "%edx", "cc" /* clobbers edx and flags */
+ );
+ return result;
+ }