aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-10-19 21:05:21 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-10-19 21:05:21 +0800
commit8c7679ac3155b74dfb07a8643b17b1b160a09da6 (patch)
tree481b299f32509b14747aa501264a4a3beb0e861d /emulators
parent3a28f7dc1af28aef1c54ca2c541731df733fc819 (diff)
downloadfreebsd-ports-gnome-8c7679ac3155b74dfb07a8643b17b1b160a09da6.tar.gz
freebsd-ports-gnome-8c7679ac3155b74dfb07a8643b17b1b160a09da6.tar.zst
freebsd-ports-gnome-8c7679ac3155b74dfb07a8643b17b1b160a09da6.zip
Update to 0.9.96
PR: 161649 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/osmose/Makefile42
-rw-r--r--emulators/osmose/distinfo4
-rw-r--r--emulators/osmose/files/patch-Makefile54
-rw-r--r--emulators/osmose/files/patch-PrecisionTimer.h10
-rw-r--r--emulators/osmose/files/patch-TvVideoFilter.h11
-rw-r--r--emulators/osmose/files/patch-unzip-Makefile8
-rw-r--r--emulators/osmose/files/patch-zlib-Makefile12
-rw-r--r--emulators/osmose/pkg-descr7
8 files changed, 24 insertions, 124 deletions
diff --git a/emulators/osmose/Makefile b/emulators/osmose/Makefile
index 7dc57231fc62..a2f8966aa4ce 100644
--- a/emulators/osmose/Makefile
+++ b/emulators/osmose/Makefile
@@ -6,42 +6,40 @@
#
PORTNAME= osmose
-PORTVERSION= 0.6.30
-PORTREVISION= 3
+PORTVERSION= 0.9.96
CATEGORIES= emulators
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= pav
-DISTNAME= ${PORTNAME}-final-src
+MASTER_SITES= http://bcz.asterope.fr/osmose/
+DISTNAME= Osmose-${PORTVERSION:S/./-/g}-QT
MAINTAINER= ports@FreeBSD.org
COMMENT= Sega Master System emulator
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+LICENSE= GPLv3
-ONLY_FOR_ARCHS= i386
-ONLY_FOR_ARCHS_REASON= uses i386 assembly code
-USE_DOS2UNIX= yes
-USE_ZIP= yes
-USE_GMAKE= yes
-USE_SDL= sdl
-NO_WRKSUBDIR= yes
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/joystick.h:${PORTSDIR}/devel/linux-js
+LIB_DEPENDS= asound.2:${PORTSDIR}/audio/alsa-lib
+RUN_DEPENDS= ${LOCALBASE}/include/linux/joystick.h:${PORTSDIR}/devel/linux-js
-OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+USE_ZIP= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui opengl moc_build qmake_build uic_build
+QMAKEFLAGS+= TARGET=release
-PLIST_FILES= bin/osmose
-PORTDOCS= readme.txt
+PORTDOCS= Readme.txt TODO.txt
+PLIST_FILES= bin/${PORTNAME}
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
-MAKE_ENV+= OPTIMIZED_CFLAGS=yes
-.endif
+do-configure:
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.post.mk>
diff --git a/emulators/osmose/distinfo b/emulators/osmose/distinfo
index 691a5dcee634..c5b02d876a85 100644
--- a/emulators/osmose/distinfo
+++ b/emulators/osmose/distinfo
@@ -1,2 +1,2 @@
-SHA256 (osmose-final-src.zip) = 1e0b0efe772fe10a3648e6878e7e495c8b9466fab1f8bf6864e80b7fb9b6d112
-SIZE (osmose-final-src.zip) = 297235
+SHA256 (Osmose-0-9-96-QT.zip) = aca1d1b6b01d1e0efefd7e42eca9bc332d043869a934863321d3925267ca8d79
+SIZE (Osmose-0-9-96-QT.zip) = 194671
diff --git a/emulators/osmose/files/patch-Makefile b/emulators/osmose/files/patch-Makefile
deleted file mode 100644
index 991022705684..000000000000
--- a/emulators/osmose/files/patch-Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
---- Makefile.orig Sat Apr 7 20:42:59 2007
-+++ Makefile Sat Apr 7 20:44:04 2007
-@@ -43,21 +43,25 @@
-
- # Compiler/Linker Flags
- # add -O3 to CFLAGS for speedup -pg on LFLAGS and CFLAGS for gprof
--CFLAGS = -Wall -O3
--LFLAGS = -lSDL
-+CFLAGS += -Dlinux `sdl-config --cflags`
-+
-+ifdef OPTIMIZED_CFLAGS
-+CFLAGS += -O3
-+endif
-+
-+LFLAGS = $(LDFLAGS) `sdl-config --libs`
- AFLAGS = -f elf
--CC = g++
--C_COMP = gcc
-+CXX ?= g++
- ASM = nasm
-
- # Our needed rules. $* is current file, without suffix.
- .SUFFIXES: .cxx .o
- .cxx.o:
-- $(CC) $(CFLAGS) -c $*.cxx -o $*.o
-+ $(CXX) $(CFLAGS) -c $*.cxx -o $*.o
-
- .SUFFIXES: .cpp .o
- .cpp.o:
-- $(CC) $(CFLAGS) -c $*.cpp -o $*.o
-+ $(CXX) $(CFLAGS) -c $*.cpp -o $*.o
-
- .SUFFIXES: .asm .o
- .asm.o:
-@@ -66,7 +70,7 @@
- all: disasm z80_lib libs osmose
-
- osmose: $(z80_lib) $(OSM_OBJS) $(OPT_OBJS)
-- $(CC) $(CFLAGS) $(OSM_OBJS) $(Z80_LIB) $(OPT_OBJS) $(UNZIP_LIB) $(Z_LIB) -o $(OSM_EXE) $(LFLAGS)
-+ $(CXX) $(CFLAGS) $(OSM_OBJS) $(Z80_LIB) $(OPT_OBJS) $(UNZIP_LIB) $(Z_LIB) -o $(OSM_EXE) $(LFLAGS)
-
- z80_lib: $(Z80_OBJS)
- ar -rv $(Z80_LIB) $(Z80_DIR)/*.o
-@@ -84,8 +88,8 @@
- rm -f *.o core $(OSM_EXE)
-
- libs:
-- cd $(Z_LIB_DIR) && make libz.a
-- cd $(UNZIP_DIR) && make unzip.a
-+ cd $(Z_LIB_DIR) && ${MAKE} libz.a
-+ cd $(UNZIP_DIR) && ${MAKE} unzip.a
-
-
-
diff --git a/emulators/osmose/files/patch-PrecisionTimer.h b/emulators/osmose/files/patch-PrecisionTimer.h
deleted file mode 100644
index 838bd0b1d28e..000000000000
--- a/emulators/osmose/files/patch-PrecisionTimer.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./PrecisionTimer.h.orig Sat Apr 7 19:48:42 2007
-+++ ./PrecisionTimer.h Sat Apr 7 19:49:31 2007
-@@ -81,6 +81,6 @@
- unsigned long long tick_per_second; // Self explanatory.
- unsigned long long T0; // Self explanatory.
- unsigned long long T1; // Self explanatory.
-- double PrecisionTimer::getOneShotDuration();
-+ double getOneShotDuration();
- };
- #endif
diff --git a/emulators/osmose/files/patch-TvVideoFilter.h b/emulators/osmose/files/patch-TvVideoFilter.h
deleted file mode 100644
index f10129ef0423..000000000000
--- a/emulators/osmose/files/patch-TvVideoFilter.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./TvVideoFilter.h.orig Sat Apr 7 19:48:42 2007
-+++ ./TvVideoFilter.h Sat Apr 7 19:49:43 2007
-@@ -19,7 +19,7 @@
-
- class TvVideoFilter : public VideoFilter {
- public:
-- TvVideoFilter::TvVideoFilter();
-+ TvVideoFilter();
- int getFinalOutputWidth();
- int getFinalOutputHeight();
- void Filter(SDL_Surface *s, SDL_Surface *d);
diff --git a/emulators/osmose/files/patch-unzip-Makefile b/emulators/osmose/files/patch-unzip-Makefile
deleted file mode 100644
index 7b3094da8317..000000000000
--- a/emulators/osmose/files/patch-unzip-Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
---- unzip/Makefile.orig Fri Dec 17 13:21:30 2004
-+++ unzip/Makefile Tue Jul 26 21:15:04 2005
-@@ -1,5 +1,3 @@
--CC=cc
--CFLAGS=-O
-
- UNZ_OBJS = unzip.o ioapi.o
-
diff --git a/emulators/osmose/files/patch-zlib-Makefile b/emulators/osmose/files/patch-zlib-Makefile
deleted file mode 100644
index 77da14966812..000000000000
--- a/emulators/osmose/files/patch-zlib-Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- zlib/Makefile.orig Fri Dec 17 11:04:40 2004
-+++ zlib/Makefile Tue Jul 26 21:16:20 2005
-@@ -16,9 +16,7 @@
- # To install in $HOME instead of /usr/local, use:
- # make install prefix=$HOME
-
--CC=cc
-
--CFLAGS=-O
- #CFLAGS=-O -DMAX_WBITS=14 -DMAX_MEM_LEVEL=7
- #CFLAGS=-g -DDEBUG
- #CFLAGS=-O3 -Wall -Wwrite-strings -Wpointer-arith -Wconversion \
diff --git a/emulators/osmose/pkg-descr b/emulators/osmose/pkg-descr
index 851aac9f5e0f..46b7a1e99097 100644
--- a/emulators/osmose/pkg-descr
+++ b/emulators/osmose/pkg-descr
@@ -1,12 +1,9 @@
Osmose is another Sega Master System emulator. The emulator is released as
open source project, under GPL license.
-The emulator relies on SDL library, zlib, and uses Alessandro Scotti z80 cpu
+The emulator relies on Qt library, zlib, and uses Alessandro Scotti z80 cpu
core. Alessandro, is the author of the nice multi machine emulator 'Tickle'.
Rom decompression relies on Zlib and Gilles Vollant unzip package. Scale2x
video Filter is based on Andrea Mazzoleni's algorithm.
-WWW: http://bcz.emu-france.com/
-
-- Alejandro Pulver
-alejandro@varnet.biz
+WWW: http://bcz.asterope.fr/osmose.htm