aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2012-03-15 17:09:13 +0800
committermartymac <martymac@FreeBSD.org>2012-03-15 17:09:13 +0800
commitf1aae6ea3900832ee4c90da041c0dd8c0abbf5b5 (patch)
treec8874c8405723cfdd74b4791d2d0a9e87d465973 /emulators
parentd0da027e72dc3ae03c14d4e1e668e29421aef16c (diff)
downloadfreebsd-ports-gnome-f1aae6ea3900832ee4c90da041c0dd8c0abbf5b5.tar.gz
freebsd-ports-gnome-f1aae6ea3900832ee4c90da041c0dd8c0abbf5b5.tar.zst
freebsd-ports-gnome-f1aae6ea3900832ee4c90da041c0dd8c0abbf5b5.zip
Update to 3.0.r20120307
Feature safe: yes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu-devel/Makefile8
-rw-r--r--emulators/dolphin-emu-devel/distinfo4
-rw-r--r--emulators/dolphin-emu-devel/files/patch-CMakeLists.txt18
-rw-r--r--emulators/dolphin-emu-devel/files/patch-Source-Core-DolphinWX-CMakeLists.txt9
-rw-r--r--emulators/dolphin-emu-devel/files/patch-Source-Core-DolphinWX-Src-LogWindow.h11
-rw-r--r--emulators/dolphin-emu-devel/pkg-plist31
6 files changed, 62 insertions, 19 deletions
diff --git a/emulators/dolphin-emu-devel/Makefile b/emulators/dolphin-emu-devel/Makefile
index 52e9744d5285..1b962042f99a 100644
--- a/emulators/dolphin-emu-devel/Makefile
+++ b/emulators/dolphin-emu-devel/Makefile
@@ -7,7 +7,6 @@
PORTNAME= dolphin-emu
PORTVERSION= 3.0.r${REVDATE}
-PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@@ -25,8 +24,9 @@ LIB_DEPENDS= avformat.1:${PORTSDIR}/multimedia/ffmpeg \
lzo2.2:${PORTSDIR}/archivers/lzo2 \
sfml-network.1:${PORTSDIR}/devel/sfml
-REVDATE= 20111213
+REVDATE= 20120307
+USE_ICONV= yes
USE_GNOME= pkgconfig
USE_SDL= sdl
USE_OPENAL= yes
@@ -34,12 +34,14 @@ USE_XORG= ice xext x11 xrandr
USE_WX= 2.8
USE_GL= gl glew glu
+USE_GCC= 4.6+
USE_CMAKE= yes
CMAKE_BUILD_TYPE= Release
# Disable ao (seems buggy) and ALSA (emulated)
CMAKE_ARGS+= -DDISABLE_AO:BOOL=ON \
-DDISABLE_ALSA:BOOL=ON \
- -DDISABLE_BLUEZ:BOOL=ON
+ -DDISABLE_BLUEZ:BOOL=ON \
+ -DCMAKE_INSTALL_RPATH_USE_LINK_PATH:BOOL=ON
## Un-comment the following to build with debug symbols
#INSTALL_TARGET= install
diff --git a/emulators/dolphin-emu-devel/distinfo b/emulators/dolphin-emu-devel/distinfo
index 3f4eabe2dc29..367519f873f6 100644
--- a/emulators/dolphin-emu-devel/distinfo
+++ b/emulators/dolphin-emu-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dolphin-emu-3.0.r20111213.tgz) = c507664e9db3124f8e9b8559f9381d35176f144f68c618074f7e98e16bc7f537
-SIZE (dolphin-emu-3.0.r20111213.tgz) = 28067223
+SHA256 (dolphin-emu-3.0.r20120307.tgz) = ed8e16a60d3ba8d8e25f0d171fa8425647a698498576fcb3095a39230817854e
+SIZE (dolphin-emu-3.0.r20120307.tgz) = 28153474
diff --git a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
index e29b0341b344..0e43bf44abcf 100644
--- a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
+++ b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2011-09-13 08:18:10.000000000 +0200
-+++ CMakeLists.txt 2011-09-13 16:55:59.463344784 +0200
-@@ -174,51 +174,81 @@
+--- CMakeLists.txt.orig 2012-03-07 15:35:35.714613728 +0100
++++ CMakeLists.txt 2012-03-07 15:46:51.665626357 +0100
+@@ -228,51 +228,81 @@
message("OpenMP parallelization disabled")
endif()
@@ -113,7 +113,7 @@
# Note: We do not need to explicitly check for X11 as it is done in the cmake
# FindOpenGL module on linux.
-@@ -246,22 +276,29 @@
+@@ -302,22 +332,29 @@
check_libav()
endif()
@@ -156,10 +156,10 @@
option(OPROFILING "Enable profiling" OFF)
if(OPROFILING)
-@@ -458,10 +495,13 @@
- #
- install(DIRECTORY Data/User/ DESTINATION ${datadir}/user PATTERN .svn EXCLUDE)
- install(DIRECTORY Data/Sys/ DESTINATION ${datadir}/sys PATTERN .svn EXCLUDE)
+@@ -563,10 +600,13 @@
+ install(DIRECTORY Data/User/ DESTINATION ${datadir}/user PATTERN)
+ install(DIRECTORY Data/Sys/ DESTINATION ${datadir}/sys PATTERN)
+ endif()
-include(FindGettext)
-if(GETTEXT_FOUND AND NOT DISABLE_WX)
- file(GLOB LINGUAS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} Languages/po/*.po)
@@ -172,5 +172,5 @@
+ GETTEXT_CREATE_TRANSLATIONS(Languages/po/dolphin-emu.pot ALL ${LINGUAS})
+ endif()
endif()
- if((NOT ${CMAKE_SYSTEM_NAME} MATCHES "Linux") AND (NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD"))
+ if((NOT ${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|Darwin"))
install(FILES Data/license.txt DESTINATION ${datadir})
diff --git a/emulators/dolphin-emu-devel/files/patch-Source-Core-DolphinWX-CMakeLists.txt b/emulators/dolphin-emu-devel/files/patch-Source-Core-DolphinWX-CMakeLists.txt
index 232a242e444d..b0a973557682 100644
--- a/emulators/dolphin-emu-devel/files/patch-Source-Core-DolphinWX-CMakeLists.txt
+++ b/emulators/dolphin-emu-devel/files/patch-Source-Core-DolphinWX-CMakeLists.txt
@@ -1,8 +1,9 @@
---- Source/Core/DolphinWX/CMakeLists.txt.orig 2011-09-14 08:18:20.920474936 +0200
-+++ Source/Core/DolphinWX/CMakeLists.txt 2011-09-14 08:18:42.246379206 +0200
-@@ -1,4 +1,5 @@
+--- Source/Core/DolphinWX/CMakeLists.txt.orig 2012-03-07 15:33:14.000000000 +0100
++++ Source/Core/DolphinWX/CMakeLists.txt 2012-03-07 18:16:05.629985514 +0100
+@@ -1,4 +1,6 @@
set(LIBS core
+ execinfo
- lzo2
++ iconv
+ ${LZO}
discio
bdisasm
diff --git a/emulators/dolphin-emu-devel/files/patch-Source-Core-DolphinWX-Src-LogWindow.h b/emulators/dolphin-emu-devel/files/patch-Source-Core-DolphinWX-Src-LogWindow.h
new file mode 100644
index 000000000000..70e1aa710dc4
--- /dev/null
+++ b/emulators/dolphin-emu-devel/files/patch-Source-Core-DolphinWX-Src-LogWindow.h
@@ -0,0 +1,11 @@
+--- Source/Core/DolphinWX/Src/LogWindow.h.orig 2012-03-14 18:12:23.066269697 +0100
++++ Source/Core/DolphinWX/Src/LogWindow.h 2012-03-14 18:12:36.531263827 +0100
+@@ -79,7 +79,7 @@
+
+ DECLARE_EVENT_TABLE()
+
+- wxTextCtrl * CreateTextCtrl(wxPanel* parent, wxWindowID id = wxID_ANY, long Style = NULL);
++ wxTextCtrl * CreateTextCtrl(wxPanel* parent, wxWindowID id = wxID_ANY, long Style = 0);
+ void CreateGUIControls();
+ void PopulateBottom();
+ void UnPopulateBottom();
diff --git a/emulators/dolphin-emu-devel/pkg-plist b/emulators/dolphin-emu-devel/pkg-plist
index 210b21cfcd07..c0c1d824b63d 100644
--- a/emulators/dolphin-emu-devel/pkg-plist
+++ b/emulators/dolphin-emu-devel/pkg-plist
@@ -6,6 +6,7 @@ bin/dolphin-emu
%%NLS%%share/locale/el/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/en/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/es/LC_MESSAGES/dolphin-emu.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/fr/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/he/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/hu/LC_MESSAGES/dolphin-emu.mo
@@ -22,6 +23,7 @@ bin/dolphin-emu
%%NLS%%share/locale/tr/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/dolphin-emu.mo
+%%DATADIR%%/sys/codehandler.bin
%%DATADIR%%/sys/totaldb.dsy
%%DATADIR%%/sys/GC/font_sjis.bin
%%DATADIR%%/sys/GC/font_ansi.bin
@@ -99,6 +101,34 @@ bin/dolphin-emu
%%DATADIR%%/user/GameConfig/GAVY78.ini
%%DATADIR%%/user/GameConfig/G8FE8P.ini
%%DATADIR%%/user/GameConfig/GMIP70.ini
+%%DATADIR%%/user/GameConfig/GIZE52.ini
+%%DATADIR%%/user/GameConfig/G3LE8P.ini
+%%DATADIR%%/user/GameConfig/RS8J8N.ini
+%%DATADIR%%/user/GameConfig/RZTP01.ini
+%%DATADIR%%/user/GameConfig/GP8EAF.ini
+%%DATADIR%%/user/GameConfig/R9IE01.ini
+%%DATADIR%%/user/GameConfig/RZTK01.ini
+%%DATADIR%%/user/GameConfig/REDJ41.ini
+%%DATADIR%%/user/GameConfig/WBME01.ini
+%%DATADIR%%/user/GameConfig/RZTJ01.ini
+%%DATADIR%%/user/GameConfig/RGHE52.ini
+%%DATADIR%%/user/GameConfig/GLNP69.ini
+%%DATADIR%%/user/GameConfig/GYWD41.ini
+%%DATADIR%%/user/GameConfig/RBME5G.ini
+%%DATADIR%%/user/GameConfig/STEETR.ini
+%%DATADIR%%/user/GameConfig/JAEE01.ini
+%%DATADIR%%/user/GameConfig/GYWP41.ini
+%%DATADIR%%/user/GameConfig/RFBJ01.ini
+%%DATADIR%%/user/GameConfig/R8XE52.ini
+%%DATADIR%%/user/GameConfig/SS3EWR.ini
+%%DATADIR%%/user/GameConfig/RZTW01.ini
+%%DATADIR%%/user/GameConfig/RFBE01.ini
+%%DATADIR%%/user/GameConfig/ROAP36.ini
+%%DATADIR%%/user/GameConfig/SDFE4Q.ini
+%%DATADIR%%/user/GameConfig/JBKP01.ini
+%%DATADIR%%/user/GameConfig/WPPJJF.ini
+%%DATADIR%%/user/GameConfig/ROAE36.ini
+%%DATADIR%%/user/GameConfig/RLBEWR.ini
%%DATADIR%%/user/GameConfig/RTMP41.ini
%%DATADIR%%/user/GameConfig/GUBP69.ini
%%DATADIR%%/user/GameConfig/SX8E52.ini
@@ -372,7 +402,6 @@ bin/dolphin-emu
%%DATADIR%%/user/GameConfig/G8OJ18.ini
%%DATADIR%%/user/GameConfig/GF2E69.ini
%%DATADIR%%/user/GameConfig/RZJD69.ini
-%%DATADIR%%/user/GameConfig/WBEEJV.ini
%%DATADIR%%/user/GameConfig/R2GEXJ.ini
%%DATADIR%%/user/GameConfig/SPVXA4.ini
%%DATADIR%%/user/GameConfig/WILETL.ini