aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2011-12-21 07:54:32 +0800
committeracm <acm@FreeBSD.org>2011-12-21 07:54:32 +0800
commit0dd6dbfb8e2c322b21166a76d7ece3e85193544f (patch)
tree2da8a26cd83687cec8c73d94ca240c734ef5b1b8 /emulators
parent978995b2afb686a96d84605824ff15e4cc7db376 (diff)
downloadfreebsd-ports-gnome-0dd6dbfb8e2c322b21166a76d7ece3e85193544f.tar.gz
freebsd-ports-gnome-0dd6dbfb8e2c322b21166a76d7ece3e85193544f.tar.zst
freebsd-ports-gnome-0dd6dbfb8e2c322b21166a76d7ece3e85193544f.zip
- New port: emulators/mupen64plus-plugins
This is the metaport to install third party plugins of the mupen64plus. WWW: http://code.google.com/p/mupen64plus/
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-plugins/Makefile49
-rw-r--r--emulators/mupen64plus-plugins/pkg-descr3
3 files changed, 53 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 04c0671d8323..886cf637362c 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -112,6 +112,7 @@
SUBDIR += mupen64plus-audio-sdl
SUBDIR += mupen64plus-core
SUBDIR += mupen64plus-input-sdl
+ SUBDIR += mupen64plus-plugins
SUBDIR += mupen64plus-rsp-hle
SUBDIR += mupen64plus-rsp-z64
SUBDIR += mupen64plus-ui-console
diff --git a/emulators/mupen64plus-plugins/Makefile b/emulators/mupen64plus-plugins/Makefile
new file mode 100644
index 000000000000..6664ee926d22
--- /dev/null
+++ b/emulators/mupen64plus-plugins/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: mupen64plus-plugins
+# Date created: 2011-12-20
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64plus
+PORTVERSION= 1.99.4
+CATEGORIES= emulators
+MASTER_SITES= # empty
+PKGNAMESUFFIX= -plugins
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER?= acm@FreeBSD.org
+COMMENT= Third party plugins for Mupen64plus
+
+OPTIONS= VIDEO_ARACHNOID "Arachnoid video plugin" on \
+ VIDEO_GLIDE64 "Glide64 video plugin" on \
+ VIDEO_Z64 "z64 video plugin" on \
+ RSP_Z64 "z64 RSP plugin" on
+
+.include <bsd.port.pre.mk>
+
+# Graphics plugins
+.if defined(WITH_VIDEO_ARACHNOID)
+RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-video-arachnoid.so:${PORTSDIR}/emulators/mupen64plus-video-arachnoid
+.endif
+
+.if defined(WITH_VIDEO_GLIDE64)
+RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-video-glide64.so:${PORTSDIR}/emulators/mupen64plus-video-glide64
+.endif
+
+.if defined(WITH_VIDEO_Z64)
+RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-video-z64.so:${PORTSDIR}/emulators/mupen64plus-video-z64
+.endif
+
+# RSP plugins
+.if defined(WITH_RSP_Z64)
+RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-rsp-z64.so:${PORTSDIR}/emulators/mupen64plus-rsp-z64
+.endif
+
+NO_MTREE= yes
+NO_BUILD= yes
+
+do-install: # empty
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mupen64plus-plugins/pkg-descr b/emulators/mupen64plus-plugins/pkg-descr
new file mode 100644
index 000000000000..a0b400e87c57
--- /dev/null
+++ b/emulators/mupen64plus-plugins/pkg-descr
@@ -0,0 +1,3 @@
+This is the metaport to install third party plugins of the mupen64plus.
+
+WWW: http://code.google.com/p/mupen64plus/