aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2009-05-22 00:28:27 +0800
committernox <nox@FreeBSD.org>2009-05-22 00:28:27 +0800
commit1fed21213ab31ce14cc5b77b05a756c8fe3b5a0b (patch)
tree1c6124c023eee0887fd1b75fc9e030650fd5de65 /emulators
parent5b52f5c63e7c1c97a96d0904531d2f714763c4b5 (diff)
downloadfreebsd-ports-gnome-1fed21213ab31ce14cc5b77b05a756c8fe3b5a0b.tar.gz
freebsd-ports-gnome-1fed21213ab31ce14cc5b77b05a756c8fe3b5a0b.tar.zst
freebsd-ports-gnome-1fed21213ab31ce14cc5b77b05a756c8fe3b5a0b.zip
Update to 0.10.5 - from the official announcement:
- kvm: trim unsupported cpu features from cpuid (Avi Kivity) - kvm: provide a better error message for -smp > 1 (Mark McLoughlin) - Remove initrd printfs (Richard Jones) - Initial variables found by valgrind (Jean-Christophe Dubois) - Fix -initrd with > 4GB guests (Glauber Costa) - Fix busy loop on live migration for certain platforms (Uri Lublin) - Remove GCC 3.x requirements from docs (Hollis Blanchard) - ETRAX: fixes for kernel command line, ethernet address, bmi (Edgar Iglesias) - CRIS: Fix bmi (Edgar Iglesias) - Fix bounce buffer errors (Avi Kivity) - Fix regression in -kernel (Anthony Liguori)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/qemu/distinfo6
-rw-r--r--emulators/qemu/files/patch-faf8a63492cd98f00f7daff001e0d27b27038bec85
3 files changed, 4 insertions, 89 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 707d5a42ac87..6c538c1b798a 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.10.4
+PORTVERSION= 0.10.5
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
http://bellard.org/qemu/
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index 45d9a846eec8..fca78f47893a 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,3 +1,3 @@
-MD5 (qemu/qemu-0.10.4.tar.gz) = 4cdec0df66749281fbf73039fdf7f81b
-SHA256 (qemu/qemu-0.10.4.tar.gz) = bc370b4096fd516142cc5d8cbbae599cde8ef3f2bec33b21c95c2c5e3e3f3e5e
-SIZE (qemu/qemu-0.10.4.tar.gz) = 3749481
+MD5 (qemu/qemu-0.10.5.tar.gz) = 60060feb98c9649a5da8b136685f76ba
+SHA256 (qemu/qemu-0.10.5.tar.gz) = d54f268f5545dd182d96c1b09e79af58efaf2e51695efd1331d560a552d657c1
+SIZE (qemu/qemu-0.10.5.tar.gz) = 3662495
diff --git a/emulators/qemu/files/patch-faf8a63492cd98f00f7daff001e0d27b27038bec b/emulators/qemu/files/patch-faf8a63492cd98f00f7daff001e0d27b27038bec
deleted file mode 100644
index e53afb35e87e..000000000000
--- a/emulators/qemu/files/patch-faf8a63492cd98f00f7daff001e0d27b27038bec
+++ /dev/null
@@ -1,85 +0,0 @@
-From faf8a63492cd98f00f7daff001e0d27b27038bec Mon Sep 17 00:00:00 2001
-From: Anthony Liguori <aliguori@us.ibm.com>
-Date: Wed, 13 May 2009 08:06:54 -0500
-Subject: [PATCH] Revert "reset state for load_linux"
-
-This reverts commit 2da1e398641d9fccf683645c808dee0d088f84cf.
-
-This fix on the stable branch:
-
- commit 2da1e398641d9fccf683645c808dee0d088f84cf
- Author: Glauber Costa <glommer@redhat.com>
- Date: Fri May 8 02:22:13 2009 -0300
-
- reset state for load_linux
-
-Caused -kernel to break.
-
-The problem is that we're passing the ROM's ram_addr_t to
-load_linux() rather than its target_phys_addr_t. We also
-need to register the memory before trying to write to
-it.
-
-Signed-off-by: Mark McLoughlin <markmc@redhat.com>
-Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
----
- hw/pc.c | 15 ++++-----------
- 1 files changed, 4 insertions(+), 11 deletions(-)
-
-diff --git a/hw/pc.c b/hw/pc.c
-index 1b16373..c33cd75 100644
---- a/hw/pc.c
-+++ b/hw/pc.c
-@@ -471,7 +471,7 @@ static void bochs_bios_init(void)
-
- /* Generate an initial boot sector which sets state and jump to
- a specified vector */
--static void generate_bootsect(target_phys_addr_t option_rom,
-+static void generate_bootsect(uint8_t *option_rom,
- uint32_t gpr[8], uint16_t segs[6], uint16_t ip)
- {
- uint8_t rom[512], *p, *reloc;
-@@ -545,8 +545,7 @@ static void generate_bootsect(target_phys_addr_t option_rom,
- sum += rom[i];
- rom[sizeof(rom) - 1] = -sum;
-
-- cpu_physical_memory_write_rom(option_rom, rom, sizeof(rom));
-- option_rom_setup_reset(option_rom, sizeof (rom));
-+ memcpy(option_rom, rom, sizeof(rom));
- }
-
- static long get_file_size(FILE *f)
-@@ -563,7 +562,7 @@ static long get_file_size(FILE *f)
- return size;
- }
-
--static void load_linux(target_phys_addr_t option_rom,
-+static void load_linux(uint8_t *option_rom,
- const char *kernel_filename,
- const char *initrd_filename,
- const char *kernel_cmdline)
-@@ -714,12 +713,6 @@ static void load_linux(target_phys_addr_t option_rom,
- memset(gpr, 0, sizeof gpr);
- gpr[4] = cmdline_addr-real_addr-16; /* SP (-16 is paranoia) */
-
-- option_rom_setup_reset(real_addr, setup_size);
-- option_rom_setup_reset(prot_addr, kernel_size);
-- option_rom_setup_reset(cmdline_addr, cmdline_size);
-- if (initrd_filename)
-- option_rom_setup_reset(initrd_addr, initrd_size);
--
- generate_bootsect(option_rom, gpr, seg, 0);
- }
-
-@@ -927,7 +920,7 @@ vga_bios_error:
- offset = 0;
- if (linux_boot) {
- option_rom_offset = qemu_ram_alloc(TARGET_PAGE_SIZE);
-- load_linux(option_rom_offset,
-+ load_linux(phys_ram_base + option_rom_offset,
- kernel_filename, initrd_filename, kernel_cmdline);
- cpu_register_physical_memory(0xd0000, TARGET_PAGE_SIZE,
- option_rom_offset);
---
-1.6.2.5
-