aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2010-12-13 16:33:44 +0800
committeracm <acm@FreeBSD.org>2010-12-13 16:33:44 +0800
commit54e92baa36651621119a6075ea8ff11029c31eb7 (patch)
tree82f77644f04009e8a0fe60bd5e463df1258fe9aa /emulators
parentc79078d9a00b7fdc8360067e30ea50abfcc56459 (diff)
downloadfreebsd-ports-gnome-54e92baa36651621119a6075ea8ff11029c31eb7.tar.gz
freebsd-ports-gnome-54e92baa36651621119a6075ea8ff11029c31eb7.tar.zst
freebsd-ports-gnome-54e92baa36651621119a6075ea8ff11029c31eb7.zip
- Remove obsolete mupen64plus ports
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-dummyaudio/Makefile20
-rw-r--r--emulators/mupen64plus-dummyvideo/Makefile20
-rw-r--r--emulators/mupen64plus-gln64/Makefile23
-rw-r--r--emulators/mupen64plus-gln64/files/patch-glN64_Config_linux.cpp39
5 files changed, 0 insertions, 103 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index e52fc90cfcba..322c82fb0756 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -114,7 +114,6 @@
SUBDIR += mupen64-tr64
SUBDIR += mupen64plus
SUBDIR += mupen64plus-audio-sdl
- SUBDIR += mupen64plus-base
SUBDIR += mupen64plus-core
SUBDIR += mupen64plus-input-sdl
SUBDIR += mupen64plus-rice
diff --git a/emulators/mupen64plus-dummyaudio/Makefile b/emulators/mupen64plus-dummyaudio/Makefile
deleted file mode 100644
index 9b9e56b80bf9..000000000000
--- a/emulators/mupen64plus-dummyaudio/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# New ports collection makefile for: mupen64plus-dummyaudio
-# Date created: 2008-05-16
-# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PKGNAMESUFFIX= -dummyaudio
-
-COMMENT= Dummy audio plugin for Mupen64plus
-
-FIXFILES= #
-
-PLUGIN_NAME= dummyaudio
-
-MASTERDIR= ${.CURDIR}/../mupen64plus-base
-
-OPTIONS= #
-
-.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-dummyvideo/Makefile b/emulators/mupen64plus-dummyvideo/Makefile
deleted file mode 100644
index 2872cd357e5c..000000000000
--- a/emulators/mupen64plus-dummyvideo/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# New ports collection makefile for: mupen64plus-dummyvideo
-# Date created: 2009-01-13
-# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PKGNAMESUFFIX= -dummyvideo
-
-COMMENT= Dummy video plugin for Mupen64plus
-
-FIXFILES= #
-
-PLUGIN_NAME= dummyvideo
-
-MASTERDIR= ${.CURDIR}/../mupen64plus-base
-
-OPTIONS= #
-
-.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-gln64/Makefile b/emulators/mupen64plus-gln64/Makefile
deleted file mode 100644
index 407b8b6b49d1..000000000000
--- a/emulators/mupen64plus-gln64/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-# New ports collection makefile for: mupen64plus-gln64
-# Date created: 2008-05-16
-# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PKGNAMESUFFIX= -gln64
-
-COMMENT= The glN64 graphics plugin for Mupen64plus
-
-USE_GL= yes
-USE_SDL= sdl
-
-FIXFILES= glN64/DepthBuffer.cpp
-
-PLUGIN_NAME= glN64
-
-MASTERDIR= ${.CURDIR}/../mupen64plus-base
-
-OPTIONS= #
-
-.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-gln64/files/patch-glN64_Config_linux.cpp b/emulators/mupen64plus-gln64/files/patch-glN64_Config_linux.cpp
deleted file mode 100644
index 75456d9a4ad0..000000000000
--- a/emulators/mupen64plus-gln64/files/patch-glN64_Config_linux.cpp
+++ /dev/null
@@ -1,39 +0,0 @@
---- glN64/Config_gtk2.cpp 2008-12-15 01:42:14.000000000 -0500
-+++ glN64/Config_gtk2.cpp 2008-12-15 01:50:17.000000000 -0500
-@@ -1,4 +1,3 @@
--#include <features.h>
- #include <dlfcn.h>
- #include <unistd.h>
- #include "../main/winlnxdefs.h"
-@@ -44,29 +43,8 @@
- }
- else
- {
--#ifdef __USE_GNU
-- Dl_info info;
-- void *addr = (void*)GetPluginDir;
-- if(dladdr(addr, &info) != 0)
-- {
-- strncpy(path, info.dli_fname, PATH_MAX);
-- *(strrchr(path, '/')) = '\0';
-- }
-- else
-- {
-- fprintf(stderr, "(WW) Couldn't get path of .so, trying to get emulator's path\n");
--#endif // __USE_GNU
-- if(readlink("/proc/self/exe", path, PATH_MAX) == -1)
-- {
-- fprintf(stderr, "(WW) readlink() /proc/self/exe failed: %s\n", strerror(errno));
-- path[0] = '.';
-- path[1] = '\0';
-- }
-- *(strrchr(path, '/')) = '\0';
-- strncat(path, "/plugins", PATH_MAX);
--#ifdef __USE_GNU
-- }
--#endif
-+ strcpy(path, getenv("HOME"));
-+ strncat(path, "/.mupen64plus/plugins", PATH_MAX);
- }
- return path;
- }