aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-03-08 06:59:59 +0800
committermat <mat@FreeBSD.org>2016-03-08 06:59:59 +0800
commit70043e264ff775b74968f24b48af95b57931d955 (patch)
tree17acaaa029eddfe77d2fb80e319d5d7bd3d2bac9 /emulators
parent74da66e912dfc728545b709b1a63b53bec7f16ab (diff)
downloadfreebsd-ports-gnome-70043e264ff775b74968f24b48af95b57931d955.tar.gz
freebsd-ports-gnome-70043e264ff775b74968f24b48af95b57931d955.tar.zst
freebsd-ports-gnome-70043e264ff775b74968f24b48af95b57931d955.zip
Update to 1.9.0
PR: 203245 Submitted by: tkato432 yahoo com Sponsored by: Absolight
Diffstat (limited to 'emulators')
-rw-r--r--emulators/hatari/Makefile42
-rw-r--r--emulators/hatari/distinfo4
-rw-r--r--emulators/hatari/files/patch-share_CMakeLists.txt24
-rw-r--r--emulators/hatari/pkg-descr6
-rw-r--r--emulators/hatari/pkg-plist37
5 files changed, 90 insertions, 23 deletions
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index 1573535f9d0f..818e04eea6c5 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= hatari
-PORTVERSION= 1.8.0
-PORTREVISION= 4
+PORTVERSION= 1.9.0
CATEGORIES= emulators
-MASTER_SITES= http://download.tuxfamily.org/hatari/${PORTVERSION}/
+MASTER_SITES= http://download.tuxfamily.org/hatari/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Atari ST emulator
@@ -16,14 +16,27 @@ LICENSE_FILE= ${WRKSRC}/gpl.txt
LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio \
libpng.so:${PORTSDIR}/graphics/png
-USES= cmake readline tar:bzip2
+USES= cmake desktop-file-utils python readline shared-mime-info \
+ shebangfix tar:bzip2
+SHEBANG_FILES= tools/atari-convert-dir.py
+python_OLD_CMD= /usr/bin/python2
USE_GNOME= pygtk2
-USE_SDL= sdl
-CMAKE_ARGS= -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
- -DETCDIR:STRING="${PREFIX}/etc" \
- -DMANDIR:STRING="man/man1"
-
-OPTIONS_DEFINE= DOCS
+CMAKE_ARGS= -DETCDIR:PATH="${PREFIX}/etc" \
+ -DMANDIR:PATH="man/man1" \
+ -DREADLINE_FOUND:BOOL=ON
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= DEBUG DOCS SDL2 WINUAE
+
+DEBUG_CFLAGS_OFF= -DNDEBUG
+SDL2_DESC= Use SDL2 libraries instead of SDL 1.2
+SDL2_USES= iconv
+SDL2_USE= sdl=sdl2
+SDL2_USE_OFF= sdl=sdl
+SDL2_CMAKE_ON= -DENABLE_SDL2:BOOL=ON
+SDL2_CFLAGS= -I${ICONV_INCLUDE_PATH}
+WINUAE_DESC= Build with WinUAE CPU core (experimental)
+WINUAE_CMAKE_ON= -DENABLE_WINUAE_CPU:BOOL=ON
post-patch:
.for i in doc/hatari.1 doc/fr/hatari.1 tools/hconsole/hconsole.1
@@ -31,15 +44,12 @@ post-patch:
's|^/etc/hatari.cfg .*|${PREFIX}/etc/hatari.cfg| ; \
s|/usr/share|${PREFIX}/share|' ${WRKSRC}/${i}
.endfor
- @${REINPLACE_CMD} -e '/DESTINATION/s|/icons/.*)|/pixmaps)|' \
- ${WRKSRC}/python-ui/CMakeLists.txt
-
-post-build:
- @cd ${WRKSRC}/doc/fr && ${GZIP_CMD} -c ${PORTNAME}.1 > ${PORTNAME}.1.gz
+ @${REINPLACE_CMD} -e \
+ 's|-Wno-maybe-uninitialized||' ${WRKSRC}/src/cpu/CMakeLists.txt
post-install:
@${MKDIR} ${STAGEDIR}${MANPREFIX}/man/fr/man1
- ${INSTALL_MAN} ${WRKSRC}/doc/fr/${PORTNAME}.1.gz ${STAGEDIR}${MANPREFIX}/man/fr/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/fr/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/fr/man1
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/fr
diff --git a/emulators/hatari/distinfo b/emulators/hatari/distinfo
index bdc4dc31f4dd..06ef2546d7cf 100644
--- a/emulators/hatari/distinfo
+++ b/emulators/hatari/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hatari-1.8.0.tar.bz2) = 7ecf486ba578e3b4d7a3d3e86ef3e879d5e5611b39c2504e38ccafdaacb5ffeb
-SIZE (hatari-1.8.0.tar.bz2) = 1985358
+SHA256 (hatari-1.9.0.tar.bz2) = b2b56e6cbe7f8769a5e8b1d96599f392d9351b44cacf959da6905da06d30e992
+SIZE (hatari-1.9.0.tar.bz2) = 2379016
diff --git a/emulators/hatari/files/patch-share_CMakeLists.txt b/emulators/hatari/files/patch-share_CMakeLists.txt
new file mode 100644
index 000000000000..a00dabdb92da
--- /dev/null
+++ b/emulators/hatari/files/patch-share_CMakeLists.txt
@@ -0,0 +1,24 @@
+--- share/CMakeLists.txt.orig 2015-09-10 21:16:03 UTC
++++ share/CMakeLists.txt
+@@ -5,8 +5,8 @@ foreach(size 32x32 48x48 64x64 128x128 2
+ install(FILES icons/hicolor/${size}/mimetypes/application-x-st-disk-image.png
+ DESTINATION ${ICONDIR}/${size}/mimetypes)
+ foreach(type vnd.msa vnd.fastcopy x-stx)
+- install(CODE "execute_process(COMMAND ln -sf application-x-st-disk-image.png
+- ${CMAKE_INSTALL_PREFIX}/${ICONDIR}/${size}/mimetypes/application-${type}-disk-image.png)
++ install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink application-x-st-disk-image.png application-${type}-disk-image.png
++ WORKING_DIRECTORY \$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${ICONDIR}/${size}/mimetypes)
+ ")
+ endforeach()
+ endforeach()
+@@ -16,8 +16,8 @@ install(FILES icons/hicolor/scalable/app
+ install(FILES icons/hicolor/scalable/mimetypes/application-x-st-disk-image.svg
+ DESTINATION ${ICONDIR}/scalable/mimetypes)
+ foreach(type vnd.msa vnd.fastcopy x-stx)
+- install(CODE "execute_process(COMMAND ln -sf application-x-st-disk-image.svg
+- ${CMAKE_INSTALL_PREFIX}/${ICONDIR}/scalable/mimetypes/application-${type}-disk-image.svg)
++ install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink application-x-st-disk-image.svg application-${type}-disk-image.svg
++ WORKING_DIRECTORY \$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${ICONDIR}/scalable/mimetypes)
+ ")
+ endforeach()
+ install(FILES mime/packages/hatari.xml DESTINATION share/mime/packages)
diff --git a/emulators/hatari/pkg-descr b/emulators/hatari/pkg-descr
index 12b0544eb0bd..27f1d598740c 100644
--- a/emulators/hatari/pkg-descr
+++ b/emulators/hatari/pkg-descr
@@ -1,5 +1,5 @@
-Hatari is an Atari ST emulator. It tries to emulate the hardware of a ST
-as close as possible so that it is able to run most of the old ST games
-and demos.
+Hatari is an emulator for the Atari ST, STE, TT and Falcon computers. It
+tries to emulate the hardware of a ST as close as possible so that it is
+able to run most of the old ST games and demos.
WWW: http://hatari.tuxfamily.org/
diff --git a/emulators/hatari/pkg-plist b/emulators/hatari/pkg-plist
index dd0dc49467e1..63f5fcf41f50 100644
--- a/emulators/hatari/pkg-plist
+++ b/emulators/hatari/pkg-plist
@@ -1,3 +1,4 @@
+bin/atari-convert-dir
bin/atari-hd-image
bin/gst2ascii
bin/hatari
@@ -6,6 +7,7 @@ bin/hatariui
bin/hmsa
bin/zip2st
man/fr/man1/hatari.1.gz
+man/man1/atari-convert-dir.1.gz
man/man1/atari-hd-image.1.gz
man/man1/gst2ascii.1.gz
man/man1/hatari.1.gz
@@ -14,6 +16,7 @@ man/man1/hatariui.1.gz
man/man1/hconsole.1.gz
man/man1/hmsa.1.gz
man/man1/zip2st.1.gz
+share/applications/hatari.desktop
share/applications/hatariui.desktop
%%PORTDOCS%%%%DOCSDIR%%/authors.txt
%%PORTDOCS%%%%DOCSDIR%%/compatibility.html
@@ -50,7 +53,7 @@ share/applications/hatariui.desktop
%%DATADIR%%/hatariui/debugui.py
%%DATADIR%%/hatariui/dialogs.py
%%DATADIR%%/hatariui/hatari-icon.png
-%%DATADIR%%/hatariui/hatari.png
+%%DATADIR%%/hatariui/hatari-logo.png
%%DATADIR%%/hatariui/hatari.py
%%DATADIR%%/hatariui/hatariui.py
%%DATADIR%%/hatariui/release-notes.txt
@@ -61,4 +64,34 @@ share/applications/hatariui.desktop
%%DATADIR%%/hconsole/hconsole.py
%%DATADIR%%/hconsole/release-notes.txt
%%DATADIR%%/tos.img
-share/pixmaps/hatari-icon.png
+share/icons/hicolor/128x128/apps/hatari.png
+share/icons/hicolor/128x128/mimetypes/application-vnd.fastcopy-disk-image.png
+share/icons/hicolor/128x128/mimetypes/application-vnd.msa-disk-image.png
+share/icons/hicolor/128x128/mimetypes/application-x-st-disk-image.png
+share/icons/hicolor/128x128/mimetypes/application-x-stx-disk-image.png
+share/icons/hicolor/256x256/apps/hatari.png
+share/icons/hicolor/256x256/mimetypes/application-vnd.fastcopy-disk-image.png
+share/icons/hicolor/256x256/mimetypes/application-vnd.msa-disk-image.png
+share/icons/hicolor/256x256/mimetypes/application-x-st-disk-image.png
+share/icons/hicolor/256x256/mimetypes/application-x-stx-disk-image.png
+share/icons/hicolor/32x32/apps/hatari.png
+share/icons/hicolor/32x32/mimetypes/application-vnd.fastcopy-disk-image.png
+share/icons/hicolor/32x32/mimetypes/application-vnd.msa-disk-image.png
+share/icons/hicolor/32x32/mimetypes/application-x-st-disk-image.png
+share/icons/hicolor/32x32/mimetypes/application-x-stx-disk-image.png
+share/icons/hicolor/48x48/apps/hatari.png
+share/icons/hicolor/48x48/mimetypes/application-vnd.fastcopy-disk-image.png
+share/icons/hicolor/48x48/mimetypes/application-vnd.msa-disk-image.png
+share/icons/hicolor/48x48/mimetypes/application-x-st-disk-image.png
+share/icons/hicolor/48x48/mimetypes/application-x-stx-disk-image.png
+share/icons/hicolor/64x64/apps/hatari.png
+share/icons/hicolor/64x64/mimetypes/application-vnd.fastcopy-disk-image.png
+share/icons/hicolor/64x64/mimetypes/application-vnd.msa-disk-image.png
+share/icons/hicolor/64x64/mimetypes/application-x-st-disk-image.png
+share/icons/hicolor/64x64/mimetypes/application-x-stx-disk-image.png
+share/icons/hicolor/scalable/apps/hatari.svg
+share/icons/hicolor/scalable/mimetypes/application-vnd.fastcopy-disk-image.svg
+share/icons/hicolor/scalable/mimetypes/application-vnd.msa-disk-image.svg
+share/icons/hicolor/scalable/mimetypes/application-x-st-disk-image.svg
+share/icons/hicolor/scalable/mimetypes/application-x-stx-disk-image.svg
+share/mime/packages/hatari.xml