aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2014-04-08 04:27:24 +0800
committeracm <acm@FreeBSD.org>2014-04-08 04:27:24 +0800
commit79885e527c4f07cdb69aaf5cff3fb84246e0daf5 (patch)
tree7e6d1074c545918dbdb40bb83af307e4abbfd453 /emulators
parent9ba0063f5c51e57b1cf85de6d8a215f25979dfd2 (diff)
downloadfreebsd-ports-gnome-79885e527c4f07cdb69aaf5cff3fb84246e0daf5.tar.gz
freebsd-ports-gnome-79885e527c4f07cdb69aaf5cff3fb84246e0daf5.tar.zst
freebsd-ports-gnome-79885e527c4f07cdb69aaf5cff3fb84246e0daf5.zip
- Fix build with wxWidgest 3.0
- Add STAGE support
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wxmupen64plus/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/emulators/wxmupen64plus/Makefile b/emulators/wxmupen64plus/Makefile
index e47c31709751..f6e80f05cbd5 100644
--- a/emulators/wxmupen64plus/Makefile
+++ b/emulators/wxmupen64plus/Makefile
@@ -13,8 +13,6 @@ DIST_SUBDIR= ${PORTNAME:S/wx//}
MAINTAINER= acm@FreeBSD.org
COMMENT= Mupen64Plus 2.0 GUI frontend written using wxWidgets
-BROKEN= does not build with any of the supported wx
-
LIB_DEPENDS= mupen64plus:${PORTSDIR}/emulators/mupen64plus-core
RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-audio-sdl.so:${PORTSDIR}/emulators/mupen64plus-audio-sdl \
@@ -30,10 +28,9 @@ WX_UNICODE= yes
USE_PYTHON= yes
WAF_SCRIPT= waf
-NO_STAGE= yes
-
post-patch:
- @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' -e 's|%%CXX%%|${CXX}|g' ${WRKSRC}/wscript
+ @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' -e 's|%%CXX%%|${CXX}|g' -e
+ 's|version=2.9|version=${WX_VERSION}|g' ${WRKSRC}/wscript
do-configure:
@cd ${WRKSRC} && \
@@ -51,8 +48,8 @@ do-build:
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${WAF_SCRIPT}
do-install:
- @${MKDIR} ${DATADIR}
- @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}
- @${INSTALL_PROGRAM} ${WRKSRC}/build/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/build/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>