aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2011-12-21 07:51:31 +0800
committeracm <acm@FreeBSD.org>2011-12-21 07:51:31 +0800
commit978995b2afb686a96d84605824ff15e4cc7db376 (patch)
tree7c30fe85c6e3de7592446d88d14d9fdf9ee6091f /emulators
parent32892a230c2ff6d1045baaa70f5e07749f266523 (diff)
downloadfreebsd-ports-gnome-978995b2afb686a96d84605824ff15e4cc7db376.tar.gz
freebsd-ports-gnome-978995b2afb686a96d84605824ff15e4cc7db376.tar.zst
freebsd-ports-gnome-978995b2afb686a96d84605824ff15e4cc7db376.zip
- New port: emulators/mupen64plus-video-z64
Low-level RDP plugin for the Mupen64Plus
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-video-z64/Makefile30
2 files changed, 31 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 527985e3a2e9..04c0671d8323 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -118,6 +118,7 @@
SUBDIR += mupen64plus-video-arachnoid
SUBDIR += mupen64plus-video-glide64
SUBDIR += mupen64plus-video-rice
+ SUBDIR += mupen64plus-video-z64
SUBDIR += nonpareil
SUBDIR += o2em
SUBDIR += ods2reader
diff --git a/emulators/mupen64plus-video-z64/Makefile b/emulators/mupen64plus-video-z64/Makefile
new file mode 100644
index 000000000000..2a2523a5a2ea
--- /dev/null
+++ b/emulators/mupen64plus-video-z64/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mupen64plus-video-z64
+# Date created: 2011-12-20
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -video-z64
+DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}${EXTRACT_SUFX}:plugin
+
+COMMENT= Low-level RDP plugin for the Mupen64Plus
+
+LIB_DEPENDS= mupen64plus.2:${PORTSDIR}/emulators/mupen64plus-core
+
+USE_GL= gl glu glew
+USE_SDL= yes
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-core
+
+OPTIONS= #
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
+WRKSRC= ${WRKDIR}
+
+.include "${MASTERDIR}/Makefile"