aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2005-11-15 08:27:48 +0800
committergerald <gerald@FreeBSD.org>2005-11-15 08:27:48 +0800
commit97b70b502a7be7e6d071a09c690ed555b776873d (patch)
tree5535af24d337fcc0f4717a75afa1a2bbaf367c13 /emulators
parent096e4f54a9eca736ca3b5c774ffc93d2d5ebe579 (diff)
downloadfreebsd-ports-gnome-97b70b502a7be7e6d071a09c690ed555b776873d.tar.gz
freebsd-ports-gnome-97b70b502a7be7e6d071a09c690ed555b776873d.tar.zst
freebsd-ports-gnome-97b70b502a7be7e6d071a09c690ed555b776873d.zip
Perform some house^Wportkeeping:
- WRKSRC is predefined, no need to redefine it. - Use pre-build instead of post-configure. - Rely on the default do-install target, and use post-install for our additional changes. - $PREFIX/etc/wine.conf and .wine/config are no longer used; remove all references from pkg-message. PR: 88758 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile12
-rw-r--r--emulators/wine-devel/pkg-message7
-rw-r--r--emulators/wine/Makefile12
-rw-r--r--emulators/wine/pkg-message7
4 files changed, 8 insertions, 30 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index ab263669525a..d1d07d4b02c5 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -18,7 +18,6 @@ COMMENT= Microsoft Windows compatibility layer for Unix-like systems
LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms
-WRKSRC= ${WRKDIR}/wine-${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib LIBS=-Wl,-rpath,${PREFIX}/lib/wine
INSTALLS_SHLIB= yes
@@ -43,11 +42,10 @@ post-extract:
@${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/wine.sh \
> ${WRKSRC}/wine.sh
-post-configure:
+pre-build:
cd ${WRKSRC} && make depend
-do-install:
- cd ${WRKSRC} && ${GMAKE} install
+post-install:
-@${MKDIR} ${PREFIX}/etc/rc.d
${RM} ${PREFIX}/man/man1/wineg++.1
.if !defined(NOPORTDOCS)
@@ -60,11 +58,9 @@ do-install:
.endfor
${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${DOCSDIR}/README.winedump
.endif
- ${INSTALL_SCRIPT} ${WRKSRC}/tools/bug_report.pl ${PREFIX}/lib/wine
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/bug_report.pl ${PREFIX}/lib/wine
+ @${INSTALL_SCRIPT} ${WRKSRC}/wine.sh ${PREFIX}/etc/rc.d/000.wine.sh
${ECHO}
@${SED} s+%%PREFIX%%+${PREFIX}+g <${PKGMESSAGE}
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/wine.sh ${PREFIX}/etc/rc.d/000.wine.sh
-
.include <bsd.port.post.mk>
diff --git a/emulators/wine-devel/pkg-message b/emulators/wine-devel/pkg-message
index 05b8d520394e..5a29eb19315e 100644
--- a/emulators/wine-devel/pkg-message
+++ b/emulators/wine-devel/pkg-message
@@ -1,13 +1,6 @@
Wine should build on FreeBSD 4.x and FreeBSD 5.x, but versions before
FreeBSD 5.3 will generally not work properly.
-Wine requires a configuration file .wine/config in the home directory of
-every user, where assignments of Unix directories to DOS drive letters and
-other options can be set (see "man wine" for details). You may want to copy
- %%PREFIX%%/etc/wine.conf
-and tweak it accordingly or edit this file and make .wine/config a symlink
-there.
-
The port also installs some of Wine's doc files which describe additional
things that are not in the manual pages, see:
%%PREFIX%%/share/doc/wine
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index ab263669525a..d1d07d4b02c5 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -18,7 +18,6 @@ COMMENT= Microsoft Windows compatibility layer for Unix-like systems
LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms
-WRKSRC= ${WRKDIR}/wine-${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib LIBS=-Wl,-rpath,${PREFIX}/lib/wine
INSTALLS_SHLIB= yes
@@ -43,11 +42,10 @@ post-extract:
@${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/wine.sh \
> ${WRKSRC}/wine.sh
-post-configure:
+pre-build:
cd ${WRKSRC} && make depend
-do-install:
- cd ${WRKSRC} && ${GMAKE} install
+post-install:
-@${MKDIR} ${PREFIX}/etc/rc.d
${RM} ${PREFIX}/man/man1/wineg++.1
.if !defined(NOPORTDOCS)
@@ -60,11 +58,9 @@ do-install:
.endfor
${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${DOCSDIR}/README.winedump
.endif
- ${INSTALL_SCRIPT} ${WRKSRC}/tools/bug_report.pl ${PREFIX}/lib/wine
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/bug_report.pl ${PREFIX}/lib/wine
+ @${INSTALL_SCRIPT} ${WRKSRC}/wine.sh ${PREFIX}/etc/rc.d/000.wine.sh
${ECHO}
@${SED} s+%%PREFIX%%+${PREFIX}+g <${PKGMESSAGE}
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/wine.sh ${PREFIX}/etc/rc.d/000.wine.sh
-
.include <bsd.port.post.mk>
diff --git a/emulators/wine/pkg-message b/emulators/wine/pkg-message
index 05b8d520394e..5a29eb19315e 100644
--- a/emulators/wine/pkg-message
+++ b/emulators/wine/pkg-message
@@ -1,13 +1,6 @@
Wine should build on FreeBSD 4.x and FreeBSD 5.x, but versions before
FreeBSD 5.3 will generally not work properly.
-Wine requires a configuration file .wine/config in the home directory of
-every user, where assignments of Unix directories to DOS drive letters and
-other options can be set (see "man wine" for details). You may want to copy
- %%PREFIX%%/etc/wine.conf
-and tweak it accordingly or edit this file and make .wine/config a symlink
-there.
-
The port also installs some of Wine's doc files which describe additional
things that are not in the manual pages, see:
%%PREFIX%%/share/doc/wine