aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-05-31 04:39:12 +0800
committerbapt <bapt@FreeBSD.org>2015-05-31 04:39:12 +0800
commitb59b6099b4d24dea62584334abcd9af40a23478c (patch)
treec6487f309b5d29e868c4ea46df98e320c50df957 /emulators
parent879b5d290b19b7c2735c5fabfe2901e1d2b76a4a (diff)
downloadfreebsd-ports-gnome-b59b6099b4d24dea62584334abcd9af40a23478c.tar.gz
freebsd-ports-gnome-b59b6099b4d24dea62584334abcd9af40a23478c.tar.zst
freebsd-ports-gnome-b59b6099b4d24dea62584334abcd9af40a23478c.zip
Update portaudio to v19/Remove portaudio2 [1]
Chase portaudio change Add patches from debian for games/cultivation Add patches from upsteam for audio/rezound Mark py-fastaudio as broken Approved by: maintainer
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu/Makefile4
-rw-r--r--emulators/dolphin-emu/files/patch-CMakeLists.txt45
-rw-r--r--emulators/hatari/Makefile11
3 files changed, 5 insertions, 55 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index 51af37934fe3..f9898619a7ba 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dolphin-emu
PORTVERSION= 4.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MAINTAINER= martymac@FreeBSD.org
@@ -47,7 +47,7 @@ PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CMAKE_ON= -DDISABLE_PULSEAUDIO:BOOL=OFF
PULSEAUDIO_CMAKE_OFF= -DDISABLE_PULSEAUDIO:BOOL=ON
PORTAUDIO_DESC= Enable PortAudio (mic) support
-PORTAUDIO_LIB_DEPENDS= libportaudio.so.2:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio
PORTAUDIO_CMAKE_ON= -DDISABLE_PORTAUDIO:BOOL=OFF
PORTAUDIO_CMAKE_OFF= -DDISABLE_PORTAUDIO:BOOL=ON
DEBUG_MAKE_ENV= VERBOSE=yes
diff --git a/emulators/dolphin-emu/files/patch-CMakeLists.txt b/emulators/dolphin-emu/files/patch-CMakeLists.txt
index 45ad27dc92c5..33dadd6d5d85 100644
--- a/emulators/dolphin-emu/files/patch-CMakeLists.txt
+++ b/emulators/dolphin-emu/files/patch-CMakeLists.txt
@@ -113,51 +113,6 @@
if(UNIX AND NOT APPLE)
# Note: The convention is to check USE_X11 or USE_WAYLAND where needed.
-@@ -455,21 +485,32 @@
- check_libav()
- endif()
-
-- set(CMAKE_REQUIRED_LIBRARIES portaudio)
-- CHECK_CXX_SOURCE_RUNS(
-- "#include <portaudio.h>
-- int main(int argc, char **argv)
-- { if(Pa_GetVersion() >= 1890) return 0; else return 1; }"
-- PORTAUDIO)
-- if(PORTAUDIO)
-- message("PortAudio found, enabling mic support")
-- add_definitions(-DHAVE_PORTAUDIO=1)
-- set(PORTAUDIO_FOUND TRUE)
-+ option(DISABLE_PORTAUDIO "Disable PortAudio (mic) support" OFF)
-+ if(NOT DISABLE_PORTAUDIO)
-+ include_directories(BEFORE ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
-+ link_directories(${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
-+ set(CMAKE_REQUIRED_INCLUDES ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
-+ set(CMAKE_REQUIRED_FLAGS -L${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
-+ set(CMAKE_REQUIRED_LIBRARIES portaudio)
-+ CHECK_CXX_SOURCE_RUNS(
-+ "#include <portaudio.h>
-+ int main(int argc, char **argv)
-+ { if(Pa_GetVersion() >= 1890) return 0; else return 1; }"
-+ PORTAUDIO)
-+ if(PORTAUDIO)
-+ message("PortAudio found, enabling mic support")
-+ add_definitions(-DHAVE_PORTAUDIO=1)
-+ set(PORTAUDIO_FOUND TRUE)
-+ else()
-+ message("PortAudio not found, disabling mic support")
-+ add_definitions(-DHAVE_PORTAUDIO=0)
-+ set(PORTAUDIO_FOUND FALSE)
-+ endif(PORTAUDIO)
- else()
-- message("PortAudio not found, disabling mic support")
-+ message("PortAudio (mic) support disabled")
- add_definitions(-DHAVE_PORTAUDIO=0)
- set(PORTAUDIO_FOUND FALSE)
-- endif(PORTAUDIO)
-+ endif()
-
- if(OPROFILING)
- check_lib(OPROFILE opagent opagent.h)
@@ -577,14 +618,14 @@
set(SFML_FIND_VERSION_MAJOR 1)
set(SFML_FIND_VERSION_MINOR 5)
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index bbeb64e06e31..049b3b128e24 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hatari
PORTVERSION= 1.8.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= http://download.tuxfamily.org/hatari/${PORTVERSION}/
@@ -12,23 +12,18 @@ COMMENT= Atari ST emulator
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= libportaudio.so.2:${PORTSDIR}/audio/portaudio2 \
+LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio \
libpng.so:${PORTSDIR}/graphics/png
USES= cmake readline tar:bzip2
USE_GNOME= pygtk2
USE_SDL= sdl
-CMAKE_ARGS= -DPORTAUDIO_INCLUDE_DIR:STRING="${PA2_INCLUDE_DIR}" \
- -DPORTAUDIO_LIBRARY:STRING="${PA2_LIBRARY}" \
- -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
+CMAKE_ARGS= -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
-DETCDIR:STRING="${PREFIX}/etc" \
-DMANDIR:STRING="man/man1"
OPTIONS_DEFINE= DOCS
-PA2_INCLUDE_DIR=${LOCALBASE}/include/portaudio2
-PA2_LIBRARY= ${LOCALBASE}/lib/portaudio2/libportaudio.so
-
post-patch:
.for i in doc/hatari.1 doc/fr/hatari.1 tools/hconsole/hconsole.1
@${REINPLACE_CMD} -e \