aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-05-12 02:34:57 +0800
committermat <mat@FreeBSD.org>2015-05-12 02:34:57 +0800
commitd843ecd4966c8a5bed60cf3aaeb27edb6b5b2389 (patch)
tree634e1ef4990207301493f26b46d80abe56b9f2b3 /emulators
parent925f5606448b4e40652ba0a13bfb8cd44c8aac89 (diff)
downloadfreebsd-ports-gnome-d843ecd4966c8a5bed60cf3aaeb27edb6b5b2389.tar.gz
freebsd-ports-gnome-d843ecd4966c8a5bed60cf3aaeb27edb6b5b2389.tar.zst
freebsd-ports-gnome-d843ecd4966c8a5bed60cf3aaeb27edb6b5b2389.zip
Cleanup DIST* variables.
When appropriate: - Try to use DISTVERSION{SUF,PRE}FIX - Replace PORTNAME-PORTVERSION by DISTNAME - Convert MASTER_SITES to use macros - Other light cleanup With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'emulators')
-rw-r--r--emulators/kqemu-kmod-devel/Makefile6
-rw-r--r--emulators/kqemu-kmod/Makefile6
-rw-r--r--emulators/minivmac/Makefile6
-rw-r--r--emulators/q4wine/Makefile3
-rw-r--r--emulators/ucon64/Makefile2
5 files changed, 9 insertions, 14 deletions
diff --git a/emulators/kqemu-kmod-devel/Makefile b/emulators/kqemu-kmod-devel/Makefile
index de46de82952f..b51c529290e9 100644
--- a/emulators/kqemu-kmod-devel/Makefile
+++ b/emulators/kqemu-kmod-devel/Makefile
@@ -2,15 +2,13 @@
# $FreeBSD$
PORTNAME= kqemu
-PORTVERSION= 1.4.0.p1
+DISTVERSION= 1.4.0pre1
PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= http://bellard.org/qemu/ \
http://qemu.org/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= nox
+ LOCAL/nox
PKGNAMESUFFIX= -kmod-devel
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/.p/pre/}
DIST_SUBDIR= kqemu
MAINTAINER= nox@FreeBSD.org
diff --git a/emulators/kqemu-kmod/Makefile b/emulators/kqemu-kmod/Makefile
index 71c019a1e4da..0f64f04539ef 100644
--- a/emulators/kqemu-kmod/Makefile
+++ b/emulators/kqemu-kmod/Makefile
@@ -2,15 +2,13 @@
# $FreeBSD$
PORTNAME= kqemu
-PORTVERSION= 1.3.0.p11
+DISTVERSION= 1.3.0pre11
PORTREVISION= 12
CATEGORIES= emulators
MASTER_SITES= http://bellard.org/qemu/ \
http://qemu.org/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= nox
+ LOCAL/nox
PKGNAMESUFFIX= -kmod
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/.p/pre/}
DIST_SUBDIR= kqemu
MAINTAINER= nox@FreeBSD.org
diff --git a/emulators/minivmac/Makefile b/emulators/minivmac/Makefile
index bcf7c2091721..f092e51c92c7 100644
--- a/emulators/minivmac/Makefile
+++ b/emulators/minivmac/Makefile
@@ -5,8 +5,8 @@ PORTNAME= minivmac
PORTVERSION= 3.0.0
CATEGORIES= emulators
MASTER_SITES= SF
-DISTFILES= ${PORTNAME}-${PORTVERSION}.src.tgz \
- ${PORTNAME}-${PORTVERSION}.prj.tgz
+DISTFILES= ${DISTNAME}.src${EXTRACT_SUFX} \
+ ${DISTNAME}.prj${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Miniature Macintosh emulator
@@ -16,7 +16,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/projects/bgclx86d
USE_XORG= x11 xext
-USES= gmake
+USES= gmake tar:tgz
CFLAGS+= -I${LOCALBASE}/include
ALL_TARGET= # nothing
diff --git a/emulators/q4wine/Makefile b/emulators/q4wine/Makefile
index db9b22be22e8..9479eed527d0 100644
--- a/emulators/q4wine/Makefile
+++ b/emulators/q4wine/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= q4wine
-PORTVERSION= 1.1.r2
+DISTVERSION= 1.1-r2
PORTREVISION= 2
CATEGORIES= emulators deskutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION:S/.r/-r/}/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-r/}
MAINTAINER= koalative@gmail.com
COMMENT= QT4 front-end for WINE
diff --git a/emulators/ucon64/Makefile b/emulators/ucon64/Makefile
index 4205c35da2ba..fbf22119ca60 100644
--- a/emulators/ucon64/Makefile
+++ b/emulators/ucon64/Makefile
@@ -13,7 +13,7 @@ USES= gmake
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src/src
+WRKSRC_SUBDIR= src
PLIST_FILES= bin/ucon64 lib/libdiscmage.so