aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2015-03-17 01:56:59 +0800
committerjkim <jkim@FreeBSD.org>2015-03-17 01:56:59 +0800
commitf25ea6508c3b8258bedc9351ff79f0d20502d3e7 (patch)
tree70ece6122951a6c1484ab250fdf5e47c065a487f /emulators
parent46d0793a4c326abfadde9a4d8cdd3041e7e4ab6b (diff)
downloadfreebsd-ports-gnome-f25ea6508c3b8258bedc9351ff79f0d20502d3e7.tar.gz
freebsd-ports-gnome-f25ea6508c3b8258bedc9351ff79f0d20502d3e7.tar.zst
freebsd-ports-gnome-f25ea6508c3b8258bedc9351ff79f0d20502d3e7.zip
Fix the fix. My patch was actually wrong and upstream properly fixed it.
Pointy hat to: jkim
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose/Makefile2
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Devices-Input-PS2M.cpp18
2 files changed, 9 insertions, 11 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index fb2dcb064504..94cbf8b77e2a 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -3,7 +3,7 @@
PORTNAME= virtualbox-ose
DISTVERSION= 4.3.24
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${DISTVERSION}/ \
http://tmp.chruetertee.ch/ \
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Devices-Input-PS2M.cpp b/emulators/virtualbox-ose/files/patch-src-VBox-Devices-Input-PS2M.cpp
index 1a7d3040848c..93fcb409991d 100644
--- a/emulators/virtualbox-ose/files/patch-src-VBox-Devices-Input-PS2M.cpp
+++ b/emulators/virtualbox-ose/files/patch-src-VBox-Devices-Input-PS2M.cpp
@@ -1,13 +1,11 @@
--- src/VBox/Devices/Input/PS2M.cpp.orig 2015-03-02 10:09:15.000000000 -0500
-+++ src/VBox/Devices/Input/PS2M.cpp 2015-03-12 18:44:38.787177000 -0400
-@@ -712,8 +712,8 @@
- int8_t dX, dY, dZ;
++++ src/VBox/Devices/Input/PS2M.cpp 2015-03-16 13:38:03.324517000 -0400
+@@ -709,7 +709,7 @@
+ static void ps2mReportAccumulatedEvents(PPS2M pThis)
+ {
+ uint8_t val;
+- int8_t dX, dY, dZ;
++ int dX, dY, dZ;
/* Clamp the accumulated delta values to the allowed range. */
-- dX = RT_MIN(RT_MAX(pThis->iAccumX, -256), 255);
-- dY = RT_MIN(RT_MAX(pThis->iAccumY, -256), 255);
-+ dX = RT_MIN(RT_MAX(pThis->iAccumX, -128), 127);
-+ dY = RT_MIN(RT_MAX(pThis->iAccumY, -128), 127);
- dZ = RT_MIN(RT_MAX(pThis->iAccumZ, -8), 7);
-
- /* Start with the sync bit and buttons 1-3. */
+ dX = RT_MIN(RT_MAX(pThis->iAccumX, -256), 255);