aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-04 06:10:07 +0800
committeradamw <adamw@FreeBSD.org>2014-07-04 06:10:07 +0800
commitf45d51def02ec068ae84186a6dab176414298160 (patch)
tree74746fb76203f9d400410f98d6a44664ba2fc428 /emulators
parent9476595cef8e08663cbc9f671e8a3f995923b228 (diff)
downloadfreebsd-ports-gnome-f45d51def02ec068ae84186a6dab176414298160.tar.gz
freebsd-ports-gnome-f45d51def02ec068ae84186a6dab176414298160.tar.zst
freebsd-ports-gnome-f45d51def02ec068ae84186a6dab176414298160.zip
Remove NOPORTDOCS, and convert some stuff to OPTIONS helpers.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/darcnes/Makefile4
-rw-r--r--emulators/m2000/Makefile4
-rw-r--r--emulators/o2em/Makefile34
-rw-r--r--emulators/stella/Makefile4
-rw-r--r--emulators/wine/Makefile73
-rw-r--r--emulators/yape/Makefile4
6 files changed, 43 insertions, 80 deletions
diff --git a/emulators/darcnes/Makefile b/emulators/darcnes/Makefile
index 27c0412ee6bf..872ecdd373bb 100644
--- a/emulators/darcnes/Makefile
+++ b/emulators/darcnes/Makefile
@@ -23,6 +23,8 @@ USES= gmake
MAKE_ARGS= CC="${CC}" TARGET_CC="${CC}" CXX="${CXX}" TARGET_CXX="${CXX}" \
AS="${AS}" TARGET_AS="${CC}" LD="${LD}" TARGET_LD="${CC}"
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" || defined(WITHOUT_X86_ASM)
@@ -50,9 +52,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/darcnes ${STAGEDIR}${PREFIX}/bin
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.post.mk>
diff --git a/emulators/m2000/Makefile b/emulators/m2000/Makefile
index 06cc9c3fa491..8f61de2f91f4 100644
--- a/emulators/m2000/Makefile
+++ b/emulators/m2000/Makefile
@@ -46,6 +46,8 @@ USE_XORG= x11 xi
SUB_FILES= m2000.sh
PORTDOCS= M2000.txt
+OPTIONS_DEFINE= DOCS
+
post-extract:
${MKDIR} ${WRKDIR}/tapeconv
${UNZIP_CMD} ${DISTDIR}/${DIST_SUBDIR}/tapeconv.zip -d ${WRKDIR}/tapeconv
@@ -62,10 +64,8 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/P2000ROM.bin ${STAGEDIR}${DATADIR}
@${INSTALL_DATA} ${WRKSRC}/Default.fnt ${STAGEDIR}${DATADIR}
@${INSTALL_DATA} ${WRKSRC}/BASIC.bin ${STAGEDIR}${DATADIR}
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/M2000.txt ${STAGEDIR}${DOCSDIR}
-.endif
.for f in ${M2000TAPES}
@${GZCAT} ${DISTDIR}/${DIST_SUBDIR}/${f}.gz > ${WRKDIR}/${f}
@${INSTALL_DATA} ${WRKDIR}/${f} ${STAGEDIR}${DATADIR}
diff --git a/emulators/o2em/Makefile b/emulators/o2em/Makefile
index 02734e3afd2d..b50f3c5c6f62 100644
--- a/emulators/o2em/Makefile
+++ b/emulators/o2em/Makefile
@@ -1,24 +1,26 @@
# Created by: Gunter Wambaugh <techgunter@yahoo.com>
# $FreeBSD$
-PORTNAME= o2em
-PORTVERSION= 1.17
-PORTREVISION= 2
-CATEGORIES= emulators games
-MASTER_SITES= SF/${PORTNAME}/OldFiles:1 \
- http://o2em.sourceforge.net/files/:2
-DISTFILES= o2em117src.zip:1 \
- o2mainsamp.zip:2
-
-MAINTAINER= techgunter@yahoo.com
+PORTNAME= o2em
+PORTVERSION= 1.17
+PORTREVISION= 2
+CATEGORIES= emulators games
+MASTER_SITES= SF/${PORTNAME}/OldFiles:1 \
+ http://o2em.sourceforge.net/files/:2
+DISTFILES= o2em117src.zip:1 \
+ o2mainsamp.zip:2
+
+MAINTAINER= techgunter@yahoo.com
COMMENT= Odyssey2 / Videopac console emulator
-LIB_DEPENDS= alleg:${PORTSDIR}/devel/allegro
+LIB_DEPENDS= alleg:${PORTSDIR}/devel/allegro
-WRKSRC= ${WRKDIR}/o2em117src
-MAKEFILE= Makefile.freebsd
-USES= gmake zip
-LDFLAGS+= ${PTHREAD_LIBS}
+WRKSRC= ${WRKDIR}/o2em117src
+MAKEFILE= Makefile.freebsd
+USES= gmake zip
+LDFLAGS+= ${PTHREAD_LIBS}
+
+OPTIONS_DEFINE= DOCS
post-extract:
@${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|h|txt)" -print0 | \
@@ -32,12 +34,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/O2ROM.BIN ${STAGEDIR}${PREFIX}/${PORTNAME}/bios/o2rom.bin
@${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}/voice
${INSTALL_DATA} ${WRKDIR}/*.WAV ${STAGEDIR}${PREFIX}/${PORTNAME}/voice/
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/O2EM.txt ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/changelog.txt ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/license.txt ${STAGEDIR}${DOCSDIR}
-.endif
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/o2em/roms
diff --git a/emulators/stella/Makefile b/emulators/stella/Makefile
index 131c57a778c3..57f25a05754c 100644
--- a/emulators/stella/Makefile
+++ b/emulators/stella/Makefile
@@ -21,6 +21,8 @@ HAS_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
's|=sdl-config|="$$SDL_CONFIG"|g' ${WRKSRC}/configure
@@ -29,10 +31,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/stella ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/src/emucore/stella.pro ${STAGEDIR}${DATADIR}
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/docs && ${FIND} . | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 3c277c472e87..46a3a6fb1fe5 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -48,11 +48,12 @@ SHEBANG_FILES= tools/winemaker tools/winedump/function_grep.pl
USE_BZIP2= yes
USE_GL= glu
USE_XORG= xcomposite xcursor xi xpm xrandr xrender
+OPTIONS_SUB= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO
+OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO DOCS
DOSBOX_DESC= Use DOSBox to run MS-DOS programs
LIBXSLT_DESC= Use libxslt (only used by msxml3.dll)
WINEMAKER_DESC= Fully support winemaker (requires Perl)
@@ -66,66 +67,32 @@ PORTDATA= fonts/ generic.ppd l_intl.nls wine.inf
PORTSCOUT= limitw:1,even
-.include <bsd.port.pre.mk>
+CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
+CUPS_CONFIGURE_WITH= cups
-.if ${PORT_OPTIONS:MCUPS}
-CONFIGURE_ARGS+= --with-cups
-LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
-.else
-CONFIGURE_ARGS+= --without-cups
-.endif
+DOSBOX_RUN_DEPENDS= dosbox:${PORTSDIR}/emulators/dosbox
-.if ${PORT_OPTIONS:MDOSBOX}
-RUN_DEPENDS+= dosbox:${PORTSDIR}/emulators/dosbox
-.endif
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+GNUTLS_CONFIGURE_WITH= gnutls
-.if ${PORT_OPTIONS:MGNUTLS}
-CONFIGURE_ARGS+= --with-gnutls
-LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
-.else
-CONFIGURE_ARGS+= --without-gnutls
-.endif
+HAL_LIB_DEPENDS= libhal.so:${PORTSDIR}/sysutils/hal
+HAL_CONFIGURE_WITH= hal
-.if ${PORT_OPTIONS:MHAL}
-CONFIGURE_ARGS+= --with-hal
-LIB_DEPENDS+= libhal.so:${PORTSDIR}/sysutils/hal
-.else
-CONFIGURE_ARGS+= --without-hal
-.endif
+LDAP_USE= OPENLDAP=yes
+LDAP_CONFIGURE_WITH= ldap
-.if ${PORT_OPTIONS:MLDAP}
-CONFIGURE_ARGS+= --with-ldap
-USE_OPENLDAP= yes
-.else
-CONFIGURE_ARGS+= --without-ldap
-.endif
+LIBXSLT_LIB_DEPENDS= libxslt.so:${PORTSDIR}/textproc/libxslt
+LIBXSLT_CONFIGURE_WITH= xslt
-.if ${PORT_OPTIONS:MLIBXSLT}
-CONFIGURE_ARGS+= --with-xslt
-LIB_DEPENDS+= libxslt.so:${PORTSDIR}/textproc/libxslt
-.else
-CONFIGURE_ARGS+= --without-xslt
-.endif
+OPENAL_CONFIGURE_WITH= openal
-.if ${PORT_OPTIONS:MOPENAL}
-CONFIGURE_ARGS+= --with-openal
-PLIST_SUB+= OPENAL=""
-.else
-CONFIGURE_ARGS+= --without-openal
-PLIST_SUB+= OPENAL="@comment "
-.endif
+WINEMAKER_RUN_DEPENDS= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
-.if ${PORT_OPTIONS:MWINEMAKER}
-RUN_DEPENDS+= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
-.endif
+GECKO_RUN_DEPENDS= ${DATADIR}/gecko/wine_gecko-2.21-x86.msi:${PORTSDIR}/emulators/wine-gecko
-.if ${PORT_OPTIONS:MGECKO}
-RUN_DEPENDS+= ${DATADIR}/gecko/wine_gecko-2.21-x86.msi:${PORTSDIR}/emulators/wine-gecko
-.endif
+MONO_RUN_DEPENDS= ${DATADIR}/mono/wine-mono-0.0.8.msi:${PORTSDIR}/emulators/wine-mono
-.if ${PORT_OPTIONS:MMONO}
-RUN_DEPENDS+= ${DATADIR}/mono/wine-mono-0.0.8.msi:${PORTSDIR}/emulators/wine-mono
-.endif
+.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800000
IGNORE= lacks required sound support on FreeBSD before 8.0
@@ -138,15 +105,11 @@ post-install:
@${MV} -f ${STAGEDIR}${WINELIBDIR}/libwine.so.1.0 \
${STAGEDIR}${WINELIBDIR}/libwine.so.1
@${LN} -sf libwine.so.1 ${STAGEDIR}/${WINELIBDIR}/libwine.so
-.if !defined(NOPORTDOCS)
-@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README ANNOUNCE AUTHORS
@${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
@${INSTALL_DATA} ${WRKSRC}/programs/winedbg/README ${STAGEDIR}${DOCSDIR}/README.winedbg
@${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${STAGEDIR}${DOCSDIR}/README.winedump
-.endif
- @${ECHO}
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/emulators/yape/Makefile b/emulators/yape/Makefile
index 5fc88ab490b6..09a618537110 100644
--- a/emulators/yape/Makefile
+++ b/emulators/yape/Makefile
@@ -19,6 +19,8 @@ ALL_TARGET= yape
PLIST_FILES= bin/yape
PORTDOCS= README.SDL
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|cpp|h|txt)" -print0 | \
${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
@@ -32,9 +34,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/yape ${STAGEDIR}${PREFIX}/bin
post-install:
-.ifndef(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.SDL ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>