aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-08-09 05:32:20 +0800
committergerald <gerald@FreeBSD.org>2012-08-09 05:32:20 +0800
commitfc0b17337aa664abb455e396ebb64324a511176e (patch)
tree37d72e128570f082ca341de1b6296baa1b09a04e /emulators
parent028f2838c8a73bf97a9ecc940ad2beb8a7d808c6 (diff)
downloadfreebsd-ports-gnome-fc0b17337aa664abb455e396ebb64324a511176e.tar.gz
freebsd-ports-gnome-fc0b17337aa664abb455e396ebb64324a511176e.tar.zst
freebsd-ports-gnome-fc0b17337aa664abb455e396ebb64324a511176e.zip
Add two options that pull in a Gecko MSI package and a Mono MSI package,
emulators/wine-gecko-devel and emulators/wine-mono, respectively. Submitted by: David Naylor <naylor.b.david@gmail.com>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 8c952ac89801..c34188a01dd4 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -63,11 +63,13 @@ USE_XORG= xcursor xi xpm xrandr xrender
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER
+OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO
DOSBOX_DESC= Use DOSBox to run MS-DOS programs
LIBXSLT_DESC= Use libxslt (only used by msxml3.dll)
WINEMAKER_DESC= Fully support winemaker (requires Perl)
+GECKO_DESC= Bundle Gecko MSI package for Wine
+MONO_DESC= Bundle Mono MSI package for Wine
PORTDATA= fonts/ generic.ppd l_intl.nls wine.inf
@@ -125,6 +127,14 @@ PLIST_SUB+= OPENAL="@comment "
RUN_DEPENDS+= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
.endif
+.if ${PORT_OPTIONS:MGECKO}
+RUN_DEPENDS+= ${DATADIR}/gecko/wine_gecko-1.7-x86.msi:${PORTSDIR}/emulators/wine-gecko-devel
+.endif
+
+.if ${PORT_OPTIONS:MMONO}
+RUN_DEPENDS+= ${DATADIR}/mono/wine-mono-0.0.4.msi:${PORTSDIR}/emulators/wine-mono
+.endif
+
.if ${OSVERSION} < 800000
IGNORE= lacks required sound support on FreeBSD before 8.0
.endif