aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-04-09 10:18:39 +0800
committeralepulver <alepulver@FreeBSD.org>2007-04-09 10:18:39 +0800
commit06a6881fef6348d81265fcd19f695178adfbcdad (patch)
tree6a8a1c09098f26ea477e34e84f67e74877d5f809 /emulators
parentad98847a10128229a2ad95943917711d7e11d3cd (diff)
downloadfreebsd-ports-gnome-06a6881fef6348d81265fcd19f695178adfbcdad.tar.gz
freebsd-ports-gnome-06a6881fef6348d81265fcd19f695178adfbcdad.tar.zst
freebsd-ports-gnome-06a6881fef6348d81265fcd19f695178adfbcdad.zip
- Update to version 0.113.
Reported by: distfiles survey
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mess/Makefile5
-rw-r--r--emulators/mess/distinfo6
-rw-r--r--emulators/mess/files/patch-makefile.sdl114
-rw-r--r--emulators/mess/pkg-plist6
-rw-r--r--emulators/sdlmess/Makefile5
-rw-r--r--emulators/sdlmess/distinfo6
-rw-r--r--emulators/sdlmess/files/patch-makefile.sdl114
-rw-r--r--emulators/sdlmess/pkg-plist6
8 files changed, 194 insertions, 68 deletions
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index e76ed66bd353..11656b24f863 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmess
-PORTVERSION= 0.112
+PORTVERSION= 0.113
CATEGORIES= emulators
MASTER_SITES= http://rbelmont.mameworld.info/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -25,7 +25,8 @@ SUB_FILES= ${PORTNAME} pkg-message
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/${PORTNAME}
-.for f in chdman file2str imgtool messdocs messtest sdlmess
+.for f in obj/sdlmess/file2str sdlmess testkeys dat2html messtest messdocs \
+ imgtool romcmp chdman jedutil makemeta regrep
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${f:S/sdl//}
.endfor
${MKDIR} ${DATADIR}
diff --git a/emulators/mess/distinfo b/emulators/mess/distinfo
index 2216eaba94b2..f5c0bf8a3839 100644
--- a/emulators/mess/distinfo
+++ b/emulators/mess/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmess0112.zip) = 9c5c09527cd5ba5863204a87b1a0db9b
-SHA256 (sdlmess0112.zip) = 2c60d49d3583a0e6dadc5fa71f0cc2fb927b3885c610ec3599a2f3cc4a1c14d7
-SIZE (sdlmess0112.zip) = 25600058
+MD5 (sdlmess0113.zip) = d73b55eda07d0615a558f767c440546f
+SHA256 (sdlmess0113.zip) = b5228907ea9b335573f7d5a88a7a98d7637b39dfb138ed8c0bda87621c6cb0af
+SIZE (sdlmess0113.zip) = 28302634
diff --git a/emulators/mess/files/patch-makefile.sdl b/emulators/mess/files/patch-makefile.sdl
index 1e911c1715e0..b59a75950026 100644
--- a/emulators/mess/files/patch-makefile.sdl
+++ b/emulators/mess/files/patch-makefile.sdl
@@ -1,18 +1,18 @@
---- ./makefile.sdl.orig Wed Feb 7 15:35:34 2007
-+++ ./makefile.sdl Fri Feb 23 01:26:06 2007
-@@ -37,7 +37,7 @@
- #
- # for SDLMESS, set this to linux or macosx (lowercase is important!)
- #
+--- ./makefile.sdl.orig Fri Mar 9 01:10:42 2007
++++ ./makefile.sdl Sun Apr 8 20:07:08 2007
+@@ -52,7 +52,7 @@
+ # for SDLMAME, set this to linux, freebsd, win32, or macosx (lowercase is important!)
+ #------------------------------------------------------------------------------------
+
-SUBARCH = linux
+SUBARCH = freebsd
#-------------------------------------------------
-@@ -48,11 +48,13 @@
+@@ -63,11 +63,13 @@
# uncomment next line to include the debugger
- # DEBUG = 1
-
+ #DEBUG = 1
+
+ifeq ($(ARCH),i386)
# uncomment next line to use DRC MIPS3 engine
X86_MIPS3_DRC = 1
@@ -23,22 +23,40 @@
#-------------------------------------------------
# specify build options; see each option below
-@@ -155,8 +157,8 @@
+@@ -128,17 +130,6 @@
+ PPC = 1
+ endif
+
+-ifdef PPC
+-X86_MIPS3_DRC =
+-X86_PPC_DRC =
+-endif
+-
+-# disable DRC cores for 64-bit builds
+-ifdef PTR64
+-X86_MIPS3_DRC =
+-X86_PPC_DRC =
+-endif
+-
+ # Mac builds always need EXPAT and ZLIB built
+ ifeq ($(SUBARCH),macosx)
+ BUILD_EXPAT = 1
+@@ -174,8 +165,8 @@
# compiler, linker and utilities
AR = @ar
-CC = @gcc
--LD = gcc
+-LD = @gcc
+CC := @$(CC)
+LD = $(CC)
MD = -mkdir
RM = @rm -f
-@@ -167,49 +169,8 @@
- #-------------------------------------------------
+@@ -191,49 +182,8 @@
+ endif
# by default, don't compile for a specific target CPU
--NAME = sdl$(PREFIX)$(TARGET)
+-NAME = $(PREFIX)$(TARGET)
-ARCH =
-
-# architecture-specific builds get extra options
@@ -85,16 +103,54 @@
# debug builds just get the 'd' suffix and nothing more
ifdef DEBUG
-@@ -255,7 +216,7 @@
- MESSTEST = messtest$(EXE)
- MESSDOCS = messdocs$(EXE)
+@@ -253,18 +203,22 @@
+ # compile-time definitions
+ #-------------------------------------------------
--CFLAGS = $(OPT_FLAGS) -std=gnu89 -Imess -Isrc -Isrc/includes -Isrc/$(MAMEOS) -I$(OBJ)/mess/layout -I$(OBJ)/layout -Imess/$(MAMEOS)
-+CFLAGS += $(OPT_FLAGS) -std=gnu89 -Imess -Isrc -Isrc/includes -Isrc/$(MAMEOS) -I$(OBJ)/mess/layout -I$(OBJ)/layout -Imess/$(MAMEOS) -I$(LOCALBASE)/include -I$(X11BASE)/include
+-ifdef PPC
+-DEFS = -DPPC_ASM -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1 -Dbool=int
+-else
+-ifdef PTR64
+ DEFS = -DLSB_FIRST -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1
+-else
+-DEFS = -DX86_ASM -DLSB_FIRST -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1
++
++ifeq ($(ARCH),i386)
++DEFS += -DX86_ASM
++endif
++
++ifeq ($(ARCH),powerpc)
++DEFS += -DPPC_ASM -Dbool=int
+ endif
++
++ifneq ($(shell echo $(ARCH) | grep -v 64),)
++PTR64 = yes
+ endif
+
+ ifdef PTR64
+-DEFS += -DPTR64
++DEFS += -DLSB_FIRST -DPTR64
+ endif
+
+ ifdef DEBUG
+@@ -275,7 +229,7 @@
+ # compile and linking flags
+ #-------------------------------------------------
- ifdef SYMBOLS
- ifdef PPC
-@@ -267,7 +228,7 @@
+-CFLAGS = \
++CFLAGS += \
+ $(OPT_FLAGS) \
+ -std=gnu89 \
+ -I$(SRC)/$(TARGET) \
+@@ -286,6 +240,7 @@
+ -I$(SRC)/lib/util \
+ -I$(SRC)/osd \
+ -I$(SRC)/osd/$(MAMEOS) \
++ -I$(LOCALBASE)/include -I$(X11BASE)/include
+
+ ifdef MESS
+ CFLAGS += \
+@@ -304,7 +259,7 @@
endif # PPC
endif # SYMBOLS
@@ -103,7 +159,7 @@
-Wall \
-Wpointer-arith \
-Wbad-function-cast \
-@@ -279,7 +240,7 @@
+@@ -316,7 +271,7 @@
-Wdeclaration-after-statement
ifneq ($(OPTIMIZE),0)
@@ -112,22 +168,22 @@
endif
CFLAGS += -O$(OPTIMIZE)
-@@ -287,11 +248,9 @@
+@@ -329,11 +284,9 @@
# extra options needed *only* for the osd files
CFLAGSOSDEPEND = $(CFLAGS)
-LDFLAGS = -WO
-+LDFLAGS += -WO -L$(LOCALBASE)/lib -L$(X11BASE)/lib
++LDFLAGS = -WO -L$(LOCALBASE)/lib -L$(X11BASE)/lib
-ifdef SYMBOLS
--LDFLAGS =
+-LDFLAGS =
-else
+ifndef SYMBOLS
LDFLAGS += -s
endif
-@@ -404,6 +363,10 @@
- # add SDLMAME subarch definitions
+@@ -402,6 +355,10 @@
+
ifeq ($(SUBARCH),linux)
CFLAGS += -DSDLMAME_LINUX
+endif
@@ -136,4 +192,4 @@
+CFLAGS += -DSDLMAME_FREEBSD -DSDLMAME_NO64BITIO
endif
- ifeq ($(SUBARCH),macosx)
+ ifeq ($(SUBARCH),freebsd)
diff --git a/emulators/mess/pkg-plist b/emulators/mess/pkg-plist
index d179fde71646..506379eac8db 100644
--- a/emulators/mess/pkg-plist
+++ b/emulators/mess/pkg-plist
@@ -1,10 +1,16 @@
bin/sdlmess
libexec/chdman
+libexec/dat2html
libexec/file2str
libexec/imgtool
+libexec/jedutil
+libexec/makemeta
libexec/mess
libexec/messdocs
libexec/messtest
+libexec/regrep
+libexec/romcmp
+libexec/testkeys
%%PORTDOCS%%%%DOCSDIR%%/SDLMESS.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/credits.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/faq.htm
diff --git a/emulators/sdlmess/Makefile b/emulators/sdlmess/Makefile
index e76ed66bd353..11656b24f863 100644
--- a/emulators/sdlmess/Makefile
+++ b/emulators/sdlmess/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmess
-PORTVERSION= 0.112
+PORTVERSION= 0.113
CATEGORIES= emulators
MASTER_SITES= http://rbelmont.mameworld.info/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -25,7 +25,8 @@ SUB_FILES= ${PORTNAME} pkg-message
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/${PORTNAME}
-.for f in chdman file2str imgtool messdocs messtest sdlmess
+.for f in obj/sdlmess/file2str sdlmess testkeys dat2html messtest messdocs \
+ imgtool romcmp chdman jedutil makemeta regrep
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${f:S/sdl//}
.endfor
${MKDIR} ${DATADIR}
diff --git a/emulators/sdlmess/distinfo b/emulators/sdlmess/distinfo
index 2216eaba94b2..f5c0bf8a3839 100644
--- a/emulators/sdlmess/distinfo
+++ b/emulators/sdlmess/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmess0112.zip) = 9c5c09527cd5ba5863204a87b1a0db9b
-SHA256 (sdlmess0112.zip) = 2c60d49d3583a0e6dadc5fa71f0cc2fb927b3885c610ec3599a2f3cc4a1c14d7
-SIZE (sdlmess0112.zip) = 25600058
+MD5 (sdlmess0113.zip) = d73b55eda07d0615a558f767c440546f
+SHA256 (sdlmess0113.zip) = b5228907ea9b335573f7d5a88a7a98d7637b39dfb138ed8c0bda87621c6cb0af
+SIZE (sdlmess0113.zip) = 28302634
diff --git a/emulators/sdlmess/files/patch-makefile.sdl b/emulators/sdlmess/files/patch-makefile.sdl
index 1e911c1715e0..b59a75950026 100644
--- a/emulators/sdlmess/files/patch-makefile.sdl
+++ b/emulators/sdlmess/files/patch-makefile.sdl
@@ -1,18 +1,18 @@
---- ./makefile.sdl.orig Wed Feb 7 15:35:34 2007
-+++ ./makefile.sdl Fri Feb 23 01:26:06 2007
-@@ -37,7 +37,7 @@
- #
- # for SDLMESS, set this to linux or macosx (lowercase is important!)
- #
+--- ./makefile.sdl.orig Fri Mar 9 01:10:42 2007
++++ ./makefile.sdl Sun Apr 8 20:07:08 2007
+@@ -52,7 +52,7 @@
+ # for SDLMAME, set this to linux, freebsd, win32, or macosx (lowercase is important!)
+ #------------------------------------------------------------------------------------
+
-SUBARCH = linux
+SUBARCH = freebsd
#-------------------------------------------------
-@@ -48,11 +48,13 @@
+@@ -63,11 +63,13 @@
# uncomment next line to include the debugger
- # DEBUG = 1
-
+ #DEBUG = 1
+
+ifeq ($(ARCH),i386)
# uncomment next line to use DRC MIPS3 engine
X86_MIPS3_DRC = 1
@@ -23,22 +23,40 @@
#-------------------------------------------------
# specify build options; see each option below
-@@ -155,8 +157,8 @@
+@@ -128,17 +130,6 @@
+ PPC = 1
+ endif
+
+-ifdef PPC
+-X86_MIPS3_DRC =
+-X86_PPC_DRC =
+-endif
+-
+-# disable DRC cores for 64-bit builds
+-ifdef PTR64
+-X86_MIPS3_DRC =
+-X86_PPC_DRC =
+-endif
+-
+ # Mac builds always need EXPAT and ZLIB built
+ ifeq ($(SUBARCH),macosx)
+ BUILD_EXPAT = 1
+@@ -174,8 +165,8 @@
# compiler, linker and utilities
AR = @ar
-CC = @gcc
--LD = gcc
+-LD = @gcc
+CC := @$(CC)
+LD = $(CC)
MD = -mkdir
RM = @rm -f
-@@ -167,49 +169,8 @@
- #-------------------------------------------------
+@@ -191,49 +182,8 @@
+ endif
# by default, don't compile for a specific target CPU
--NAME = sdl$(PREFIX)$(TARGET)
+-NAME = $(PREFIX)$(TARGET)
-ARCH =
-
-# architecture-specific builds get extra options
@@ -85,16 +103,54 @@
# debug builds just get the 'd' suffix and nothing more
ifdef DEBUG
-@@ -255,7 +216,7 @@
- MESSTEST = messtest$(EXE)
- MESSDOCS = messdocs$(EXE)
+@@ -253,18 +203,22 @@
+ # compile-time definitions
+ #-------------------------------------------------
--CFLAGS = $(OPT_FLAGS) -std=gnu89 -Imess -Isrc -Isrc/includes -Isrc/$(MAMEOS) -I$(OBJ)/mess/layout -I$(OBJ)/layout -Imess/$(MAMEOS)
-+CFLAGS += $(OPT_FLAGS) -std=gnu89 -Imess -Isrc -Isrc/includes -Isrc/$(MAMEOS) -I$(OBJ)/mess/layout -I$(OBJ)/layout -Imess/$(MAMEOS) -I$(LOCALBASE)/include -I$(X11BASE)/include
+-ifdef PPC
+-DEFS = -DPPC_ASM -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1 -Dbool=int
+-else
+-ifdef PTR64
+ DEFS = -DLSB_FIRST -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1
+-else
+-DEFS = -DX86_ASM -DLSB_FIRST -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1
++
++ifeq ($(ARCH),i386)
++DEFS += -DX86_ASM
++endif
++
++ifeq ($(ARCH),powerpc)
++DEFS += -DPPC_ASM -Dbool=int
+ endif
++
++ifneq ($(shell echo $(ARCH) | grep -v 64),)
++PTR64 = yes
+ endif
+
+ ifdef PTR64
+-DEFS += -DPTR64
++DEFS += -DLSB_FIRST -DPTR64
+ endif
+
+ ifdef DEBUG
+@@ -275,7 +229,7 @@
+ # compile and linking flags
+ #-------------------------------------------------
- ifdef SYMBOLS
- ifdef PPC
-@@ -267,7 +228,7 @@
+-CFLAGS = \
++CFLAGS += \
+ $(OPT_FLAGS) \
+ -std=gnu89 \
+ -I$(SRC)/$(TARGET) \
+@@ -286,6 +240,7 @@
+ -I$(SRC)/lib/util \
+ -I$(SRC)/osd \
+ -I$(SRC)/osd/$(MAMEOS) \
++ -I$(LOCALBASE)/include -I$(X11BASE)/include
+
+ ifdef MESS
+ CFLAGS += \
+@@ -304,7 +259,7 @@
endif # PPC
endif # SYMBOLS
@@ -103,7 +159,7 @@
-Wall \
-Wpointer-arith \
-Wbad-function-cast \
-@@ -279,7 +240,7 @@
+@@ -316,7 +271,7 @@
-Wdeclaration-after-statement
ifneq ($(OPTIMIZE),0)
@@ -112,22 +168,22 @@
endif
CFLAGS += -O$(OPTIMIZE)
-@@ -287,11 +248,9 @@
+@@ -329,11 +284,9 @@
# extra options needed *only* for the osd files
CFLAGSOSDEPEND = $(CFLAGS)
-LDFLAGS = -WO
-+LDFLAGS += -WO -L$(LOCALBASE)/lib -L$(X11BASE)/lib
++LDFLAGS = -WO -L$(LOCALBASE)/lib -L$(X11BASE)/lib
-ifdef SYMBOLS
--LDFLAGS =
+-LDFLAGS =
-else
+ifndef SYMBOLS
LDFLAGS += -s
endif
-@@ -404,6 +363,10 @@
- # add SDLMAME subarch definitions
+@@ -402,6 +355,10 @@
+
ifeq ($(SUBARCH),linux)
CFLAGS += -DSDLMAME_LINUX
+endif
@@ -136,4 +192,4 @@
+CFLAGS += -DSDLMAME_FREEBSD -DSDLMAME_NO64BITIO
endif
- ifeq ($(SUBARCH),macosx)
+ ifeq ($(SUBARCH),freebsd)
diff --git a/emulators/sdlmess/pkg-plist b/emulators/sdlmess/pkg-plist
index d179fde71646..506379eac8db 100644
--- a/emulators/sdlmess/pkg-plist
+++ b/emulators/sdlmess/pkg-plist
@@ -1,10 +1,16 @@
bin/sdlmess
libexec/chdman
+libexec/dat2html
libexec/file2str
libexec/imgtool
+libexec/jedutil
+libexec/makemeta
libexec/mess
libexec/messdocs
libexec/messtest
+libexec/regrep
+libexec/romcmp
+libexec/testkeys
%%PORTDOCS%%%%DOCSDIR%%/SDLMESS.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/credits.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/faq.htm