aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-12-06 02:27:31 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-12-06 02:27:31 +0800
commit08bc58f732431a575acbedfbd1a3ae718eb02700 (patch)
tree600dfb8281e66527f2684e94627e1ba5cf18e3d1 /emulators
parent499b52f0692e5b45af4cefc9d586669281ad31b0 (diff)
downloadfreebsd-ports-gnome-08bc58f732431a575acbedfbd1a3ae718eb02700.tar.gz
freebsd-ports-gnome-08bc58f732431a575acbedfbd1a3ae718eb02700.tar.zst
freebsd-ports-gnome-08bc58f732431a575acbedfbd1a3ae718eb02700.zip
- Add LICENSE_FILE
- Pet portlint - Switch to options helpers - Fix return-type warnings and remove dangerous -Wno-return-type
Diffstat (limited to 'emulators')
-rw-r--r--emulators/snes9express/Makefile12
-rw-r--r--emulators/snes9express/files/patch-frend.cc26
2 files changed, 32 insertions, 6 deletions
diff --git a/emulators/snes9express/Makefile b/emulators/snes9express/Makefile
index 5b59b4bff059..02ee147da133 100644
--- a/emulators/snes9express/Makefile
+++ b/emulators/snes9express/Makefile
@@ -11,22 +11,22 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GTK interface for snes9x
LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BROKEN_sparc64= does not compile on sparc64
RUN_DEPENDS= snes9x:emulators/snes9x
-USE_GNOME= gtk20
USES= gettext pkgconfig
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
-BROKEN_sparc64= does not compile on sparc64
-
PORTDOCS= AUTHORS ChangeLog NEWS README
PLIST_FILES= bin/${PORTNAME} \
%%DATADIR%%/snes.s9xskin \
%%DATADIR%%/snsp.s9xskin
-# fix build with clang
-CFLAGS+= -Wno-return-type
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|(gzFile\*)||' \
@@ -38,6 +38,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.s9xskin ${STAGEDIR}${DATADIR}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/emulators/snes9express/files/patch-frend.cc b/emulators/snes9express/files/patch-frend.cc
index a0cc77b7014b..2818d94c3f0d 100644
--- a/emulators/snes9express/files/patch-frend.cc
+++ b/emulators/snes9express/files/patch-frend.cc
@@ -1,6 +1,30 @@
--- frend.cc.orig 2009-12-21 22:38:54 UTC
+++ frend.cc
-@@ -2527,7 +2527,7 @@ void Window::addMenu(const char*label, M
+@@ -379,7 +379,7 @@ void dimension<T>::input(std::istream& i
+ i >> buf;
+ unsigned int l = buf.size(), xpos = 0, ypos = 0;
+ if(l < 3)
+- return i;
++ return;
+ if(buf[0]=='(')
+ xpos++;
+ if(buf[l-1]==',')
+@@ -400,13 +400,12 @@ void dimension<T>::input(std::istream& i
+ const char*buf3 = buf.c_str();
+ _x = strtol(&(buf[xpos]), NULL, 0);
+ _y = strtol(&(buf[ypos]), NULL, 0);
+- return i;
+ }
+
+ template <class T>
+ void dimension<T>::print(std::ostream& o) const
+ {
+- return o << "(" << _x << ", " << _y << ")";
++ o << "(" << _x << ", " << _y << ")";
+ }
+
+ /* ############################## Color ################################ */
+@@ -2527,7 +2526,7 @@ void Window::addMenu(const char*label, M
{
if(strcmp(items[i].label, "-"))
{