aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorfenner <fenner@FreeBSD.org>2001-10-06 13:45:30 +0800
committerfenner <fenner@FreeBSD.org>2001-10-06 13:45:30 +0800
commit513710a41d503e48bdf41d7b766dc2d0bd15be9c (patch)
tree60245a1866f40632ce5e15d4af8cab71e52b17eb /emulators
parent44d7be81c2d1c54f3d2724137a90bbb053ca1965 (diff)
downloadfreebsd-ports-gnome-513710a41d503e48bdf41d7b766dc2d0bd15be9c.tar.gz
freebsd-ports-gnome-513710a41d503e48bdf41d7b766dc2d0bd15be9c.tar.zst
freebsd-ports-gnome-513710a41d503e48bdf41d7b766dc2d0bd15be9c.zip
Add full path to sysctl; not everyone has /sbin in their PATH. (If we
still support systems where sysctl is in /usr/bin then this needs to be fixed.) Noticed by: distfile survey
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-7/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/emulators/linux_base-7/Makefile b/emulators/linux_base-7/Makefile
index c161ef88ede9..7c218442a82a 100644
--- a/emulators/linux_base-7/Makefile
+++ b/emulators/linux_base-7/Makefile
@@ -108,7 +108,7 @@ BRAND_FILES= bin/rpm sbin/ldconfig sbin/sln
FALLBACK_ELF_MIB= kern.fallback_elf_brand
LINUX_ELF= 3
-PREVIOUS_ELF!= sysctl -n ${FALLBACK_ELF_MIB}
+PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
do-patch:
@${DO_NADA}
@@ -132,7 +132,7 @@ do-install:
# Install all packages. Ignore dependencies just like the Red Hat installer.
# Also, set the ELF fallback brand to Linux, so that we don't have to do
# anything special to run staticly linked binaries.
- @sysctl -w ${FALLBACK_ELF_MIB}=${LINUX_ELF}
+ @/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${LINUX_ELF}
@for R in ${DISTFILES}; do \
${ECHO} $$R; \
${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
@@ -146,7 +146,7 @@ do-install:
${ECHO} $$R; \
${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
- @sysctl -w ${FALLBACK_ELF_MIB}=${PREVIOUS_ELF}
+ @/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${PREVIOUS_ELF}
#
# Install yp.conf as a hint to NIS users
#