aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgrembo <grembo@FreeBSD.org>2014-06-02 01:06:55 +0800
committergrembo <grembo@FreeBSD.org>2014-06-02 01:06:55 +0800
commit5609554721f160c2eca57756388b9504cd707b21 (patch)
tree23e1888e8afd714be4491ac205bf268db6597db0 /emulators
parentdf3edca40adc4f931a1a6442656944291933a560 (diff)
downloadfreebsd-ports-gnome-5609554721f160c2eca57756388b9504cd707b21.tar.gz
freebsd-ports-gnome-5609554721f160c2eca57756388b9504cd707b21.tar.zst
freebsd-ports-gnome-5609554721f160c2eca57756388b9504cd707b21.zip
Stagify.
Note that this won't fix the port to build on 10 or 11. Reviewed by: flo (mentor) Approved by: flo (mentor)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/zsnes/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 74cffede4dca..3a42ac4d8a74 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -14,7 +14,7 @@ COMMENT= Intel x86 only Super Nintendo Entertainment System (SNES) Emulator
# This must be >= 0.98!
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= non-portable, for a portable emulator see emulators/snes9x
@@ -32,14 +32,12 @@ USES= gmake tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-cpucheck
-MAN1= zsnes.1
-PLIST_FILES= bin/zsnes
+PLIST_FILES= bin/zsnes man/man1/zsnes.1.gz
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUGGER}
@@ -83,7 +81,7 @@ post-patch:
's|-O3||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/zsnes ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/linux/zsnes.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/zsnes ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/linux/zsnes.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>