aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-28 21:20:05 +0800
committerpav <pav@FreeBSD.org>2005-07-28 21:20:05 +0800
commit5bfeafa00352905be81f9aa7418e3e1e30bfb78b (patch)
tree456164510e376eda70df05d81da389a4137e729c /emulators
parentb30c3b440a3d898b085524961cb8a901f45c60b3 (diff)
downloadfreebsd-ports-gnome-5bfeafa00352905be81f9aa7418e3e1e30bfb78b.tar.gz
freebsd-ports-gnome-5bfeafa00352905be81f9aa7418e3e1e30bfb78b.tar.zst
freebsd-ports-gnome-5bfeafa00352905be81f9aa7418e3e1e30bfb78b.zip
SkyEye is an Open Source Software Project. The goal of SkyEye is to provide an
integrated simulation environment in Linux and Windows. SkyEye environment simulates typical Embedded Computer Systems (Now it supports Atmel AT91 board based on ARM7TDMI CPU, board based on ARM720T CPU, board based on StrongARM (SA1100/SA1110). You can run some Embedded Operation System such as ARM Linux, uClinux, uc/O PR: ports/83770 Submitted by: Ruan Wei <iamayan@gmail.com>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/skyeye/Makefile42
-rw-r--r--emulators/skyeye/distinfo2
-rw-r--r--emulators/skyeye/files/patch-Makefile.in51
-rw-r--r--emulators/skyeye/files/patch-etc_Makefile.in11
-rw-r--r--emulators/skyeye/files/patch-gdb_doc_Makefile.in10
-rw-r--r--emulators/skyeye/files/patch-sim_arm_armdefs.h24
-rw-r--r--emulators/skyeye/files/patch-sim_arm_configure12
-rw-r--r--emulators/skyeye/files/patch-sim_arm_skyeye-ne2k.c27
-rw-r--r--emulators/skyeye/files/patch-sim_arm_skyeye_net_tuntap.c68
-rw-r--r--emulators/skyeye/files/patch-sim_arm_skyeye_net_vnet.c15
-rw-r--r--emulators/skyeye/files/patch-tcl_unix_Makefile.in19
-rw-r--r--emulators/skyeye/files/patch-usegtk-1.2.sh9
-rw-r--r--emulators/skyeye/files/patch-usegtk-2.0.sh9
-rw-r--r--emulators/skyeye/pkg-descr9
-rw-r--r--emulators/skyeye/pkg-plist288
16 files changed, 597 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 9da68d254d93..86fc0a3867a1 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -98,6 +98,7 @@
SUBDIR += sim
SUBDIR += sim6811
SUBDIR += ski
+ SUBDIR += skyeye
SUBDIR += snes9express
SUBDIR += snes9x
SUBDIR += spim
diff --git a/emulators/skyeye/Makefile b/emulators/skyeye/Makefile
new file mode 100644
index 000000000000..b9bc59ad1e42
--- /dev/null
+++ b/emulators/skyeye/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: skyeye
+# Date created: Mon July 18, 2005
+# Whom: Ruan Wei (iamayan@gmail.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= skyeye
+PORTVERSION= 0.9.5
+CATEGORIES= emulators
+MASTER_SITES= http://download.gro.clinux.org/skyeye/
+
+MAINTAINER= iamayan@gmail.com
+COMMENT= An environment simulates typical ARM-base embedded computer systems
+
+BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gtk20
+
+WRKSRC= ${WRKDIR}/skyeye
+
+MAN1= arm-elf-gdb.1 arm-elf-run.1
+INFO= mmalloc
+
+ONLY_FOR_ARCHS= i386
+
+SKYEYETARGET?= arm-elf
+CONFIGURE_TARGET= --target=${SKYEYETARGET}
+CONFIGURE_ARGS+= --without-gtk-prefix \
+ --without-gtk-exec-prefix \
+ --disable-gtktest
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not compile"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/skyeye/distinfo b/emulators/skyeye/distinfo
new file mode 100644
index 000000000000..890d0ebf8e2a
--- /dev/null
+++ b/emulators/skyeye/distinfo
@@ -0,0 +1,2 @@
+MD5 (skyeye-0.9.5.tar.bz2) = 3976381bcb83bb0fe4c57175c2e3b602
+SIZE (skyeye-0.9.5.tar.bz2) = 18134145
diff --git a/emulators/skyeye/files/patch-Makefile.in b/emulators/skyeye/files/patch-Makefile.in
new file mode 100644
index 000000000000..cbb5adb97b9e
--- /dev/null
+++ b/emulators/skyeye/files/patch-Makefile.in
@@ -0,0 +1,51 @@
+--- Makefile.in.orig Tue Jul 19 22:33:06 2005
++++ Makefile.in Tue Jul 19 22:36:07 2005
+@@ -668,7 +668,6 @@
+ install-autoconf \
+ install-automake \
+ install-bash \
+- install-bfd \
+ install-bzip2 \
+ install-opcodes \
+ install-binutils \
+@@ -693,9 +692,6 @@
+ install-gzip \
+ install-hello \
+ install-indent \
+- install-intl \
+- install-tcl \
+- install-itcl \
+ install-ld \
+ install-libgui \
+ install-libiberty \
+@@ -707,7 +703,6 @@
+ install-perl \
+ install-prms \
+ install-rcs \
+- install-readline \
+ install-recode \
+ install-sed \
+ install-send-pr \
+@@ -748,10 +743,7 @@
+ INSTALL_X11_MODULES = \
+ install-gdb \
+ install-guile \
+- install-expect \
+- install-tclX \
+- install-tk \
+- install-tix
++ install-expect
+
+ # This is a list of the targets for all of the modules which are compiled
+ # using $(TARGET_FLAGS_TO_PASS).
+@@ -1755,8 +1747,8 @@
+ all-target-libiberty: configure-target-libiberty
+ all-target: $(ALL_TARGET_MODULES)
+ install-target: $(INSTALL_TARGET_MODULES)
+-install-gdb: install-tcl install-tk install-itcl install-tix install-libgui
+-install-sid: install-tcl install-tk
++install-gdb:
++install-sid:
+ ### other supporting targets
+
+ MAKEDIRS= \
diff --git a/emulators/skyeye/files/patch-etc_Makefile.in b/emulators/skyeye/files/patch-etc_Makefile.in
new file mode 100644
index 000000000000..4807e076e2e0
--- /dev/null
+++ b/emulators/skyeye/files/patch-etc_Makefile.in
@@ -0,0 +1,11 @@
+--- etc/Makefile.in.orig Tue Jul 19 23:03:00 2005
++++ etc/Makefile.in Tue Jul 19 23:03:14 2005
+@@ -52,7 +52,7 @@
+ all:
+
+ # We want install to imply install-info as per GNU standards.
+-install: install-info
++install:
+
+ uninstall:
+
diff --git a/emulators/skyeye/files/patch-gdb_doc_Makefile.in b/emulators/skyeye/files/patch-gdb_doc_Makefile.in
new file mode 100644
index 000000000000..873cada9c1b3
--- /dev/null
+++ b/emulators/skyeye/files/patch-gdb_doc_Makefile.in
@@ -0,0 +1,10 @@
+--- gdb/doc/Makefile.in.orig Tue Jul 19 22:38:16 2005
++++ gdb/doc/Makefile.in Tue Jul 19 22:38:36 2005
+@@ -449,6 +449,6 @@
+ maintainer-clean realclean: distclean
+ rm -f GDBvn.texi *.info* *.dvi *.ps *.html *.pdf
+
+-install: install-info
++install:
+
+ uninstall: uninstall-info
diff --git a/emulators/skyeye/files/patch-sim_arm_armdefs.h b/emulators/skyeye/files/patch-sim_arm_armdefs.h
new file mode 100644
index 000000000000..128895d7afe2
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_armdefs.h
@@ -0,0 +1,24 @@
+--- sim/arm/armdefs.h.orig Wed May 11 22:10:09 2005
++++ sim/arm/armdefs.h Sat Jul 16 18:25:48 2005
+@@ -22,6 +22,13 @@
+ #include <stdlib.h>
+ #include <errno.h>
+
++
++#ifdef __FreeBSD__
++#include <sys/select.h>
++#define MAP_ANONYMOUS MAP_ANON
++#endif
++
++
+ //teawater add for arm2x86 2005.02.14-------------------------------------------
+ #include <sys/mman.h>
+ //AJ2D--------------------------------------------------------------------------
+@@ -63,6 +70,7 @@
+ typedef unsigned char uint8_t;
+ typedef unsigned short uint16_t;
+ typedef unsigned int uint32_t;
++typedef int int32_t;
+ #if defined (__x86_64__)
+ typedef unsigned long uint64_t;
+ #else
diff --git a/emulators/skyeye/files/patch-sim_arm_configure b/emulators/skyeye/files/patch-sim_arm_configure
new file mode 100644
index 000000000000..63abe035eb47
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_configure
@@ -0,0 +1,12 @@
+--- sim/arm/configure.orig Wed Jul 20 13:40:44 2005
++++ sim/arm/configure Wed Jul 20 13:42:23 2005
+@@ -3620,7 +3620,8 @@
+ echo "$ac_t""no" 1>&6
+ fi
+ #2004-09-29 chy define GTK_CONFIG
+- GTK_CONFIG=/usr/bin/pkg-config
++# GTK_CONFIG=/usr/bin/pkg-config
++ GTK_CONFIG=/usr/local/bin/pkg-config
+ min_gtk_version=1.1.3
+ echo $ac_n "checking for GTK - version >= $min_gtk_version""... $ac_c" 1>&6
+ echo "configure:3626: checking for GTK - version >= $min_gtk_version" >&5
diff --git a/emulators/skyeye/files/patch-sim_arm_skyeye-ne2k.c b/emulators/skyeye/files/patch-sim_arm_skyeye-ne2k.c
new file mode 100644
index 000000000000..86a7c6b24763
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_skyeye-ne2k.c
@@ -0,0 +1,27 @@
+--- sim/arm/skyeye-ne2k.c.orig Tue Mar 1 14:51:24 2005
++++ sim/arm/skyeye-ne2k.c Sat Jul 16 18:17:14 2005
+@@ -26,13 +26,23 @@
+ * 02/25/2003 initial version
+ * yangye <yangye@163.net>
+ */
+-
++#ifdef __linux__
+ //#include <linux/if.h>
+ #include <net/if.h>
+ #include <linux/if_tun.h>
+ //#include <sys/types.h>
+ //#include <sys/stat.h>
+ //#include <fcntl.h>
++#endif
++
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <net/if.h>
++#include <net/if_tun.h>
++#endif
++
++
+ #include <sys/ioctl.h>
+ #include <armdefs.h>
+ #include <clps7110.h>
diff --git a/emulators/skyeye/files/patch-sim_arm_skyeye_net_tuntap.c b/emulators/skyeye/files/patch-sim_arm_skyeye_net_tuntap.c
new file mode 100644
index 000000000000..f227b65cec86
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_skyeye_net_tuntap.c
@@ -0,0 +1,68 @@
+--- sim/arm/skyeye_net_tuntap.c.orig Tue Mar 1 14:51:24 2005
++++ sim/arm/skyeye_net_tuntap.c Sat Jul 16 18:22:57 2005
+@@ -26,8 +26,19 @@
+ * chenyu <chenyu@hpclab.cs.tsinghua.edu.cn>
+ */
+
++#ifdef __linux__
+ #include <net/if.h>
+ #include <linux/if_tun.h>
++#endif
++
++#ifdef __FreeBSD__
++#include <sys/socket.h>
++#include <net/if.h>
++#include <net/if_tun.h>
++#include <fcntl.h>
++#endif
++
++
+ #include <sys/ioctl.h>
+ #include "armdefs.h"
+
+@@ -51,7 +62,7 @@
+ DBG_PRINT("tapif_init begin\n");
+
+ firsttime++;
+-
++#ifdef __linux__
+ //tapif_fd = open("/dev/net/tun", O_RDWR);
+ tapif_fd = open("/dev/net/tun", 2);
+ DBG_PRINT("tapif_init: fd %d\n", tapif_fd);
+@@ -68,13 +79,36 @@
+ exit(1);
+ //return ;
+ }
++#endif
+
++#ifdef __FreeBSD__
++ tapif_fd = open("/dev/tap", O_RDWR);
++ DBG_PRINT("tapif_init: fd %d\n", tapif_fd);
++ if(tapif_fd == -1) {
++ perror("tapif_init:open");
++ printf("-----------------------------------------------------------\n");
++ printf("NOTICE: You should run as root if you require network\n");
++ printf("NOTICE: load the kernel tap module with 'kldload if_tap'\n");
++ printf("NOTICE: and execute 'cat /dev/tap'. there should be a \n");
++ printf("NOTICE: device node under /dev/ (e.g. /dev/tap0).\n");
++ printf("-----------------------------------------------------------\n");
++ exit(1);
++ }
++#endif
++
++#if !defined(__FreeBSD__)&&!defined(__linux__)
++ printf("NOTICE: No network support for your OS(yet). Bugging out!\n");
++ exit(1);
++#endif
++
++#ifndef __FreeBSD__
+ memset(&ifr, 0, sizeof(ifr));
+ ifr.ifr_flags = IFF_TAP|IFF_NO_PI;
+ if (ioctl(tapif_fd, TUNSETIFF, (void *) &ifr) < 0) {
+ perror("tapif_init: icotl TUNSETIFF error");
+ exit(-1);
+ }
++#endif
+
+ if(firsttime==1){
+ snprintf(buf, sizeof(buf), "ifconfig tap0 inet %d.%d.%d.%d",
diff --git a/emulators/skyeye/files/patch-sim_arm_skyeye_net_vnet.c b/emulators/skyeye/files/patch-sim_arm_skyeye_net_vnet.c
new file mode 100644
index 000000000000..58c09e3d8766
--- /dev/null
+++ b/emulators/skyeye/files/patch-sim_arm_skyeye_net_vnet.c
@@ -0,0 +1,15 @@
+--- sim/arm/skyeye_net_vnet.c.orig Tue Mar 1 14:51:24 2005
++++ sim/arm/skyeye_net_vnet.c Sat Jul 16 18:23:34 2005
+@@ -26,6 +26,12 @@
+ * chenyu <chenyu@hpclab.cs.tsinghua.edu.cn>
+ */
+ #include <fcntl.h>
++
++#ifdef __FreeBSD__
++#include <sys/socket.h>
++#endif
++
++
+ #include <net/if.h>
+ //#include <linux/if_tun.h>
+ #include <sys/ioctl.h>
diff --git a/emulators/skyeye/files/patch-tcl_unix_Makefile.in b/emulators/skyeye/files/patch-tcl_unix_Makefile.in
new file mode 100644
index 000000000000..7dcc2afc09bd
--- /dev/null
+++ b/emulators/skyeye/files/patch-tcl_unix_Makefile.in
@@ -0,0 +1,19 @@
+*** tcl/unix/Makefile.in.orig Tue Jul 19 00:29:52 2005
+--- tcl/unix/Makefile.in Mon Jul 18 00:08:02 2005
+***************
+*** 194,200 ****
+ # once we have created the initial executable, but in some cases you
+ # may want to use a target without having made tclsh on these sources
+ # (like for make genstubs)
+! TCL_EXE = tclsh
+
+ # The symbols below provide support for dynamic loading and shared
+ # libraries. See configure.in for a description of what the
+--- 194,200 ----
+ # once we have created the initial executable, but in some cases you
+ # may want to use a target without having made tclsh on these sources
+ # (like for make genstubs)
+! TCL_EXE = tclsh${VERSION}
+
+ # The symbols below provide support for dynamic loading and shared
+ # libraries. See configure.in for a description of what the
diff --git a/emulators/skyeye/files/patch-usegtk-1.2.sh b/emulators/skyeye/files/patch-usegtk-1.2.sh
new file mode 100644
index 000000000000..71ebc9234dc6
--- /dev/null
+++ b/emulators/skyeye/files/patch-usegtk-1.2.sh
@@ -0,0 +1,9 @@
+--- usegtk-1.2.sh.orig Wed Jul 20 13:28:34 2005
++++ usegtk-1.2.sh Wed Jul 20 13:29:18 2005
+@@ -1,5 +1,5 @@
+ #! /bin/sh
+ cp gdb/Makefile.in.gtk-1.2 gdb/Makefile.in
+ cp sim/arm/Makefile.in.gtk-1.2 sim/arm/Makefile.in
+-cp sim/arm/configure.gtk-1.2 sim/arm/configure
++cp sim/arm/configure.gtk1.2 sim/arm/configure
+
diff --git a/emulators/skyeye/files/patch-usegtk-2.0.sh b/emulators/skyeye/files/patch-usegtk-2.0.sh
new file mode 100644
index 000000000000..a28f79c782ad
--- /dev/null
+++ b/emulators/skyeye/files/patch-usegtk-2.0.sh
@@ -0,0 +1,9 @@
+--- usegtk-2.0.sh.orig Wed Jul 20 13:28:03 2005
++++ usegtk-2.0.sh Wed Jul 20 13:25:21 2005
+@@ -1,5 +1,5 @@
+ #! /bin/sh
+ cp gdb/Makefile.in.gtk-2.0 gdb/Makefile.in
+ cp sim/arm/Makefile.in.gtk-2.0 sim/arm/Makefile.in
+-cp sim/arm/configure.gtk-2.0 sim/arm/configure
++cp sim/arm/configure.gtk2.0 sim/arm/configure
+
diff --git a/emulators/skyeye/pkg-descr b/emulators/skyeye/pkg-descr
new file mode 100644
index 000000000000..c5f6c0568d06
--- /dev/null
+++ b/emulators/skyeye/pkg-descr
@@ -0,0 +1,9 @@
+SkyEye is an Open Source Software Project. The goal of SkyEye is to provide an
+integrated simulation environment in Linux and Windows. SkyEye environment
+simulates typical Embedded Computer Systems (Now it supports Atmel AT91 board
+based on ARM7TDMI CPU, board based on ARM720T CPU, board based on StrongARM
+(SA1100/SA1110). You can run some Embedded Operation System such as ARM Linux,
+uClinux, uc/OS-II (ucos-ii) etc in SkyEye, and analyze or debug them at source
+level.
+
+WWW: http://www.skyeye.org/
diff --git a/emulators/skyeye/pkg-plist b/emulators/skyeye/pkg-plist
new file mode 100644
index 000000000000..5bd180c06fd2
--- /dev/null
+++ b/emulators/skyeye/pkg-plist
@@ -0,0 +1,288 @@
+bin/arm-elf-run
+bin/skyeye
+bin/skyinsight
+lib/insight1.0/plugins.tcl
+lib/libarm-elf-sim.a
+lib/libiberty.a
+lib/libmmalloc.a
+share/insight1.0/about.tcl
+share/insight1.0/actiondlg.tcl
+share/insight1.0/attachdlg.itb
+share/insight1.0/attachdlg.ith
+share/insight1.0/blockframe.itb
+share/insight1.0/blockframe.ith
+share/insight1.0/bpwin.itb
+share/insight1.0/bpwin.ith
+share/insight1.0/browserwin.itb
+share/insight1.0/browserwin.ith
+share/insight1.0/console.itb
+share/insight1.0/console.ith
+share/insight1.0/data.itb
+share/insight1.0/data.ith
+share/insight1.0/debugwin.itb
+share/insight1.0/debugwin.ith
+share/insight1.0/download.itb
+share/insight1.0/download.ith
+share/insight1.0/editor.tcl
+share/insight1.0/ehandler.itb
+share/insight1.0/ehandler.ith
+share/insight1.0/embeddedwin.ith
+share/insight1.0/gdbevent.itb
+share/insight1.0/gdbevent.ith
+share/insight1.0/gdbmenubar.itcl
+share/insight1.0/gdbtoolbar.itcl
+share/insight1.0/gdbwin.ith
+share/insight1.0/globalpref.itb
+share/insight1.0/globalpref.ith
+share/insight1.0/help/breakpoint.html
+share/insight1.0/help/browser.html
+share/insight1.0/help/console.html
+share/insight1.0/help/debug.html
+share/insight1.0/help/gbl_pref.html
+share/insight1.0/help/help.html
+share/insight1.0/help/images/frame_info.gif
+share/insight1.0/help/images/index.gif
+share/insight1.0/help/images/mem_menu.gif
+share/insight1.0/help/images/mem_popup.gif
+share/insight1.0/help/images/mem_pref.gif
+share/insight1.0/help/images/src_bal.gif
+share/insight1.0/help/images/src_bp_bal.gif
+share/insight1.0/help/images/src_bpop.gif
+share/insight1.0/help/images/src_menu.gif
+share/insight1.0/help/images/src_pop.gif
+share/insight1.0/help/images/src_stat.gif
+share/insight1.0/help/images/src_thread.gif
+share/insight1.0/help/images/src_toolbar.gif
+share/insight1.0/help/index.html
+share/insight1.0/help/license.html
+share/insight1.0/help/locals.html
+share/insight1.0/help/memory.html
+share/insight1.0/help/reg_pref.html
+share/insight1.0/help/register.html
+share/insight1.0/help/session.html
+share/insight1.0/help/source.html
+share/insight1.0/help/src_pref.html
+share/insight1.0/help/stack.html
+share/insight1.0/help/target.html
+share/insight1.0/help/thread.html
+share/insight1.0/help/trace/console.html
+share/insight1.0/help/trace/gbl_pref.html
+share/insight1.0/help/trace/help.html
+share/insight1.0/help/trace/index.toc
+share/insight1.0/help/trace/license.html
+share/insight1.0/help/trace/locals.html
+share/insight1.0/help/trace/memory.html
+share/insight1.0/help/trace/reg_pref.html
+share/insight1.0/help/trace/register.html
+share/insight1.0/help/trace/source.html
+share/insight1.0/help/trace/src_pref.html
+share/insight1.0/help/trace/stack.html
+share/insight1.0/help/trace/target.html
+share/insight1.0/help/trace/tdump.html
+share/insight1.0/help/trace/tp.html
+share/insight1.0/help/trace/tracedlg.html
+share/insight1.0/help/trace/watch.html
+share/insight1.0/help/watch.html
+share/insight1.0/helpviewer.itb
+share/insight1.0/helpviewer.ith
+share/insight1.0/images/Movie_off.gif
+share/insight1.0/images/Movie_on.gif
+share/insight1.0/images/back.gif
+share/insight1.0/images/bottom.gif
+share/insight1.0/images/bp.gif
+share/insight1.0/images/build.gif
+share/insight1.0/images/check.gif
+share/insight1.0/images/console.gif
+share/insight1.0/images/continue.gif
+share/insight1.0/images/down.gif
+share/insight1.0/images/edit.gif
+share/insight1.0/images/file.gif
+share/insight1.0/images/finish.gif
+share/insight1.0/images/fore.gif
+share/insight1.0/images/gdbtk.gif
+share/insight1.0/images/gdbtk_icon.gif
+share/insight1.0/images/help.gif
+share/insight1.0/images/home.gif
+share/insight1.0/images/icons.txt
+share/insight1.0/images/insight.gif
+share/insight1.0/images/less.gif
+share/insight1.0/images/memory.gif
+share/insight1.0/images/more.gif
+share/insight1.0/images/next.gif
+share/insight1.0/images/next_check.gif
+share/insight1.0/images/next_frame.gif
+share/insight1.0/images/next_hit.gif
+share/insight1.0/images/next_line.gif
+share/insight1.0/images/nexti.gif
+share/insight1.0/images/open.gif
+share/insight1.0/images/opt.gif
+share/insight1.0/images/prev_hit.gif
+share/insight1.0/images/reg.gif
+share/insight1.0/images/rewind.gif
+share/insight1.0/images/run.gif
+share/insight1.0/images/run_expt.gif
+share/insight1.0/images/src.gif
+share/insight1.0/images/stack.gif
+share/insight1.0/images/step.gif
+share/insight1.0/images/stepi.gif
+share/insight1.0/images/stop.gif
+share/insight1.0/images/tdump.gif
+share/insight1.0/images/tools.gif
+share/insight1.0/images/tools2_3d.gif
+share/insight1.0/images/tp.gif
+share/insight1.0/images/up.gif
+share/insight1.0/images/vars.gif
+share/insight1.0/images/vmake.gif
+share/insight1.0/images/watch.gif
+share/insight1.0/images/watch_movie.gif
+share/insight1.0/images2/Movie_off.gif
+share/insight1.0/images2/Movie_on.gif
+share/insight1.0/images2/back.gif
+share/insight1.0/images2/bottom.gif
+share/insight1.0/images2/bp.gif
+share/insight1.0/images2/build.gif
+share/insight1.0/images2/check.gif
+share/insight1.0/images2/console.gif
+share/insight1.0/images2/continue.gif
+share/insight1.0/images2/down.gif
+share/insight1.0/images2/edit.gif
+share/insight1.0/images2/file.gif
+share/insight1.0/images2/finish.gif
+share/insight1.0/images2/fore.gif
+share/insight1.0/images2/function.gif
+share/insight1.0/images2/gdbtk.gif
+share/insight1.0/images2/gdbtk_icon.gif
+share/insight1.0/images2/help.gif
+share/insight1.0/images2/home.gif
+share/insight1.0/images2/icons.txt
+share/insight1.0/images2/insight.gif
+share/insight1.0/images2/less.gif
+share/insight1.0/images2/load.gif
+share/insight1.0/images2/memory.gif
+share/insight1.0/images2/more.gif
+share/insight1.0/images2/next.gif
+share/insight1.0/images2/next_check.gif
+share/insight1.0/images2/next_frame.gif
+share/insight1.0/images2/next_hit.gif
+share/insight1.0/images2/next_line.gif
+share/insight1.0/images2/nexti.gif
+share/insight1.0/images2/open.gif
+share/insight1.0/images2/opt.gif
+share/insight1.0/images2/prev_hit.gif
+share/insight1.0/images2/reg.gif
+share/insight1.0/images2/rewind.gif
+share/insight1.0/images2/run.gif
+share/insight1.0/images2/run_expt.gif
+share/insight1.0/images2/src.gif
+share/insight1.0/images2/stack.gif
+share/insight1.0/images2/step.gif
+share/insight1.0/images2/stepi.gif
+share/insight1.0/images2/stop.gif
+share/insight1.0/images2/target.gif
+share/insight1.0/images2/tdump.gif
+share/insight1.0/images2/tools.gif
+share/insight1.0/images2/tools2_3d.gif
+share/insight1.0/images2/tp.gif
+share/insight1.0/images2/up.gif
+share/insight1.0/images2/vars.gif
+share/insight1.0/images2/vmake.gif
+share/insight1.0/images2/watch.gif
+share/insight1.0/images2/watch_movie.gif
+share/insight1.0/interface.tcl
+share/insight1.0/kod.itb
+share/insight1.0/kod.ith
+share/insight1.0/locals.tcl
+share/insight1.0/main.tcl
+share/insight1.0/managedwin.itb
+share/insight1.0/managedwin.ith
+share/insight1.0/mempref.itb
+share/insight1.0/mempref.ith
+share/insight1.0/memwin.itb
+share/insight1.0/memwin.ith
+share/insight1.0/modal.tcl
+share/insight1.0/pluginwin.itcl
+share/insight1.0/prefs.tcl
+share/insight1.0/process.itb
+share/insight1.0/process.ith
+share/insight1.0/regwin.itb
+share/insight1.0/regwin.ith
+share/insight1.0/session.tcl
+share/insight1.0/srcbar.itcl
+share/insight1.0/srcpref.itb
+share/insight1.0/srcpref.ith
+share/insight1.0/srctextwin.itb
+share/insight1.0/srctextwin.ith
+share/insight1.0/srcwin.itb
+share/insight1.0/srcwin.ith
+share/insight1.0/stackwin.itb
+share/insight1.0/stackwin.ith
+share/insight1.0/targetselection.itb
+share/insight1.0/targetselection.ith
+share/insight1.0/tclIndex
+share/insight1.0/tdump.tcl
+share/insight1.0/tfind_args.tcl
+share/insight1.0/toolbar.tcl
+share/insight1.0/toplevelwin.ith
+share/insight1.0/tracedlg.tcl
+share/insight1.0/tty.tcl
+share/insight1.0/util.tcl
+share/insight1.0/variables.tcl
+share/insight1.0/warning.tcl
+share/insight1.0/watch.tcl
+share/locale/da/LC_MESSAGES/opcodes.mo
+share/locale/de/LC_MESSAGES/opcodes.mo
+share/locale/es/LC_MESSAGES/opcodes.mo
+share/locale/fr/LC_MESSAGES/opcodes.mo
+share/locale/id/LC_MESSAGES/opcodes.mo
+share/locale/pt_BR/LC_MESSAGES/opcodes.mo
+share/locale/sv/LC_MESSAGES/opcodes.mo
+share/locale/tr/LC_MESSAGES/opcodes.mo
+share/redhat/gui/advice.tcl
+share/redhat/gui/balloon.tcl
+share/redhat/gui/bbox.tcl
+share/redhat/gui/bgerror.tcl
+share/redhat/gui/bindings.tcl
+share/redhat/gui/canvas.tcl
+share/redhat/gui/center.tcl
+share/redhat/gui/cframe.tcl
+share/redhat/gui/combobox.tcl
+share/redhat/gui/debug.tcl
+share/redhat/gui/def.tcl
+share/redhat/gui/font.tcl
+share/redhat/gui/gensym.tcl
+share/redhat/gui/gettext.tcl
+share/redhat/gui/hooks.tcl
+share/redhat/gui/internet.tcl
+share/redhat/gui/lframe.tcl
+share/redhat/gui/list.tcl
+share/redhat/gui/looknfeel.tcl
+share/redhat/gui/menu.tcl
+share/redhat/gui/mono.tcl
+share/redhat/gui/multibox.tcl
+share/redhat/gui/pane.tcl
+share/redhat/gui/panedwindow.tcl
+share/redhat/gui/parse_args.tcl
+share/redhat/gui/path.tcl
+share/redhat/gui/pkgIndex.tcl
+share/redhat/gui/postghost.tcl
+share/redhat/gui/prefs.tcl
+share/redhat/gui/print.tcl
+share/redhat/gui/sendpr.tcl
+share/redhat/gui/tclIndex
+share/redhat/gui/toolbar.tcl
+share/redhat/gui/topbind.tcl
+share/redhat/gui/ulset.tcl
+share/redhat/gui/ventry.tcl
+share/redhat/gui/wframe.tcl
+share/redhat/gui/wingrab.tcl
+@dirrm share/redhat/gui
+@dirrm share/redhat
+@dirrm share/nls/en_US.US-ASCII
+@dirrm share/nls/POSIX
+@dirrm share/insight1.0/images2
+@dirrm share/insight1.0/images
+@dirrm share/insight1.0/help/trace
+@dirrm share/insight1.0/help/images
+@dirrm share/insight1.0/help
+@dirrm share/insight1.0
+@dirrm lib/insight1.0