aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-06-03 08:40:13 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-06-03 08:40:13 +0800
commit618bb0239016ba05d92f019ef3fd707aa3529f7b (patch)
tree6d789d0ad68d0cafa73fc3819c6d6bc7843d1934 /emulators
parent7515c18c76609ccc2b08360244a250f6354e025d (diff)
downloadfreebsd-ports-gnome-618bb0239016ba05d92f019ef3fd707aa3529f7b.tar.gz
freebsd-ports-gnome-618bb0239016ba05d92f019ef3fd707aa3529f7b.tar.zst
freebsd-ports-gnome-618bb0239016ba05d92f019ef3fd707aa3529f7b.zip
- Add USES=libtool
- Strip binaries
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 881e17142b65..d4bb26c6fe40 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -74,8 +74,8 @@ VMX_DESC= Enable Virtialization extensions
VOODOO_DESC= Enable 3dfx Voodoo Graphics emulation
X86_64_DESC= Enable x86-64 instructions support
-USES= gmake pkgconfig
-USE_AUTOTOOLS= libtool
+USES= gmake pkgconfig libtool
+GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_alsa_asoundlib_h=no
CONFIGURE_ARGS= --disable-docbook --disable-instrumentation
@@ -288,6 +288,9 @@ post-patch:
${WRKSRC}/gui/Makefile.in
post-install:
+.for f in bochs bxcommit bximage
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
+.endfor
.if ${PORT_OPTIONS:MPLUGINS}
@${FIND} ${STAGEDIR}${PREFIX}/lib/bochs ! -type d | \
${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}