aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-09-26 10:43:13 +0800
committerkris <kris@FreeBSD.org>2004-09-26 10:43:13 +0800
commit6424fd5192e6e888303ce266ccb6b88a31cd3003 (patch)
tree344dec9163299897e862e1053185162428fc0e36 /emulators
parentf0ffa4773cf009acee4354c9b5ae2066182c2d78 (diff)
downloadfreebsd-ports-gnome-6424fd5192e6e888303ce266ccb6b88a31cd3003.tar.gz
freebsd-ports-gnome-6424fd5192e6e888303ce266ccb6b88a31cd3003.tar.zst
freebsd-ports-gnome-6424fd5192e6e888303ce266ccb6b88a31cd3003.zip
BROKEN on 5.x: Does not compile
Approved by: portmgr (self)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/psim-freebsd/Makefile8
-rw-r--r--emulators/qemu-devel/Makefile8
-rw-r--r--emulators/qemu/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/emulators/psim-freebsd/Makefile b/emulators/psim-freebsd/Makefile
index 37a3cc621f5d..f1dce620db67 100644
--- a/emulators/psim-freebsd/Makefile
+++ b/emulators/psim-freebsd/Makefile
@@ -23,6 +23,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-psim --target=powerpc-freebsd-elf \
--program-suffix=psim
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb ${PREFIX}/bin/${PORTNAME}
${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
@@ -38,4 +44,4 @@ cklatest:
ftp://mirrors.rcn.net/mirrors/sources.redhat.com/${MASTER_SITE_SUBDIR}/ \
| ${GREP} gdb+dejagnu-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index bbd69b04a05f..6dcbff214ee6 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -29,7 +29,13 @@ CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}\ -I${PREFIX}/include
MAN1= qemu.1 qemu-mkcow.1
ONLY_FOR_ARCHS= i386 amd64 powerpc
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index bbd69b04a05f..6dcbff214ee6 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -29,7 +29,13 @@ CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}\ -I${PREFIX}/include
MAN1= qemu.1 qemu-mkcow.1
ONLY_FOR_ARCHS= i386 amd64 powerpc
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>