aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2008-04-04 04:18:40 +0800
committernox <nox@FreeBSD.org>2008-04-04 04:18:40 +0800
commit8b0a9915192c1866e738b17a69bc07a09e460d79 (patch)
treebffcfcd6bb44e83044252768708373b6f1fb08f0 /emulators
parent249ec1ba3b75a1f27a044fd2cdf97fc118c607b0 (diff)
downloadfreebsd-ports-gnome-8b0a9915192c1866e738b17a69bc07a09e460d79.tar.gz
freebsd-ports-gnome-8b0a9915192c1866e738b17a69bc07a09e460d79.tar.zst
freebsd-ports-gnome-8b0a9915192c1866e738b17a69bc07a09e460d79.zip
- Use PREFIX for qemu-ifup, install default scripts, bump PORTREVISION [1]
- Patch a pointer to pkg-message into the manpage Submitted by: bms [1]
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile10
-rw-r--r--emulators/qemu-devel/files/patch-bg8
-rw-r--r--emulators/qemu-devel/files/patch-qemu-doc.texi11
-rw-r--r--emulators/qemu-devel/files/qemu-ifdown.sample2
-rw-r--r--emulators/qemu-devel/files/qemu-ifup.sample2
-rw-r--r--emulators/qemu-devel/pkg-message3
-rw-r--r--emulators/qemu-devel/pkg-plist6
-rw-r--r--emulators/qemu/Makefile10
-rw-r--r--emulators/qemu/files/patch-bg8
-rw-r--r--emulators/qemu/files/patch-qemu-doc.texi11
-rw-r--r--emulators/qemu/files/qemu-ifdown.sample2
-rw-r--r--emulators/qemu/files/qemu-ifup.sample2
-rw-r--r--emulators/qemu/pkg-message3
-rw-r--r--emulators/qemu/pkg-plist6
14 files changed, 76 insertions, 8 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 5a4ec7c0533f..414c269ba007 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.9.1s.20080302
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= http://qemu.org/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
@@ -117,6 +117,14 @@ post-patch:
${WRKSRC}/Makefile
post-install:
+ @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
+ @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc
+ @if [ ! -f ${PREFIX}/etc/qemu-ifup ]; then \
+ ${CP} -p ${PREFIX}/etc/qemu-ifup.sample ${PREFIX}/etc/qemu-ifup ; \
+ fi
+ @if [ ! -f ${PREFIX}/etc/qemu-ifdown ]; then \
+ ${CP} -p ${PREFIX}/etc/qemu-ifdown.sample ${PREFIX}/etc/qemu-ifdown ; \
+ fi
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/emulators/qemu-devel/files/patch-bg b/emulators/qemu-devel/files/patch-bg
index eaa753d13cb4..7e645929d40e 100644
--- a/emulators/qemu-devel/files/patch-bg
+++ b/emulators/qemu-devel/files/patch-bg
@@ -4,15 +4,17 @@ Index: qemu/Makefile.target
#########################################################
-CPPFLAGS+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-+CPPFLAGS+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\" -I${LOCALBASE}/include
++CPPFLAGS+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\" -I${LOCALBASE}/include -DPREFIX=\"${PREFIX}\"
LIBS+=-lm
ifndef CONFIG_USER_ONLY
LIBS+=-lz
Index: qemu/vl.c
@@ -133,10 +133,12 @@
- #define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
- #define DEFAULT_NETWORK_DOWN_SCRIPT "/etc/qemu-ifdown"
+-#define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
+-#define DEFAULT_NETWORK_DOWN_SCRIPT "/etc/qemu-ifdown"
++#define DEFAULT_NETWORK_SCRIPT PREFIX "/etc/qemu-ifup"
++#define DEFAULT_NETWORK_DOWN_SCRIPT PREFIX "/etc/qemu-ifdown"
+#ifndef SMBD_COMMAND
#ifdef __sun__
#define SMBD_COMMAND "/usr/sfw/sbin/smbd"
diff --git a/emulators/qemu-devel/files/patch-qemu-doc.texi b/emulators/qemu-devel/files/patch-qemu-doc.texi
new file mode 100644
index 000000000000..1a7d9ef2ca51
--- /dev/null
+++ b/emulators/qemu-devel/files/patch-qemu-doc.texi
@@ -0,0 +1,11 @@
+Index: qemu/qemu-doc.texi
+@@ -985,7 +985,8 @@
+
+ @c man begin SEEALSO
+ The HTML documentation of QEMU for more precise information and Linux
+-user mode emulator invocation.
++user mode emulator invocation, as well as the FreeBSD host notes in
++@file{pkg-message} in the relevant qemu port directory.
+ @c man end
+
+ @c man begin AUTHOR
diff --git a/emulators/qemu-devel/files/qemu-ifdown.sample b/emulators/qemu-devel/files/qemu-ifdown.sample
new file mode 100644
index 000000000000..89d9a9bff436
--- /dev/null
+++ b/emulators/qemu-devel/files/qemu-ifdown.sample
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec true
diff --git a/emulators/qemu-devel/files/qemu-ifup.sample b/emulators/qemu-devel/files/qemu-ifup.sample
new file mode 100644
index 000000000000..89d9a9bff436
--- /dev/null
+++ b/emulators/qemu-devel/files/qemu-ifup.sample
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec true
diff --git a/emulators/qemu-devel/pkg-message b/emulators/qemu-devel/pkg-message
index 33c49e966431..91b649ee1715 100644
--- a/emulators/qemu-devel/pkg-message
+++ b/emulators/qemu-devel/pkg-message
@@ -82,4 +82,7 @@ to panic), if this affects you you can either use an UP host kernel as a
workaround or disable kqemu.
- qemu now uses aio at least for ide dma, so if you get `Invalid system call'
crashes that is because aio is not (kld)loaded.
+- The default configuration location (qemu-ifup script etc.) has been
+changed from /etc to PREFIX/etc (usually /usr/local/etc). Move your
+files accordingly.
====
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index 2df1145002d5..35b4c135d69e 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -14,6 +14,12 @@ bin/qemu-system-sh4
bin/qemu-system-sh4eb
bin/qemu-system-sparc
bin/qemu-system-x86_64
+@unexec if cmp -s %D/etc/qemu-ifup.sample %D/etc/qemu-ifup; then rm -f %D/etc/qemu-ifup; fi
+etc/qemu-ifup.sample
+@exec if [ ! -f %D/etc/qemu-ifup ] ; then cp -p %D/%F %B/qemu-ifup; fi
+@unexec if cmp -s %D/etc/qemu-ifdown.sample %D/etc/qemu-ifdown; then rm -f %D/etc/qemu-ifdown; fi
+etc/qemu-ifdown.sample
+@exec if [ ! -f %D/etc/qemu-ifdown ] ; then cp -p %D/%F %B/qemu-ifdown; fi
%%PORTDOCS%%%%DOCSDIR%%/qemu-doc.html
%%PORTDOCS%%%%DOCSDIR%%/qemu-tech.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 28e5d457626c..c56ac93b5fa4 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.9.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= http://fabrice.bellard.free.fr/qemu/:release \
http://qemu.org/:release \
@@ -111,6 +111,14 @@ post-patch:
${WRKSRC}/Makefile
post-install:
+ @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
+ @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc
+ @if [ ! -f ${PREFIX}/etc/qemu-ifup ]; then \
+ ${CP} -p ${PREFIX}/etc/qemu-ifup.sample ${PREFIX}/etc/qemu-ifup ; \
+ fi
+ @if [ ! -f ${PREFIX}/etc/qemu-ifdown ]; then \
+ ${CP} -p ${PREFIX}/etc/qemu-ifdown.sample ${PREFIX}/etc/qemu-ifdown ; \
+ fi
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/emulators/qemu/files/patch-bg b/emulators/qemu/files/patch-bg
index eaa753d13cb4..7e645929d40e 100644
--- a/emulators/qemu/files/patch-bg
+++ b/emulators/qemu/files/patch-bg
@@ -4,15 +4,17 @@ Index: qemu/Makefile.target
#########################################################
-CPPFLAGS+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-+CPPFLAGS+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\" -I${LOCALBASE}/include
++CPPFLAGS+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\" -I${LOCALBASE}/include -DPREFIX=\"${PREFIX}\"
LIBS+=-lm
ifndef CONFIG_USER_ONLY
LIBS+=-lz
Index: qemu/vl.c
@@ -133,10 +133,12 @@
- #define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
- #define DEFAULT_NETWORK_DOWN_SCRIPT "/etc/qemu-ifdown"
+-#define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
+-#define DEFAULT_NETWORK_DOWN_SCRIPT "/etc/qemu-ifdown"
++#define DEFAULT_NETWORK_SCRIPT PREFIX "/etc/qemu-ifup"
++#define DEFAULT_NETWORK_DOWN_SCRIPT PREFIX "/etc/qemu-ifdown"
+#ifndef SMBD_COMMAND
#ifdef __sun__
#define SMBD_COMMAND "/usr/sfw/sbin/smbd"
diff --git a/emulators/qemu/files/patch-qemu-doc.texi b/emulators/qemu/files/patch-qemu-doc.texi
new file mode 100644
index 000000000000..1a7d9ef2ca51
--- /dev/null
+++ b/emulators/qemu/files/patch-qemu-doc.texi
@@ -0,0 +1,11 @@
+Index: qemu/qemu-doc.texi
+@@ -985,7 +985,8 @@
+
+ @c man begin SEEALSO
+ The HTML documentation of QEMU for more precise information and Linux
+-user mode emulator invocation.
++user mode emulator invocation, as well as the FreeBSD host notes in
++@file{pkg-message} in the relevant qemu port directory.
+ @c man end
+
+ @c man begin AUTHOR
diff --git a/emulators/qemu/files/qemu-ifdown.sample b/emulators/qemu/files/qemu-ifdown.sample
new file mode 100644
index 000000000000..89d9a9bff436
--- /dev/null
+++ b/emulators/qemu/files/qemu-ifdown.sample
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec true
diff --git a/emulators/qemu/files/qemu-ifup.sample b/emulators/qemu/files/qemu-ifup.sample
new file mode 100644
index 000000000000..89d9a9bff436
--- /dev/null
+++ b/emulators/qemu/files/qemu-ifup.sample
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec true
diff --git a/emulators/qemu/pkg-message b/emulators/qemu/pkg-message
index ec55725696fa..80d50d29e44a 100644
--- a/emulators/qemu/pkg-message
+++ b/emulators/qemu/pkg-message
@@ -81,4 +81,7 @@ to panic), if this affects you you can either use an UP host kernel as a
workaround or disable kqemu.
- qemu now uses aio at least for ide dma, so if you get `Invalid system call'
crashes that is because aio is not (kld)loaded.
+- The default configuration location (qemu-ifup script etc.) has been
+changed from /etc to PREFIX/etc (usually /usr/local/etc). Move your
+files accordingly.
====
diff --git a/emulators/qemu/pkg-plist b/emulators/qemu/pkg-plist
index 2df1145002d5..35b4c135d69e 100644
--- a/emulators/qemu/pkg-plist
+++ b/emulators/qemu/pkg-plist
@@ -14,6 +14,12 @@ bin/qemu-system-sh4
bin/qemu-system-sh4eb
bin/qemu-system-sparc
bin/qemu-system-x86_64
+@unexec if cmp -s %D/etc/qemu-ifup.sample %D/etc/qemu-ifup; then rm -f %D/etc/qemu-ifup; fi
+etc/qemu-ifup.sample
+@exec if [ ! -f %D/etc/qemu-ifup ] ; then cp -p %D/%F %B/qemu-ifup; fi
+@unexec if cmp -s %D/etc/qemu-ifdown.sample %D/etc/qemu-ifdown; then rm -f %D/etc/qemu-ifdown; fi
+etc/qemu-ifdown.sample
+@exec if [ ! -f %D/etc/qemu-ifdown ] ; then cp -p %D/%F %B/qemu-ifdown; fi
%%PORTDOCS%%%%DOCSDIR%%/qemu-doc.html
%%PORTDOCS%%%%DOCSDIR%%/qemu-tech.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%