aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-01-08 21:06:35 +0800
committergerald <gerald@FreeBSD.org>2015-01-08 21:06:35 +0800
commita2fa3741b5afee19dbb128b8d13e1aa1058d77ff (patch)
tree60f33e5b80c72adbffa5b8e891c7e4c04d79559b /emulators
parent94426039ea7eb57d560b5ef550a0b3b7b2c530c5 (diff)
downloadfreebsd-ports-gnome-a2fa3741b5afee19dbb128b8d13e1aa1058d77ff.tar.gz
freebsd-ports-gnome-a2fa3741b5afee19dbb128b8d13e1aa1058d77ff.tar.zst
freebsd-ports-gnome-a2fa3741b5afee19dbb128b8d13e1aa1058d77ff.zip
No longer always configure --with-xcomposite since this is now
handled as part of the X11 option. Sort X11_CONFIGURE_WITH alphabetically and add the previously missing xrender option. Adjust the position of PORTDATA to match the emulators/wine port.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 0e924151b492..2db766bb2cca 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ARGS+=--verbose --disable-tests \
--with-oss \
--without-sane \
--without-tiff \
- --with-xcomposite --without-xinerama
+ --without-xinerama
CONFIGURE_ENV= FLEX="${LOCALBASE}/bin/flex"
WINELIBDIR?= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
@@ -51,6 +51,8 @@ SHEBANG_FILES= tools/make_requests tools/winemaker \
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+PORTDATA= l_intl.nls wine.inf
+
OPTIONS_DEFINE= COMPHOLIO CUPS DOCS DOSBOX GNUTLS HAL LDAP LIBXSLT MPG123 OPENAL V4L WINEMAKER X11 GECKO MONO
OPTIONS_DEFAULT=X11
OPTIONS_SUB= yes
@@ -94,7 +96,7 @@ V4L_LIB_DEPENDS= libv4l1.so:${PORTSDIR}/multimedia/libv4l
WINEMAKER_RUN_DEPENDS= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
-X11_CONFIGURE_WITH= x cms fontconfig glu jpeg opengl png xinput2 xrandr freetype
+X11_CONFIGURE_WITH= x cms fontconfig freetype glu jpeg opengl png xinput2 xrandr xrender
X11_USE= GL=glu XORG=xcomposite,xcursor,xi,xrandr,xrender
X11_LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libfreetype.so:${PORTSDIR}/print/freetype2 \
@@ -102,8 +104,6 @@ X11_LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libpng.so:${PORTSDIR}/graphics/png
-PORTDATA= l_intl.nls wine.inf
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCOMPHOLIO}