aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2010-06-07 04:39:21 +0800
committernaddy <naddy@FreeBSD.org>2010-06-07 04:39:21 +0800
commita7e23ef2423b94523671d838b70763ecfea3ca60 (patch)
tree3d3fdf131c6f5d30a25430d16a62f0d82e33445f /emulators
parent14d2f864caf57bceba3f0ac72ea827fafd27743d (diff)
downloadfreebsd-ports-gnome-a7e23ef2423b94523671d838b70763ecfea3ca60.tar.gz
freebsd-ports-gnome-a7e23ef2423b94523671d838b70763ecfea3ca60.tar.zst
freebsd-ports-gnome-a7e23ef2423b94523671d838b70763ecfea3ca60.zip
Bump PORTREVISION after libao update and handle API incompatibility.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bsnes/Makefile4
-rw-r--r--emulators/bsnes/files/patch-src_lib_ruby_audio_ao.cpp10
-rw-r--r--emulators/fuse/Makefile4
-rw-r--r--emulators/zsnes/Makefile4
-rw-r--r--emulators/zsnes/files/patch-linux_audio.c10
5 files changed, 26 insertions, 6 deletions
diff --git a/emulators/bsnes/Makefile b/emulators/bsnes/Makefile
index 9e647e561da7..0e7af2873023 100644
--- a/emulators/bsnes/Makefile
+++ b/emulators/bsnes/Makefile
@@ -6,7 +6,7 @@
PORTNAME= bsnes
PORTVERSION= 0.58
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= http://byuu.org/files/ \
ftp://ftp.arcadebsd.org/pub/ArcadeBSD/ports/distfiles/
@@ -73,7 +73,7 @@ AUDIO_DRIVER+= audio.pulseaudio
.endif
.if defined(WITH_SOUND_AO)
-LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
AUDIO_DRIVER+= audio.ao
.endif
diff --git a/emulators/bsnes/files/patch-src_lib_ruby_audio_ao.cpp b/emulators/bsnes/files/patch-src_lib_ruby_audio_ao.cpp
new file mode 100644
index 000000000000..6cd66ebbde34
--- /dev/null
+++ b/emulators/bsnes/files/patch-src_lib_ruby_audio_ao.cpp
@@ -0,0 +1,10 @@
+--- src/lib/ruby/audio/ao.cpp.orig 2010-06-06 18:49:07.000000000 +0200
++++ src/lib/ruby/audio/ao.cpp 2010-06-06 18:49:30.000000000 +0200
+@@ -51,6 +51,7 @@ public:
+ driver_id = ao_default_driver_id(); //ao_driver_id((const char*)driver)
+ if(driver_id < 0) return false;
+
++ memset(&driver_format, 0, sizeof(driver_format));
+ driver_format.bits = 16;
+ driver_format.channels = 2;
+ driver_format.rate = settings.frequency;
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index b179fbe23eb2..785ca8975acf 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fuse
PORTVERSION= 0.10.0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}-emulator/${PORTNAME}/${PORTVERSION}
@@ -31,7 +31,7 @@ OPTIONS= AO "Use libao for audio output" off \
.if defined(WITH_AO)
CONFIGURE_ARGS+=--with-libao
-LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
.endif
.if !defined(WITHOUT_SAMPLERATE)
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 747f09e2e6a0..02316eedb770 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zsnes
PORTVERSION= 1.51
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ZSNES%20v${PORTVERSION}
@@ -78,7 +78,7 @@ CONFIGURE_ARGS+= --disable-opengl
.endif
.if defined(WITH_LIBAO)
-LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+= --enable-libao
.else
CONFIGURE_ARGS+= --disable-libao
diff --git a/emulators/zsnes/files/patch-linux_audio.c b/emulators/zsnes/files/patch-linux_audio.c
new file mode 100644
index 000000000000..a88985a34fa5
--- /dev/null
+++ b/emulators/zsnes/files/patch-linux_audio.c
@@ -0,0 +1,10 @@
+--- linux/audio.c.orig 2010-06-06 14:56:20.000000000 +0200
++++ linux/audio.c 2010-06-06 14:56:41.000000000 +0200
+@@ -166,6 +166,7 @@ static int SoundInit_ao()
+ if (driver_id < 0) { driver_id = ao_default_driver_id(); }
+
+ ao_sample_format driver_format;
++ memset(&driver_format, 0, sizeof(driver_format));
+ driver_format.bits = 16;
+ driver_format.channels = StereoSound+1;
+ driver_format.rate = freqtab[SoundQuality = ((SoundQuality > 6) ? 1 : SoundQuality)];