aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-02 23:51:50 +0800
committerkrion <krion@FreeBSD.org>2004-02-02 23:51:50 +0800
commitc2e04171455eed608f82ef80acd258e8c603e6d6 (patch)
tree04ed9e2d85800fd3bbbd61fada701dccb95d722f /emulators
parent1ab5b2d7430dac0b457d50c0420f4ad055b2c66f (diff)
downloadfreebsd-ports-gnome-c2e04171455eed608f82ef80acd258e8c603e6d6.tar.gz
freebsd-ports-gnome-c2e04171455eed608f82ef80acd258e8c603e6d6.tar.zst
freebsd-ports-gnome-c2e04171455eed608f82ef80acd258e8c603e6d6.zip
- Update to version 20040115
PR: ports/62263 Submitted by: Ports Fury
Diffstat (limited to 'emulators')
-rw-r--r--emulators/gngb/Makefile50
-rw-r--r--emulators/gngb/distinfo3
-rw-r--r--emulators/gngb/pkg-descr2
-rw-r--r--emulators/gngb/pkg-plist1
4 files changed, 25 insertions, 31 deletions
diff --git a/emulators/gngb/Makefile b/emulators/gngb/Makefile
index c80491ea2645..557b9274dc30 100644
--- a/emulators/gngb/Makefile
+++ b/emulators/gngb/Makefile
@@ -6,48 +6,44 @@
#
PORTNAME= gngb
-PORTVERSION= 20030809
+PORTVERSION= 20040115
CATEGORIES= emulators
-MASTER_SITES= http://membres.lycos.fr/frogus/gngb/download/ \
- http://m.peponas.free.fr/gngb/download/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
+MASTER_SITES= http://m.peponas.free.fr/gngb/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= GameBoy(tm) emulator
+USE_X_PREFIX= yes
USE_SDL= sdl
-GNU_CONFIGURE= yes
+USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GETOPT_LONG=yes
-USE_XLIB= yes
-USE_X_PREFIX= yes
-CONFIGURE_ENV= CFLAGS="-I${X11BASE}/include" \
- LDFLAGS="-L${X11BASE}/lib"
-PORT_CFLAGS= -DSDL_YUV -I${LOCALBASE}/include -I${LOCALBASE}/include/SDL11 -I${X11BASE}/include
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= bin/gngb
+
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} "You can enable additional compilation optimizations"
- @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
-.endif
.if defined(WITH_GL)
-CONFIGURE_ARGS= --with-gl
-PORT_CFLAGS+= -DSDL_GL
+USE_GL= yes
.else
+CONFIGURE_ARGS+= --disable-gl
+.endif
+
+pre-everything::
+.if !defined(WITH_GL)
@${ECHO_MSG}
@${ECHO_MSG} "You can enable OpenGL support by defining WITH_GL"
@${ECHO_MSG}
.endif
-pre-configure:
- @${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g; \
- s|-lSDL|-lSDL-1.1|g; \
- s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-
-post-configure:
-.if !defined(WITH_OPTIMIZED_CFLAGS)
- @${REINPLACE_CMD} -e 's|\(CFLAGS =\).*|\1 ${PORT_CFLAGS} ${CFLAGS}|' ${WRKSRC}/src/Makefile
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|"$$SDL_CONFIG" = yes|-n "$$SDL_CONFIG"|g ; \
+ s|sdl-config |$$SDL_CONFIG |g ; \
+ s|-lSDL|-lSDL-1.1|g ; \
+ s|$$OPT||g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/emulators/gngb/distinfo b/emulators/gngb/distinfo
index 7271da5d8cd6..d837eb5575c9 100644
--- a/emulators/gngb/distinfo
+++ b/emulators/gngb/distinfo
@@ -1,2 +1 @@
-MD5 (gngb-20030809.tar.gz) = 4582a4315d442f398c106d236a581d53
-SIZE (gngb-20030809.tar.gz) = 134892
+MD5 (gngb-20040115.tar.gz) = 64b2c58df2512852baa87c9a9f57c53f
diff --git a/emulators/gngb/pkg-descr b/emulators/gngb/pkg-descr
index bd383a20c5ae..8d7354718037 100644
--- a/emulators/gngb/pkg-descr
+++ b/emulators/gngb/pkg-descr
@@ -1,3 +1,3 @@
GameBoy(tm) emulator
-WWW: http://membres.lycos.fr/frogus/gngb.html
+WWW: http://m.peponas.free.fr/gngb/
diff --git a/emulators/gngb/pkg-plist b/emulators/gngb/pkg-plist
deleted file mode 100644
index b377ac5037a3..000000000000
--- a/emulators/gngb/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/gngb