aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-07-27 12:27:19 +0800
committerhrs <hrs@FreeBSD.org>2013-07-27 12:27:19 +0800
commitceb9e4aeab174e924b375605e41e548192fcc2ef (patch)
tree799a346deb544199ab83414ac91c71e8ae7f77aa /emulators
parent44b49aa9ec8cb06d93e9437471d801cdccca455d (diff)
downloadfreebsd-ports-gnome-ceb9e4aeab174e924b375605e41e548192fcc2ef.tar.gz
freebsd-ports-gnome-ceb9e4aeab174e924b375605e41e548192fcc2ef.tar.zst
freebsd-ports-gnome-ceb9e4aeab174e924b375605e41e548192fcc2ef.zip
- Fix CONFLICTS.
- Style cleanups. - Take maintainership.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/tpm-emulator/Makefile16
-rw-r--r--emulators/tpm-emulator/pkg-plist1
2 files changed, 8 insertions, 9 deletions
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index 372369521e9a..5527e999b764 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -8,27 +8,24 @@ CATEGORIES= emulators security
MASTER_SITES= SF/${PORTNAME}.berlios
DISTNAME= ${PORTNAME:S,-,_,}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hrs@FreeBSD.org
COMMENT= Trusted Platform Module (TPM) emulator
LICENSE= GPLv2
LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
-CONFLICTS= trousers-tddl-[0-9d]*
-
-USE_RC_SUBR= tpmd
+CONFLICTS= trousers-tddl-[0-9]*
USES= cmake:outsource
+USE_RC_SUBR= tpmd
CMAKE_ENV= PREFIX="${PREFIX}"
CMAKE_ARGS= -DTPM_INCLUDE_DIRS:STRING="${LOCALBASE}/include" \
-DTPM_LIBRARY_DIRS:STRING="${LOCALBASE}/lib"
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-
USERS= _tss
GROUPS= _tss
-
SUB_LIST= USERS="${USERS}" GROUPS="${GROUPS}"
.include <bsd.port.pre.mk>
@@ -42,8 +39,9 @@ post-install:
@${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 /var/run/tpm
add-plist-post:
- @${ECHO_CMD} "@cwd /" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ${RMDIR} var/run/tpm 2>/dev/null || true" >> ${TMPPLIST}
- @${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 var/run/tpm" >> ${TMPPLIST}
+ @(${ECHO_CMD} "@cwd /"; \
+ ${ECHO_CMD} "@unexec ${RMDIR} var/run/tpm 2>/dev/null || true"; \
+ ${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 var/run/tpm"; \
+ ) >> ${TMPPLIST}
.include <bsd.port.post.mk>
diff --git a/emulators/tpm-emulator/pkg-plist b/emulators/tpm-emulator/pkg-plist
index bcb3428eec8f..602f29adbaaa 100644
--- a/emulators/tpm-emulator/pkg-plist
+++ b/emulators/tpm-emulator/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
bin/tpmd
include/tddl.h
lib/libtddl.a