aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2014-07-16 02:07:08 +0800
committerkmoore <kmoore@FreeBSD.org>2014-07-16 02:07:08 +0800
commitf351518181bef0ee3ceff550d5c98057f7954826 (patch)
treea1929ee220c2f863eee5ead96ea437aea0589b96 /emulators
parent79de3b005170a94d65f19da5cd871bbac67b8cd1 (diff)
downloadfreebsd-ports-gnome-f351518181bef0ee3ceff550d5c98057f7954826.tar.gz
freebsd-ports-gnome-f351518181bef0ee3ceff550d5c98057f7954826.tar.zst
freebsd-ports-gnome-f351518181bef0ee3ceff550d5c98057f7954826.zip
- Cleanup Makefile includes, remove depreciated MAN1= entry
Diffstat (limited to 'emulators')
-rw-r--r--emulators/pipelight/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/emulators/pipelight/Makefile b/emulators/pipelight/Makefile
index ac39c4d6f21d..1f46ef316abe 100644
--- a/emulators/pipelight/Makefile
+++ b/emulators/pipelight/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pipelight
DISTVERSION= 0.2.7.1
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= https://bitbucket.org/mmueller2012/pipelight/get/
DISTNAME= v${DISTVERSION}
@@ -22,16 +23,6 @@ RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/bin/flock:${PORTSDIR}/sysutils/flock \
${LOCALBASE}/bin/gpg2:${PORTSDIR}/security/gnupg
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "i386"
-BUILD_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/wine-devel
-RUN_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/wine-devel
-.elif ${ARCH} == "amd64"
-BUILD_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/i386-wine-devel
-RUN_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/i386-wine-devel
-.endif
-
WRKSRC= ${WRKDIR}/mmueller2012-pipelight-e2362eb15df6
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -42,11 +33,19 @@ CONFIGURE_ARGS+=--verbose --wine-path=${LOCALBASE}/bin/wine --win32-prebuilt \
USES= compiler:c11 gmake
MAKE_JOBS_UNSAFE=yes
-MAN1= pipelight-plugin.1
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BUILD_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/wine-devel
+RUN_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/wine-devel
+.elif ${ARCH} == "amd64"
+BUILD_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/i386-wine-devel
+RUN_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/i386-wine-devel
+.endif
pre-configure:
${REINPLACE_CMD} "s|DISTVERSION|v${DISTVERSION}|g" ${WRKSRC}/src/windows/Makefile
${REINPLACE_CMD} "s|DISTVERSION|v${DISTVERSION}|g" ${WRKSRC}/src/winecheck/Makefile
${REINPLACE_CMD} "s|/share/man/man1|/man/man1|g" ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>