aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-04-09 00:46:06 +0800
committerlinimon <linimon@FreeBSD.org>2019-04-09 00:46:06 +0800
commitcfe3c4128ffc8b172c43cb6cc682f28a4883647c (patch)
treeb7f98e8c969f193b7a623580ac057d24407ec8a2 /emulators
parent91c22ae516dad2b0c793d85f6b0450bd0c2336c8 (diff)
downloadfreebsd-ports-gnome-cfe3c4128ffc8b172c43cb6cc682f28a4883647c.tar.gz
freebsd-ports-gnome-cfe3c4128ffc8b172c43cb6cc682f28a4883647c.tar.zst
freebsd-ports-gnome-cfe3c4128ffc8b172c43cb6cc682f28a4883647c.zip
Add compiler:c++11-lang to USES to fix build on GCC-based architectures:
/usr/local/lib/libgraphite2.so.3: undefined reference to `__cxa_throw_bad_array_new_length@CXXABI_1.3.8' While here, pet portlint and alpha sort some USE* variables. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/kcemu/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/emulators/kcemu/Makefile b/emulators/kcemu/Makefile
index a9c8b0ce7fbc..db24d8c3f25e 100644
--- a/emulators/kcemu/Makefile
+++ b/emulators/kcemu/Makefile
@@ -22,11 +22,11 @@ LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
libxvidcore.so:multimedia/xvid \
libz80ex.so:devel/z80ex
-GNU_CONFIGURE= yes
-USE_XORG= xmu
-USE_GNOME= gtk20
-USES= gettext ncurses pkgconfig
+USES= compiler:c++11-lang gettext ncurses pkgconfig
USE_CXXSTD= gnu++98
+USE_GNOME= gtk20
+USE_XORG= xmu
+GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/KCemu-${PORTVERSION}