aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
committermakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
commit071186fd6d22f1abd16554cae92bf26af9d1cb4e (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /emulators
parenteda1ae8e7cf50659cf0b55fefdcae532e6ad0405 (diff)
downloadfreebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.gz
freebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.zst
freebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.zip
- convert USE_CMAKE to USES
- while here clean up some ports from CMAKE_VERBOSE, which is intended for users Approved by: portmgr (miwi)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/aqemu/Makefile2
-rw-r--r--emulators/dolphin-emu-devel/Makefile2
-rw-r--r--emulators/hatari/Makefile2
-rw-r--r--emulators/joytran/Makefile2
-rw-r--r--emulators/tpm-emulator/Makefile3
-rw-r--r--emulators/visualboyadvance-m/Makefile2
6 files changed, 6 insertions, 7 deletions
diff --git a/emulators/aqemu/Makefile b/emulators/aqemu/Makefile
index 927c1702fc55..7ef7498e9485 100644
--- a/emulators/aqemu/Makefile
+++ b/emulators/aqemu/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= vncclient.0:${PORTSDIR}/net/libvncserver
USE_BZIP2= yes
USE_QT4= gui qtestlib xml qmake_build uic_build moc_build rcc_build \
linguist_build
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S,.0$,,}
diff --git a/emulators/dolphin-emu-devel/Makefile b/emulators/dolphin-emu-devel/Makefile
index 87fd3a7b0cd9..9348b31ca869 100644
--- a/emulators/dolphin-emu-devel/Makefile
+++ b/emulators/dolphin-emu-devel/Makefile
@@ -38,7 +38,7 @@ DOS2UNIX_REGEX= .*\.(h|c|cpp)
USE_GCC= 4.6+
.endif
-USE_CMAKE= yes
+USES= cmake
CMAKE_BUILD_TYPE= Release
# Disable ao (seems buggy) and ALSA (emulated)
CMAKE_ARGS+= -DDISABLE_AO:BOOL=ON \
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index 06029ab8c15b..ec391411bb8a 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
USE_GNOME= pygtk2
USE_SDL= sdl
USE_READLINE= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DPORTAUDIO_INCLUDE_DIR:STRING="${PA2_INCLUDE_DIR}" \
-DPORTAUDIO_LIBRARY:STRING="${PA2_LIBRARY}" \
-DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
diff --git a/emulators/joytran/Makefile b/emulators/joytran/Makefile
index f7cac8b27a86..de9b46f11ea8 100644
--- a/emulators/joytran/Makefile
+++ b/emulators/joytran/Makefile
@@ -20,7 +20,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# This is needed to fetch from BerliOS
FETCH_ARGS= "-Fpr"
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" -DPREFIX="${PREFIX}"
.if !defined(NOPORTDOCS)
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index 3d4b68601b69..372369521e9a 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -19,8 +19,7 @@ CONFLICTS= trousers-tddl-[0-9d]*
USE_RC_SUBR= tpmd
-USE_CMAKE= yes
-CMAKE_OUTSOURCE=yes
+USES= cmake:outsource
CMAKE_ENV= PREFIX="${PREFIX}"
CMAKE_ARGS= -DTPM_INCLUDE_DIRS:STRING="${LOCALBASE}/include" \
-DTPM_LIBRARY_DIRS:STRING="${LOCALBASE}/lib"
diff --git a/emulators/visualboyadvance-m/Makefile b/emulators/visualboyadvance-m/Makefile
index 00fd26a4ec2f..051b43c1f09c 100644
--- a/emulators/visualboyadvance-m/Makefile
+++ b/emulators/visualboyadvance-m/Makefile
@@ -28,7 +28,7 @@ DOS2UNIX_REGEX= .*\.(c|cpp|h)
USE_XORG= x11 xext
USE_GL= gl glu
USE_SDL= sdl
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DVERSION:STRING="${PORTVERSION}" -DSYSCONFDIR:STRING="${PREFIX}/etc"
SVN_REV= 1001