aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2003-02-13 03:15:54 +0800
committeralex <alex@FreeBSD.org>2003-02-13 03:15:54 +0800
commit2b1277887780e965dbf7af7fb08227f19520d6b2 (patch)
tree24be504c980ccd981ea628dd68fbbdc57d6f7bde /emulators
parent637c75ea935b0d89945dccc4d3fe2afef892ecfd (diff)
downloadfreebsd-ports-gnome-2b1277887780e965dbf7af7fb08227f19520d6b2.tar.gz
freebsd-ports-gnome-2b1277887780e965dbf7af7fb08227f19520d6b2.tar.zst
freebsd-ports-gnome-2b1277887780e965dbf7af7fb08227f19520d6b2.zip
Seems like I had another fix in my system. On 5.0, the vmnet1 in
$LINUXBASE/dev had a different device minor than the cloned one in /dev/vmnet1. Thus delete the one in $LINUXBASE and link it to the devfs one to have everything right. This fixes the port on my fresh installed 5.0-RELEASE box.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vmware2/Makefile6
-rw-r--r--emulators/vmware3/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index eac87f137c14..00c5b6c80057 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -114,7 +114,7 @@ post-patch:
cat ${FILESDIR}/fo_ioctl.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
.endif
.if ${OSVERSION} >= 500100
- cat ${FILESDIR}/filedesc.patch | (cd ${WRKSRC} && patch)
+ cat ${FILESDIR}/filedesc.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
cat ${FILESDIR}/m_waitok.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
.endif
@@ -174,6 +174,10 @@ pre-install: setoptions
post-install:
${LN} -sf ${PREFIX}/etc/vmware /etc/
+.if ${OSVERSION} >= 500100
+ ${RM} -f ${LINUXBASE}/dev/vmnet1
+ ${LN} -sf /dev/vmnet1 ${LINUXBASE}/dev/vmnet1
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index eac87f137c14..00c5b6c80057 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -114,7 +114,7 @@ post-patch:
cat ${FILESDIR}/fo_ioctl.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
.endif
.if ${OSVERSION} >= 500100
- cat ${FILESDIR}/filedesc.patch | (cd ${WRKSRC} && patch)
+ cat ${FILESDIR}/filedesc.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
cat ${FILESDIR}/m_waitok.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
.endif
@@ -174,6 +174,10 @@ pre-install: setoptions
post-install:
${LN} -sf ${PREFIX}/etc/vmware /etc/
+.if ${OSVERSION} >= 500100
+ ${RM} -f ${LINUXBASE}/dev/vmnet1
+ ${LN} -sf /dev/vmnet1 ${LINUXBASE}/dev/vmnet1
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>