aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2002-12-03 04:36:25 +0800
committerjoerg <joerg@FreeBSD.org>2002-12-03 04:36:25 +0800
commit8c2e2a1323ecde53f139addac46a6f9f57c6fd37 (patch)
tree7e74089e64dcfaa9817f60be616577523ac2b01e /emulators
parent9649d213ef5bf58ef6faa02f6605b4551866e919 (diff)
downloadfreebsd-ports-gnome-8c2e2a1323ecde53f139addac46a6f9f57c6fd37.tar.gz
freebsd-ports-gnome-8c2e2a1323ecde53f139addac46a6f9f57c6fd37.tar.zst
freebsd-ports-gnome-8c2e2a1323ecde53f139addac46a6f9f57c6fd37.zip
Make this port build under -current. (Of course, it'll also build under
-stable still. ;-) gcc 3 is (correctly) a lot more picky about some suspicious cpp constructs that remained undetected in the original sources until now.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/pcemu/Makefile1
-rw-r--r--emulators/pcemu/files/patch-e1-gcc333
2 files changed, 34 insertions, 0 deletions
diff --git a/emulators/pcemu/Makefile b/emulators/pcemu/Makefile
index 1a742b3374b9..947b56ca7ff3 100644
--- a/emulators/pcemu/Makefile
+++ b/emulators/pcemu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pcemu
PORTVERSION= 1.01b
+PORTREVISION= 1
CATEGORIES= emulators
#
# This could in theory become a chicken-and-egg problem. Anyway,
diff --git a/emulators/pcemu/files/patch-e1-gcc3 b/emulators/pcemu/files/patch-e1-gcc3
new file mode 100644
index 000000000000..fb30e447e257
--- /dev/null
+++ b/emulators/pcemu/files/patch-e1-gcc3
@@ -0,0 +1,33 @@
+--- cpu.c.orig Mon Dec 2 21:31:48 2002
++++ cpu.c Mon Dec 2 21:31:40 2002
+@@ -253,7 +253,7 @@
+
+
+ #define JumpCond(name, cond) \
+-static INLINE2 void i_j ## name ## (void) \
++static INLINE2 void i_j ## name (void) \
+ { \
+ register int tmp = (int)((INT8)GetMemInc(c_cs,ip)); \
+ if (cond) ip = (WORD)(ip+tmp); \
+--- mfs_link.h.orig Wed Jun 22 16:24:51 1994
++++ mfs_link.h Mon Dec 2 21:31:40 2002
+@@ -41,7 +41,7 @@
+
+
+ #define REGS vm86s.regs
+-#define REG(reg) (REGS.##reg)
++#define REG(reg) (REGS.reg)
+
+ #define CF (1 << 0)
+ #define TF (1 << 8)
+--- mfs.h.orig Mon Dec 2 21:31:48 2002
++++ mfs.h Mon Dec 2 21:31:40 2002
+@@ -49,7 +49,7 @@
+ extern char *sys_errlist[];
+ #endif
+
+-#if !defined(__hpux) && !defined(SOLARIS) && !defined(SGI) && !defined(RS6000)
++#if !defined(__hpux) && !defined(SOLARIS) && !defined(SGI) && !defined(RS6000) && !defined(__FreeBSD__)
+ #define strerror(x) sys_errlist[x]
+ #endif
+