aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-05-22 02:23:59 +0800
committererwin <erwin@FreeBSD.org>2006-05-22 02:23:59 +0800
commit9b3fcf27f39ad2d763eb05756077fb09589ff703 (patch)
tree9899a8a052ad5a945b7f551f2ea0286050a536d9 /emulators
parent4856edb061d01c8b0fca40525727eb8d51ed0337 (diff)
downloadfreebsd-ports-gnome-9b3fcf27f39ad2d763eb05756077fb09589ff703.tar.gz
freebsd-ports-gnome-9b3fcf27f39ad2d763eb05756077fb09589ff703.tar.zst
freebsd-ports-gnome-9b3fcf27f39ad2d763eb05756077fb09589ff703.zip
Try a different way to find(1) to prevent chmod(1) from traversing
into linprocfs as fstype doesn't seem to work on pointyhat. Not bumping PORTREVISION as it only affects pointyhat. Submitted by: kris Approved by: Kövesdán Gábor <gabor.kovesdan@t-hosting.hu> (maintainer)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-gentoo-stage1/Makefile2
-rw-r--r--emulators/linux_dist-gentoo-stage1/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/emulators/linux_base-gentoo-stage1/Makefile b/emulators/linux_base-gentoo-stage1/Makefile
index 821efabc1a3a..16cdc4075a71 100644
--- a/emulators/linux_base-gentoo-stage1/Makefile
+++ b/emulators/linux_base-gentoo-stage1/Makefile
@@ -60,7 +60,7 @@ do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${TAR} --exclude=./dev -xpy --exclude=./proc -C ${PREFIX} \
-f ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
- @${FIND} ${PREFIX} -fstype ufs -type d -exec ${CHMOD} 755 \{\} \;
+ ${FIND} ${PREFIX} \! -path "/compat/linux/proc*" -type d -exec ${CHMOD} 755 \{\} \;
@${CP} -p /etc/resolv.conf ${PREFIX}/etc/
@${BRANDELF} -t Linux ${PREFIX}/sbin/ldconfig ${PREFIX}/sbin/sln
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/emulators/linux_dist-gentoo-stage1/Makefile b/emulators/linux_dist-gentoo-stage1/Makefile
index 821efabc1a3a..16cdc4075a71 100644
--- a/emulators/linux_dist-gentoo-stage1/Makefile
+++ b/emulators/linux_dist-gentoo-stage1/Makefile
@@ -60,7 +60,7 @@ do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${TAR} --exclude=./dev -xpy --exclude=./proc -C ${PREFIX} \
-f ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES}
- @${FIND} ${PREFIX} -fstype ufs -type d -exec ${CHMOD} 755 \{\} \;
+ ${FIND} ${PREFIX} \! -path "/compat/linux/proc*" -type d -exec ${CHMOD} 755 \{\} \;
@${CP} -p /etc/resolv.conf ${PREFIX}/etc/
@${BRANDELF} -t Linux ${PREFIX}/sbin/ldconfig ${PREFIX}/sbin/sln
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL