aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-05-08 17:13:35 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-05-08 17:13:35 +0800
commitb2ac80ce8a47d9edd4a68340243efa2138c27e22 (patch)
treec5640d596ed4bec04c8f648025b0c0123c49ab52 /emulators
parenta0b44565762e269bef1c2cf7293603165747aad7 (diff)
downloadfreebsd-ports-gnome-b2ac80ce8a47d9edd4a68340243efa2138c27e22.tar.gz
freebsd-ports-gnome-b2ac80ce8a47d9edd4a68340243efa2138c27e22.tar.zst
freebsd-ports-gnome-b2ac80ce8a47d9edd4a68340243efa2138c27e22.zip
- Fix build with clang
Approved by: portmgr blanket MFH: 2015Q2
Diffstat (limited to 'emulators')
-rw-r--r--emulators/yape/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/emulators/yape/Makefile b/emulators/yape/Makefile
index fd2d72b47f65..c38ce0291730 100644
--- a/emulators/yape/Makefile
+++ b/emulators/yape/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= jmohacsi@bsd.hu
COMMENT= Yet Another Commodore +4 Emulator
USE_SDL= sdl
-USES= gmake
+USES= compiler:features gmake
NO_WRKSUBDIR= yes
ALL_TARGET= yape
@@ -21,12 +21,17 @@ PORTDOCS= README.SDL
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
post-extract:
@${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|cpp|h|txt)" -print0 | \
${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
@${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' ${WRKSRC}/Makefile
post-patch:
+.if ${COMPILER_TYPE} == clang
+ @${REINPLACE_CMD} -e "s|-frerun-loop-opt||" ${WRKSRC}/Makefile
+.endif
@${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG}|" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s|TAP::TAP|TAP|" ${WRKSRC}/tape.h
@@ -37,4 +42,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.SDL ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>