aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2008-01-12 07:13:23 +0800
committergerald <gerald@FreeBSD.org>2008-01-12 07:13:23 +0800
commitba741fba1dd99df96ebc5a63c5c0165a2524f7d4 (patch)
treef75b49ac686ff92121650bbe03c382413fa1ab20 /emulators
parent4e7f91317cf24a73cdb80fcc91a904a41bee1d98 (diff)
downloadfreebsd-ports-gnome-ba741fba1dd99df96ebc5a63c5c0165a2524f7d4.tar.gz
freebsd-ports-gnome-ba741fba1dd99df96ebc5a63c5c0165a2524f7d4.tar.zst
freebsd-ports-gnome-ba741fba1dd99df96ebc5a63c5c0165a2524f7d4.zip
Update to Wine 0.9.53. Among others, this includes the following changes:
- RunOnce and Run entries now executed on startup. - Beginnings of support for emulated disk devices. - Many Richedit improvements. - Nicer looking color dialog. - Lots of bug fixes. Plus, importantly, the ability to disable the use of certain libraries when build Wine via --without-cups and the like which we'll shortly use to add appropriate options.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile10
-rw-r--r--emulators/wine-devel/distinfo6
-rw-r--r--emulators/wine-devel/pkg-plist2
-rw-r--r--emulators/wine/Makefile10
-rw-r--r--emulators/wine/distinfo6
-rw-r--r--emulators/wine/pkg-plist2
6 files changed, 22 insertions, 14 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 5e0ee35c0630..073119e1f7a6 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9.52
+PORTVERSION= 0.9.53
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
@@ -58,9 +58,11 @@ pre-build:
cd ${WRKSRC} && make depend
post-install:
- ${RM} -f ${MAN1PREFIX}/man/de.UTF-8/man1/wine.1
- -${RMDIR} ${MAN1PREFIX}/man/de.UTF-8/man1
- -${RMDIR} ${MAN1PREFIX}/man/de.UTF-8/
+ ${RM} -f ${MAN1PREFIX}/man/de.UTF-8/man1/wine.1 \
+ ${MAN1PREFIX}/man/fr.UTF-8/man1/wine.1 \
+ ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1
+ -${RMDIR} -p ${MAN1PREFIX}/man/de.UTF-8 \
+ ${MAN1PREFIX}/man/fr.UTF-8
${MV} -f ${PREFIX}/lib/libwine.so.1.0 ${PREFIX}/lib/libwine.so.1
${LN} -sf libwine.so.1 ${PREFIX}/lib/libwine.so
.if !defined(NOPORTDOCS)
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index b87464434821..9a0a4a633f1a 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-0.9.52.tar.bz2) = c3b14ac84f049a2db28cd41c3f71998b
-SHA256 (wine-0.9.52.tar.bz2) = de3fabb72b69b088ff5c8f769e9478bdc07ff3a247428c660e12ac5cae3b6026
-SIZE (wine-0.9.52.tar.bz2) = 12966473
+MD5 (wine-0.9.53.tar.bz2) = 48fe690c6f37302401adde4cf5db7c19
+SHA256 (wine-0.9.53.tar.bz2) = 06317d78b7db39458656b6acc6b265ce97f358aefd7ded679263f397a89f1200
+SIZE (wine-0.9.53.tar.bz2) = 13064017
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index d9ff0c008b07..5cb2d799000f 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -130,6 +130,7 @@ include/wine/windows/d3dx8core.h
include/wine/windows/d3dx8math.h
include/wine/windows/d3dx8math.inl
include/wine/windows/d3dx9.h
+include/wine/windows/d3dx9core.h
include/wine/windows/d3dx9math.h
include/wine/windows/d3dx9math.inl
include/wine/windows/dbghelp.h
@@ -767,6 +768,7 @@ lib/wine/mlang.dll.so
lib/wine/mmdevldr.vxd.so
lib/wine/mmsystem.dll16
lib/wine/monodebg.vxd.so
+lib/wine/mountmgr.sys.so
lib/wine/mouse.drv16
lib/wine/mpr.dll.so
lib/wine/mprapi.dll.so
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 5e0ee35c0630..073119e1f7a6 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9.52
+PORTVERSION= 0.9.53
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
@@ -58,9 +58,11 @@ pre-build:
cd ${WRKSRC} && make depend
post-install:
- ${RM} -f ${MAN1PREFIX}/man/de.UTF-8/man1/wine.1
- -${RMDIR} ${MAN1PREFIX}/man/de.UTF-8/man1
- -${RMDIR} ${MAN1PREFIX}/man/de.UTF-8/
+ ${RM} -f ${MAN1PREFIX}/man/de.UTF-8/man1/wine.1 \
+ ${MAN1PREFIX}/man/fr.UTF-8/man1/wine.1 \
+ ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1
+ -${RMDIR} -p ${MAN1PREFIX}/man/de.UTF-8 \
+ ${MAN1PREFIX}/man/fr.UTF-8
${MV} -f ${PREFIX}/lib/libwine.so.1.0 ${PREFIX}/lib/libwine.so.1
${LN} -sf libwine.so.1 ${PREFIX}/lib/libwine.so
.if !defined(NOPORTDOCS)
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index b87464434821..9a0a4a633f1a 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-0.9.52.tar.bz2) = c3b14ac84f049a2db28cd41c3f71998b
-SHA256 (wine-0.9.52.tar.bz2) = de3fabb72b69b088ff5c8f769e9478bdc07ff3a247428c660e12ac5cae3b6026
-SIZE (wine-0.9.52.tar.bz2) = 12966473
+MD5 (wine-0.9.53.tar.bz2) = 48fe690c6f37302401adde4cf5db7c19
+SHA256 (wine-0.9.53.tar.bz2) = 06317d78b7db39458656b6acc6b265ce97f358aefd7ded679263f397a89f1200
+SIZE (wine-0.9.53.tar.bz2) = 13064017
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index d9ff0c008b07..5cb2d799000f 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -130,6 +130,7 @@ include/wine/windows/d3dx8core.h
include/wine/windows/d3dx8math.h
include/wine/windows/d3dx8math.inl
include/wine/windows/d3dx9.h
+include/wine/windows/d3dx9core.h
include/wine/windows/d3dx9math.h
include/wine/windows/d3dx9math.inl
include/wine/windows/dbghelp.h
@@ -767,6 +768,7 @@ lib/wine/mlang.dll.so
lib/wine/mmdevldr.vxd.so
lib/wine/mmsystem.dll16
lib/wine/monodebg.vxd.so
+lib/wine/mountmgr.sys.so
lib/wine/mouse.drv16
lib/wine/mpr.dll.so
lib/wine/mprapi.dll.so