aboutsummaryrefslogtreecommitdiffstats
path: root/finance/bitcoin-armory
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2015-10-24 10:25:45 +0800
committerjunovitch <junovitch@FreeBSD.org>2015-10-24 10:25:45 +0800
commit259caa6c4c8f881336af4cc87e6f88f638d010e1 (patch)
tree097c1b467c608282e4e82b84655104f53f90b9e1 /finance/bitcoin-armory
parent265e8e0160cde7b43e8239e3dd981a3735fac25e (diff)
downloadfreebsd-ports-gnome-259caa6c4c8f881336af4cc87e6f88f638d010e1.tar.gz
freebsd-ports-gnome-259caa6c4c8f881336af4cc87e6f88f638d010e1.tar.zst
freebsd-ports-gnome-259caa6c4c8f881336af4cc87e6f88f638d010e1.zip
finance/bitcoin-armory: update 0.92.3 -> 0.93.2
- Update PORTVERSION, distinfo, pkg-plist, and patches for 0.93.2 - Remove "Implementation of" word fluff from COMMENT - Add missing run-dep on bitcoin daemon - USES: Add compiler:c++11-lang and compiler:c++11-lib - USES: Restrict to python:2 - Remove USE_GCC, set and pass CXXFLAGS - Mark BROKEN on FreeBSD 9 due upstream issues with atomic ops on FreeBSD - Use INSTALL_ICONS and install several during post-stage PR: 199490 Submitted by: yuri@rawbw.com (maintainer)
Diffstat (limited to 'finance/bitcoin-armory')
-rw-r--r--finance/bitcoin-armory/Makefile30
-rw-r--r--finance/bitcoin-armory/distinfo4
-rw-r--r--finance/bitcoin-armory/files/patch-ArmoryQt.py36
-rw-r--r--finance/bitcoin-armory/files/patch-Makefile4
-rw-r--r--finance/bitcoin-armory/files/patch-announcefetch.py4
-rw-r--r--finance/bitcoin-armory/files/patch-armoryengine_ArmoryUtils.py (renamed from finance/bitcoin-armory/files/patch-ArmoryUtils.py)22
-rw-r--r--finance/bitcoin-armory/files/patch-armoryengine_Transaction.py18
-rw-r--r--finance/bitcoin-armory/files/patch-cppForSwig-Makefile17
-rw-r--r--finance/bitcoin-armory/files/patch-cppForSwig_Makefile19
-rw-r--r--finance/bitcoin-armory/files/patch-cppForSwig_cryptopp_Makefile (renamed from finance/bitcoin-armory/files/patch-cppForSwig-cryptopp-Makefile)4
-rw-r--r--finance/bitcoin-armory/files/patch-dpkgfiles_armory (renamed from finance/bitcoin-armory/files/patch-dpkgfiles-armory)2
-rw-r--r--finance/bitcoin-armory/pkg-message8
-rw-r--r--finance/bitcoin-armory/pkg-plist16
13 files changed, 111 insertions, 73 deletions
diff --git a/finance/bitcoin-armory/Makefile b/finance/bitcoin-armory/Makefile
index 5cc3a56e57f8..13b881434b67 100644
--- a/finance/bitcoin-armory/Makefile
+++ b/finance/bitcoin-armory/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= BitcoinArmory
-PORTVERSION= 0.92.3
-PORTREVISION= 1
+PORTVERSION= 0.93.2
DISTVERSIONPREFIX= v
CATEGORIES= finance
MAINTAINER= yuri@rawbw.com
-COMMENT= Implementation of desktop bitcoin management system
+COMMENT= Desktop bitcoin management system
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -19,27 +18,42 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:${PORTSDIR}/devel/swig30 \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-core \
${PYTHON_PKGNAMEPREFIX}qt4-gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-qt4-gui \
${PYTHON_PKGNAMEPREFIX}twistedCore>=14.0.0:${PORTSDIR}/devel/py-twistedCore \
- ${PYTHON_PKGNAMEPREFIX}psutil>1.2.1:${PORTSDIR}/sysutils/py-psutil
+ ${PYTHON_PKGNAMEPREFIX}psutil>1.2.1:${PORTSDIR}/sysutils/py-psutil \
+ ${LOCALBASE}/bin/bitcoind:${PORTSDIR}/net-p2p/bitcoin-daemon
USE_GITHUB= yes
GH_ACCOUNT= etotheipi
-USES= gmake python shebangfix
+USES= compiler:c++11-lang compiler:c++11-lib gmake python:2 shebangfix
SHEBANG_FILES= extras/extractKeysFromWallet.py
-USE_GCC= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM -fPIC
MAKE_ENV+= PYTHON_CONFIG=${PYTHON_CMD}-config
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= low-level code available only for i386 and amd64
+BROKEN_FreeBSD_9= cannot find atomic header
+
+MAKE_ARGS+= CXXFLAGS="${CXXFLAGS}"
+INSTALLS_ICONS= yes
+ICON_SIZES= 24x24 32x32 64x64
+
+# When CRYPTOPP_DISABLE_ASM isn't needed any more, i386 amd64 should
+# be made work through ASM code, and the other archs will still
+# have CRYPTOPP_DISABLE_ASM
post-patch:
@${REINPLACE_CMD} 's/python-config/$${PYTHON_CONFIG}/' ${WRKSRC}/cppForSwig/Makefile
+ @${REINPLACE_CMD} 's/O_DSYNC/O_SYNC/' ${WRKSRC}/cppForSwig/mdb/mdb.c
post-stage:
@${SED} -i.bak -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${STAGEDIR}/${LOCALBASE}/bin/armory && \
${RM} -f ${STAGEDIR}/${LOCALBASE}/bin/armory.bak
+ @${REINPLACE_CMD} 's|Exec=/usr/bin/armory|Exec=${LOCALBASE}/bin/armory|' ${STAGEDIR}/${LOCALBASE}/share/applications/*.desktop
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
+ ${MV} ${STAGEDIR}/${PREFIX}/share/armory/img/armory_icon_${s}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/armoryicon.png
+.endfor
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/armory/_CppBlockUtils.so
diff --git a/finance/bitcoin-armory/distinfo b/finance/bitcoin-armory/distinfo
index 0ad9ba5e72ca..e445d74bde3d 100644
--- a/finance/bitcoin-armory/distinfo
+++ b/finance/bitcoin-armory/distinfo
@@ -1,2 +1,2 @@
-SHA256 (etotheipi-BitcoinArmory-v0.92.3_GH0.tar.gz) = 349a734997527c34f66d53cdeb987aa6345907703a6d62dc48f7e5487933a13a
-SIZE (etotheipi-BitcoinArmory-v0.92.3_GH0.tar.gz) = 4698713
+SHA256 (etotheipi-BitcoinArmory-v0.93.2_GH0.tar.gz) = 0efcf179a4ea0c2e8f873378d5f171efefe720cb91ba2208223871bc1b83ac71
+SIZE (etotheipi-BitcoinArmory-v0.93.2_GH0.tar.gz) = 4774815
diff --git a/finance/bitcoin-armory/files/patch-ArmoryQt.py b/finance/bitcoin-armory/files/patch-ArmoryQt.py
index 96e35c1415b7..08a786d2edf7 100644
--- a/finance/bitcoin-armory/files/patch-ArmoryQt.py
+++ b/finance/bitcoin-armory/files/patch-ArmoryQt.py
@@ -1,12 +1,12 @@
---- ArmoryQt.py
+--- ArmoryQt.py.orig 2015-06-10 21:49:31 UTC
+++ ArmoryQt.py
@@ -1,4 +1,4 @@
-#! /usr/bin/python
+#!/usr/bin/env python
+ # -*- coding: UTF-8 -*-
################################################################################
# #
- # Copyright (C) 2011-2014, Armory Technologies, Inc. #
-@@ -1089,6 +1089,9 @@
+@@ -1236,6 +1236,9 @@ class ArmoryMainWindow(QMainWindow):
elif OS_LINUX:
tempDir = '/var/log'
extraFiles = ['/var/log/Xorg.0.log']
@@ -16,7 +16,7 @@
elif OS_MACOSX:
tempDir = '/var/log'
extraFiles = ['/var/log/system.log']
-@@ -1369,7 +1372,7 @@
+@@ -1516,7 +1519,7 @@ class ArmoryMainWindow(QMainWindow):
if USE_TESTNET:
return
@@ -25,7 +25,7 @@
out,err = execAndWait('gconftool-2 --get /desktop/gnome/url-handlers/bitcoin/command')
out2,err = execAndWait('xdg-mime query default x-scheme-handler/bitcoin')
-@@ -1890,6 +1893,8 @@
+@@ -2104,6 +2107,8 @@ class ArmoryMainWindow(QMainWindow):
shortOS = 'windows'
elif OS_LINUX:
shortOS = 'ubuntu'
@@ -34,22 +34,22 @@
elif OS_MACOSX:
shortOS = 'mac'
-@@ -4708,6 +4713,8 @@
+@@ -4570,6 +4575,8 @@ class ArmoryMainWindow(QMainWindow):
+ Download and Install Bitcoin Core for Ubuntu/Debian"""))
+ self.dashBtns[DASHBTNS.Install][TTIP] = self.createToolTipWidget( tr("""
'Will download and Bitcoin software and cryptographically verify it"""))
- elif OS_MACOSX:
- pass
+ elif OS_FREEBSD:
+ pass
+ elif OS_MACOSX:
+ pass
else:
- LOGERROR('Unrecognized OS!')
-
-@@ -5101,8 +5108,7 @@
- #############################################################################
+@@ -4970,8 +4977,7 @@ class ArmoryMainWindow(QMainWindow):
def closeExistingBitcoin(self):
for proc in psutil.process_iter():
-- if proc.name.lower() in ['bitcoind.exe','bitcoin-qt.exe',\
-- 'bitcoind','bitcoin-qt']:
-+ if proc.name() in ['bitcoind','bitcoin-qt']:
- killProcess(proc.pid)
- time.sleep(2)
- return
+ try:
+- if proc.name().lower() in ['bitcoind.exe','bitcoin-qt.exe',\
+- 'bitcoind','bitcoin-qt']:
++ if proc.name() in ['bitcoind','bitcoin-qt']:
+ killProcess(proc.pid)
+ time.sleep(2)
+ return
diff --git a/finance/bitcoin-armory/files/patch-Makefile b/finance/bitcoin-armory/files/patch-Makefile
index e746ee1f8a60..d943bf577ad3 100644
--- a/finance/bitcoin-armory/files/patch-Makefile
+++ b/finance/bitcoin-armory/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile
+--- Makefile.orig 2015-06-10 21:49:31 UTC
+++ Makefile
@@ -1,7 +1,7 @@
# All the actual Makefiles are deeper in the directory tree.
@@ -7,5 +7,5 @@
-PREFIX=/usr
+PREFIX?=/usr
DESTDIR=
+ UNAME_S := $(shell uname -s)
- all :
diff --git a/finance/bitcoin-armory/files/patch-announcefetch.py b/finance/bitcoin-armory/files/patch-announcefetch.py
index 8b4ab8641ea1..0f33009bfbfc 100644
--- a/finance/bitcoin-armory/files/patch-announcefetch.py
+++ b/finance/bitcoin-armory/files/patch-announcefetch.py
@@ -1,6 +1,6 @@
---- announcefetch.py
+--- announcefetch.py.orig 2015-06-10 21:49:31 UTC
+++ announcefetch.py
-@@ -213,6 +213,8 @@ class AnnounceDataFetcher(object):
+@@ -235,6 +235,8 @@ class AnnounceDataFetcher(object):
argsMap['os'] = 'win'
elif OS_LINUX:
argsMap['os'] = 'lin'
diff --git a/finance/bitcoin-armory/files/patch-ArmoryUtils.py b/finance/bitcoin-armory/files/patch-armoryengine_ArmoryUtils.py
index 1c796c6214ec..76ed2abbffa0 100644
--- a/finance/bitcoin-armory/files/patch-ArmoryUtils.py
+++ b/finance/bitcoin-armory/files/patch-armoryengine_ArmoryUtils.py
@@ -1,6 +1,6 @@
---- armoryengine/ArmoryUtils.py
+--- armoryengine/ArmoryUtils.py.orig 2015-06-10 21:49:31 UTC
+++ armoryengine/ArmoryUtils.py
-@@ -208,6 +208,7 @@ class P2SHNotSupportedError(Exception): pass
+@@ -234,6 +234,7 @@ class isMSWallet(Exception): pass
opsys = platform.system()
OS_WINDOWS = 'win32' in opsys.lower() or 'windows' in opsys.lower()
OS_LINUX = 'nix' in opsys.lower() or 'nux' in opsys.lower()
@@ -8,7 +8,7 @@
OS_MACOSX = 'darwin' in opsys.lower() or 'osx' in opsys.lower()
-@@ -276,6 +277,14 @@ elif OS_LINUX:
+@@ -307,6 +308,14 @@ elif OS_LINUX:
ARMORY_HOME_DIR = os.path.join(USER_HOME_DIR, '.armory', SUBDIR)
BLKFILE_DIR = os.path.join(BTC_HOME_DIR, 'blocks')
BLKFILE_1stFILE = os.path.join(BLKFILE_DIR, 'blk00000.dat')
@@ -23,7 +23,7 @@
elif OS_MACOSX:
platform.mac_ver()
OS_NAME = 'MacOSX'
-@@ -293,6 +302,7 @@ else:
+@@ -324,6 +333,7 @@ else:
opsys = platform.system()
OS_WINDOWS = 'win32' in opsys.lower() or 'windows' in opsys.lower()
OS_LINUX = 'nix' in opsys.lower() or 'nux' in opsys.lower()
@@ -31,16 +31,16 @@
OS_MACOSX = 'darwin' in opsys.lower() or 'osx' in opsys.lower()
BLOCKCHAINS = {}
-@@ -631,7 +641,7 @@ def killProcessTree(pid):
- # call, because have bundled a recent version of psutil. Linux, however,
- # does not have that function call in earlier versions.
- from subprocess import Popen, PIPE
+@@ -679,7 +689,7 @@ def killProcessTree(pid):
+ else:
+ from subprocess_win import Popen, PIPE
+
- if not OS_LINUX:
+ if not OS_LINUX and not OS_FREEBSD:
for child in psutil.Process(pid).get_children():
killProcess(child.pid)
else:
-@@ -1007,7 +1017,7 @@ except:
+@@ -1080,7 +1090,7 @@ except:
LOGCRIT(' in the current directory (or added to the PATH)')
LOGCRIT(' Specifically, you need:')
LOGCRIT(' CppBlockUtils.py and')
@@ -49,7 +49,7 @@
LOGCRIT(' _CppBlockUtils.so')
elif OS_WINDOWS:
LOGCRIT(' _CppBlockUtils.pyd')
-@@ -1041,6 +1051,11 @@ def GetSystemDetails():
+@@ -1114,6 +1124,11 @@ def GetSystemDetails():
out.CpuStr = line.split(':')[1].strip()
break
@@ -61,7 +61,7 @@
elif OS_WINDOWS:
import ctypes
-@@ -1542,7 +1557,7 @@ except:
+@@ -1619,7 +1634,7 @@ except:
LOGCRIT(' in the current directory (or added to the PATH)')
LOGCRIT(' Specifically, you need:')
LOGCRIT(' CppBlockUtils.py and')
diff --git a/finance/bitcoin-armory/files/patch-armoryengine_Transaction.py b/finance/bitcoin-armory/files/patch-armoryengine_Transaction.py
new file mode 100644
index 000000000000..3baf80b6fbb6
--- /dev/null
+++ b/finance/bitcoin-armory/files/patch-armoryengine_Transaction.py
@@ -0,0 +1,18 @@
+--- armoryengine/Transaction.py.orig 2015-06-10 21:49:31 UTC
++++ armoryengine/Transaction.py
+@@ -15,6 +15,7 @@ from armoryengine.BinaryUnpacker import
+
+ from armoryengine.AsciiSerialize import AsciiSerializable
+
++from armoryengine.MultiSigUtils import *
+
+ UNSIGNED_TX_VERSION = 1
+
+@@ -2674,7 +2675,6 @@ def PyCreateAndSignTx(ustxiList, dtxoLis
+ #
+ def PyCreateAndSignTx_old(srcTxOuts, dstAddrsVals):
+ # This needs to support multisig. Perhaps the funct should just be moved....
+- from armoryengine.MultiSigUtils import *
+
+ newTx = PyTx()
+ newTx.version = 1
diff --git a/finance/bitcoin-armory/files/patch-cppForSwig-Makefile b/finance/bitcoin-armory/files/patch-cppForSwig-Makefile
deleted file mode 100644
index f62647a71165..000000000000
--- a/finance/bitcoin-armory/files/patch-cppForSwig-Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
---- cppForSwig/Makefile
-+++ cppForSwig/Makefile
-@@ -1,4 +1,4 @@
--CXX = g++
-+CXX ?= g++
-
- ifdef DEBUG
- CFLAGS=-g3 -Wall -pipe -fPIC
-@@ -68,7 +68,7 @@
- BlockUtils.o: log.h BinaryData.h UniversalTimer.h PartialMerkle.h
- EncryptionUtils.o: log.h BtcUtils.h BinaryData.h
- CppBlockUtils_wrap.cxx: log.h BlockUtils.h BinaryData.h BlockObj.h UniversalTimer.h BlockUtils.h BlockUtils.cpp CppBlockUtils.i
-- swig $(SWIG_OPTS) -outdir ../ -v CppBlockUtils.i
-+ swig3.0 $(SWIG_OPTS) -outdir ../ -v CppBlockUtils.i
-
- CppBlockUtils_wrap.o: log.h BlockUtils.h BinaryData.h UniversalTimer.h CppBlockUtils_wrap.cxx
- $(CXX) $(SWIG_INC) $(CXXFLAGS) $(CXXCPP) -c CppBlockUtils_wrap.cxx
diff --git a/finance/bitcoin-armory/files/patch-cppForSwig_Makefile b/finance/bitcoin-armory/files/patch-cppForSwig_Makefile
new file mode 100644
index 000000000000..f8c80ce63a5f
--- /dev/null
+++ b/finance/bitcoin-armory/files/patch-cppForSwig_Makefile
@@ -0,0 +1,19 @@
+--- cppForSwig/Makefile.orig 2015-06-10 21:49:31 UTC
++++ cppForSwig/Makefile
+@@ -1,5 +1,5 @@
+-CXX = g++
+-CC = gcc
++CXX ?= g++
++CC ?= gcc
+
+ ifdef DEBUG
+ CFLAGS=-g3 -Wall -pipe -fPIC
+@@ -97,7 +97,7 @@ midl.o: mdb/midl.c mdb/lmdb.h mdb/midl.h
+
+
+ CppBlockUtils_wrap.cxx: $(ALL_HEADERS) CppBlockUtils.i
+- swig $(SWIG_OPTS) -outdir ../ -v CppBlockUtils.i
++ swig3.0 $(SWIG_OPTS) -outdir ../ -v CppBlockUtils.i
+
+ CppBlockUtils_wrap.o: $(ALL_HEADERS) CppBlockUtils_wrap.cxx
+ $(CXX) $(SWIG_INC) $(CXXFLAGS) $(CXXCPP) -c CppBlockUtils_wrap.cxx
diff --git a/finance/bitcoin-armory/files/patch-cppForSwig-cryptopp-Makefile b/finance/bitcoin-armory/files/patch-cppForSwig_cryptopp_Makefile
index e02d676223e8..6350e20fcf91 100644
--- a/finance/bitcoin-armory/files/patch-cppForSwig-cryptopp-Makefile
+++ b/finance/bitcoin-armory/files/patch-cppForSwig_cryptopp_Makefile
@@ -1,6 +1,6 @@
---- cppForSwig/cryptopp/Makefile
+--- cppForSwig/cryptopp/Makefile.orig 2015-06-10 21:49:31 UTC
+++ cppForSwig/cryptopp/Makefile
-@@ -105,6 +105,19 @@
+@@ -117,6 +117,19 @@ LDLIBS += -lnsl -lsocket
M32OR64 = -m$(shell isainfo -b)
endif
diff --git a/finance/bitcoin-armory/files/patch-dpkgfiles-armory b/finance/bitcoin-armory/files/patch-dpkgfiles_armory
index 6dee3d9d41c7..5b1d6912bdd1 100644
--- a/finance/bitcoin-armory/files/patch-dpkgfiles-armory
+++ b/finance/bitcoin-armory/files/patch-dpkgfiles_armory
@@ -1,4 +1,4 @@
---- dpkgfiles/armory
+--- dpkgfiles/armory.orig 2015-06-10 21:49:31 UTC
+++ dpkgfiles/armory
@@ -1,2 +1,2 @@
#!/bin/sh
diff --git a/finance/bitcoin-armory/pkg-message b/finance/bitcoin-armory/pkg-message
index f851607d153b..9af97b7fd70f 100644
--- a/finance/bitcoin-armory/pkg-message
+++ b/finance/bitcoin-armory/pkg-message
@@ -1,11 +1,11 @@
-
================================================================
BitcoinArmory consumes significant disk space in ~/.armory
and ~/.bitcoin, so you need to provide sufficient available
-space there, currently >30 gigabytes.
+space there, currently >50 gigabytes.
-Please note that BitcoinArmory has an embedded bitcoind, and
-doesn't require the running bitcoind, but can optionally use it.
+Please note that BitcoinArmory requires bitcoind daemon, so you
+need to have either net-p2p/bitcoin-daemon or net-p2p/bitcoin
+installed.
Please keep your *.wallet files located under the ~/.armory
directory secure. Loss of these files is equivalent to the loss
diff --git a/finance/bitcoin-armory/pkg-plist b/finance/bitcoin-armory/pkg-plist
index bb711ad973fe..0e04ecdf95bd 100644
--- a/finance/bitcoin-armory/pkg-plist
+++ b/finance/bitcoin-armory/pkg-plist
@@ -1,5 +1,4 @@
bin/armory
-lib/armory/ArmoryDB.py
lib/armory/ArmoryQt.py
lib/armory/BitTornado/BT1/Choker.py
lib/armory/BitTornado/BT1/Connecter.py
@@ -53,7 +52,7 @@ lib/armory/BitTornado/torrentlistparse.py
lib/armory/BitTornado/zurllib.py
lib/armory/CppBlockUtils.py
lib/armory/LICENSE.py
-lib/armory/README
+lib/armory/README.md
lib/armory/SDM.py
lib/armory/_CppBlockUtils.so
lib/armory/announcefetch.py
@@ -87,6 +86,9 @@ lib/armory/bitcoinrpc_jsonrpc/json.py
lib/armory/bitcoinrpc_jsonrpc/proxy.py
lib/armory/default_bootstrap.torrent
lib/armory/dynamicImport.py
+lib/armory/extras/BDMbasics_listUTXOs.py
+lib/armory/extras/BDMbasics_traceTxHistory.py
+lib/armory/extras/BDMbasics_watchBalance.py
lib/armory/extras/LastBlockHash.py
lib/armory/extras/LatestBlocksFinder.py
lib/armory/extras/PromoKit.py
@@ -122,6 +124,7 @@ lib/armory/pytest/testArmoryDTiab.py
lib/armory/pytest/testArmoryEngineUtils.py
lib/armory/pytest/testDecorators.py
lib/armory/pytest/testFragmentedBackup.py
+lib/armory/pytest/testJasvet.py
lib/armory/pytest/testMultisig.py
lib/armory/pytest/testParseAnnounce.py
lib/armory/pytest/testPyBtcAddress.py
@@ -130,6 +133,7 @@ lib/armory/pytest/testPyBtcWalletRecovery.py
lib/armory/pytest/testPyTX.py
lib/armory/pytest/testSplitSecret.py
lib/armory/pytest/testUserAddress.py
+lib/armory/pytest/testUtility.py
lib/armory/qrc_img_resources.py
lib/armory/qrcodenative.py
lib/armory/qt4reactor.py
@@ -146,7 +150,6 @@ lib/armory/txjsonrpc/web/__init__.py
lib/armory/txjsonrpc/web/jsonrpc.py
lib/armory/ui/MultiSigDialogs.py
lib/armory/ui/MultiSigModels.py
-lib/armory/ui/TxConstruct.py
lib/armory/ui/TxFrames.py
lib/armory/ui/UpgradeDownloader.py
lib/armory/ui/VerifyOfflinePackage.py
@@ -154,6 +157,7 @@ lib/armory/ui/WalletFrames.py
lib/armory/ui/Wizards.py
lib/armory/ui/__init__.py
lib/armory/ui/toolsDialogs.py
+lib/armory/update_version.py
lib/armory/urllib3/__init__.py
lib/armory/urllib3/_collections.py
lib/armory/urllib3/connection.py
@@ -194,9 +198,6 @@ share/armory/img/armory256x256.ico
share/armory/img/armory32x32.ico
share/armory/img/armory48x48.ico
share/armory/img/armory64x64.ico
-share/armory/img/armory_icon_24x24.png
-share/armory/img/armory_icon_32x32.png
-share/armory/img/armory_icon_64x64.png
share/armory/img/armory_icon_fullres.icns
share/armory/img/armory_icon_fullres.png
share/armory/img/armory_icon_green_24x24.png
@@ -312,3 +313,6 @@ share/armory/img/visible.png
share/armory/img/visible2.png
share/armory/img/wallet_16x12.png
share/armory/img/x-office-address-book.png
+share/icons/hicolor/24x24/apps/armoryicon.png
+share/icons/hicolor/32x32/apps/armoryicon.png
+share/icons/hicolor/64x64/apps/armoryicon.png