aboutsummaryrefslogtreecommitdiffstats
path: root/finance/bitcoin-armory
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-02-04 21:37:15 +0800
committertcberner <tcberner@FreeBSD.org>2017-02-04 21:37:15 +0800
commit614efcf540e295f5c397c15efa09c57cf6f129d1 (patch)
treed3572a824910587e038d1100b5972b19f37005aa /finance/bitcoin-armory
parent456af42702b83f7d7a579791394af005ff85204e (diff)
downloadfreebsd-ports-gnome-614efcf540e295f5c397c15efa09c57cf6f129d1.tar.gz
freebsd-ports-gnome-614efcf540e295f5c397c15efa09c57cf6f129d1.tar.zst
freebsd-ports-gnome-614efcf540e295f5c397c15efa09c57cf6f129d1.zip
Switch ports to use USE_PYQT=<foo> instead of using RUN_- and BUILD_DEPENDS
pyqt.mk provides USE_PYQT=<list> to depend on its components. Convert the ports not yet using it to it. Reviewed by: rakuco, mat Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D9261
Diffstat (limited to 'finance/bitcoin-armory')
-rw-r--r--finance/bitcoin-armory/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/finance/bitcoin-armory/Makefile b/finance/bitcoin-armory/Makefile
index c47797523259..d97686a29c5b 100644
--- a/finance/bitcoin-armory/Makefile
+++ b/finance/bitcoin-armory/Makefile
@@ -15,16 +15,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:devel/swig30 \
${LOCALBASE}/bin/pyrcc4:textproc/py-qt4-xml \
${LOCALBASE}/bin/rsync:net/rsync
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT4_VERSION}:devel/py-qt4-core \
- ${PYTHON_PKGNAMEPREFIX}qt4-gui>=${PYQT4_VERSION}:x11-toolkits/py-qt4-gui \
- ${PYTHON_PKGNAMEPREFIX}twistedCore>=14.0.0:devel/py-twistedCore \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twistedCore>=14.0.0:devel/py-twistedCore \
${PYTHON_PKGNAMEPREFIX}psutil>1.2.1:sysutils/py-psutil \
${LOCALBASE}/bin/bitcoind:net-p2p/bitcoin-daemon
USE_GITHUB= yes
GH_ACCOUNT= etotheipi
-USES= compiler:c++11-lang compiler:c++11-lib gmake python:2 shebangfix
+USES= compiler:c++11-lang compiler:c++11-lib gmake pyqt:4 python:2 shebangfix
+USE_PYQT= core_run gui_run
SHEBANG_FILES= extras/extractKeysFromWallet.py
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib