aboutsummaryrefslogtreecommitdiffstats
path: root/finance/bitcoin-armory
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-06-09 22:18:09 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-06-09 22:18:09 +0800
commit75143ca2743e4d0c4e920904e86c796509b813c3 (patch)
treee3a7d82f2244547acb1886fe2999ff296bf15656 /finance/bitcoin-armory
parent05edd0f86c29c581bd2dd500b2c3d076aecf317d (diff)
downloadfreebsd-ports-gnome-75143ca2743e4d0c4e920904e86c796509b813c3.tar.gz
freebsd-ports-gnome-75143ca2743e4d0c4e920904e86c796509b813c3.tar.zst
freebsd-ports-gnome-75143ca2743e4d0c4e920904e86c796509b813c3.zip
Fix shebang
- While I'm here, pet portlint - Bump PORTREVISION for package change Approved by: portmgr (blanket)
Diffstat (limited to 'finance/bitcoin-armory')
-rw-r--r--finance/bitcoin-armory/Makefile4
-rw-r--r--finance/bitcoin-armory/files/patch-ArmoryQt.py6
2 files changed, 2 insertions, 8 deletions
diff --git a/finance/bitcoin-armory/Makefile b/finance/bitcoin-armory/Makefile
index 1190795c0ce8..90f0833950d9 100644
--- a/finance/bitcoin-armory/Makefile
+++ b/finance/bitcoin-armory/Makefile
@@ -3,8 +3,8 @@
PORTNAME= BitcoinArmory
PORTVERSION= 0.93.3
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= finance
MAINTAINER= yuri@rawbw.com
@@ -25,7 +25,7 @@ GH_ACCOUNT= etotheipi
USES= compiler:c++11-lang compiler:c++11-lib gmake pyqt:4 python:2 shebangfix
USE_PYQT= core_run gui_run
-SHEBANG_FILES= extras/extractKeysFromWallet.py
+SHEBANG_FILES= ArmoryQt.py extras/extractKeysFromWallet.py
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM -fPIC
diff --git a/finance/bitcoin-armory/files/patch-ArmoryQt.py b/finance/bitcoin-armory/files/patch-ArmoryQt.py
index 08a786d2edf7..92330d521347 100644
--- a/finance/bitcoin-armory/files/patch-ArmoryQt.py
+++ b/finance/bitcoin-armory/files/patch-ArmoryQt.py
@@ -1,11 +1,5 @@
--- ArmoryQt.py.orig 2015-06-10 21:49:31 UTC
+++ ArmoryQt.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/python
-+#!/usr/bin/env python
- # -*- coding: UTF-8 -*-
- ################################################################################
- # #
@@ -1236,6 +1236,9 @@ class ArmoryMainWindow(QMainWindow):
elif OS_LINUX:
tempDir = '/var/log'