aboutsummaryrefslogtreecommitdiffstats
path: root/finance/cbb/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-08-06 06:42:24 +0800
committererwin <erwin@FreeBSD.org>2006-08-06 06:42:24 +0800
commit37f0e4bf7397fd430b15501465957bf0d9fba147 (patch)
tree429c7367a4ccca44ac19bd15398be6494c788784 /finance/cbb/Makefile
parentfd230796db30d638283b5454f067abef71c2aa88 (diff)
downloadfreebsd-ports-gnome-37f0e4bf7397fd430b15501465957bf0d9fba147.tar.gz
freebsd-ports-gnome-37f0e4bf7397fd430b15501465957bf0d9fba147.tar.zst
freebsd-ports-gnome-37f0e4bf7397fd430b15501465957bf0d9fba147.zip
Fix install after DESTDIR patch.
Submitted by: gabor
Diffstat (limited to 'finance/cbb/Makefile')
-rw-r--r--finance/cbb/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/finance/cbb/Makefile b/finance/cbb/Makefile
index a4daec6644ca..60db6609bdde 100644
--- a/finance/cbb/Makefile
+++ b/finance/cbb/Makefile
@@ -18,7 +18,17 @@ RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
NO_BUILD= yes
USE_PERL5= yes
-MAKE_ENV= PERL5=${PERL5}
GNU_CONFIGURE= yes
+post-patch:
+ @${REINPLACE_CMD} -e "s|PERL = /usr/bin/perl|PERL = ${PERL5}|" \
+ -e "s|WISH = /usr/bin/wish|WISH = ${LOCALBASE}/bin/wish8.2|" \
+ -e "s|DESTDIR =||" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} "s|DESTDIR =||" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|$$destdir/bin|$$destdir/$$prefix/bin|' \
+ -e 's|$$destdir/lib/cbb|$$destdir/$$prefix/lib/cbb|' \
+ ${WRKSRC}/install.pl
+ @${REINPLACE_CMD} -e "s|=wish|=wish8.2|" -e 's|=""wish""|=""wish8.2""|' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>