aboutsummaryrefslogtreecommitdiffstats
path: root/finance/gnucash/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-02-18 05:24:43 +0800
committermarcus <marcus@FreeBSD.org>2003-02-18 05:24:43 +0800
commit063b8c0fbb18413c796418eeb3a371d8ff5a586c (patch)
tree619cb876423e517c51e5aa4a17c1e5f905581931 /finance/gnucash/Makefile
parent13dd7832ff9879b17b3628a6b382c8963bdee805 (diff)
downloadfreebsd-ports-gnome-063b8c0fbb18413c796418eeb3a371d8ff5a586c.tar.gz
freebsd-ports-gnome-063b8c0fbb18413c796418eeb3a371d8ff5a586c.tar.zst
freebsd-ports-gnome-063b8c0fbb18413c796418eeb3a371d8ff5a586c.zip
* Add a dependency on libofx as well as a missing Perl module dependency [1]
* Update plist to satisfy portlint PR: 48360 [1] Submitted by: Glenn Johnson <glennpj@charter.net> [1]
Diffstat (limited to 'finance/gnucash/Makefile')
-rw-r--r--finance/gnucash/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 4c985aad6d6e..9d6a1eefa2ce 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnucash
PORTVERSION= 1.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance gnome
MASTER_SITES= http://www.gnucash.org/pub/gnucash/sources/stable/ \
ftp://ftp.gnucash.org/pub/gnucash/sources/stable/ \
@@ -20,13 +20,15 @@ MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile \
guppi.16:${PORTSDIR}/math/guppi \
popt.0:${PORTSDIR}/devel/popt \
+ ofx.0:${PORTSDIR}/finance/libofx \
db4.0:${PORTSDIR}/databases/db4 \
gw-standard.0:${PORTSDIR}/devel/g-wrap
RUN_DEPENDS= ${LOCALBASE}/share/slib/Template.scm:${PORTSDIR}/lang/slib \
${site_perl}/HTML/Base.pm:${PORTSDIR}/www/p5-HTML \
${site_perl}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${site_perl}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${site_perl}/Finance/Quote.pm:${PORTSDIR}/misc/p5-Finance-Quote
+ ${site_perl}/Finance/Quote.pm:${PORTSDIR}/misc/p5-Finance-Quote \
+ ${site_perl}/Finance/QuoteHist.pm:${PORTSDIR}/misc/p5-Finance-QuoteHist
site_perl= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
@@ -40,6 +42,7 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-glib-config=${GLIB_CONFIG} \
+ --enable-ofx \
--disable-error-on-warning
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lintl"